搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox will not save the password unless I enter the wrong one!

  • 4 回覆
  • 1 有這個問題
  • 49 次檢視
  • 最近回覆由 Dominic108

more options

The password was already saved, but it was incorrect. When I entered the new correct password, it did not ask to save it. I checked if there was an exception for the site and there was none. I started Firefox with add-ons disabled and it did not help. I removed the saved incorrect password and it did not help either.

Solution: I entered a wrong password and then Firefox asked to save it. Fortunately, the option was offered to show and edit the password before saving it. So, entered the correct password and saved it. The next time I tried to login, the correct saved password was available.

Explanation: I have no idea. It's weird. Somehow, Firefox did not recognize the correct password as a new password to save. I had to enter a different (and incorrect) password to trigger the mechanism used to save the password.

被選擇的解決方法

Note that you can double-click user name and password field in the Password Manager to edit their values.

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"
從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

An easier solution would have been to go the password manager (menu -> Preferences -> Privacy and Security -> Saved Logins), then ask to show the password and right click on the password to edit it.

more options

選擇的解決方法

Note that you can double-click user name and password field in the Password Manager to edit their values.

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"
more options

Did you make sure that there isn't aren't multiple version of this password stored? You can filter the Password Manager for the URL (domain) of the website.

more options

I checked that and there was only one password stored for the site and it was an incorrect password. Yep, very weird that it would not ask to save the new correct password. Yes, the simple solution was to right click (or double click?) on the password in the password manager to change it. I realized that after.