搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I want to open my new tab to my home page, not the tiles or blank page

  • 6 回覆
  • 5 有這個問題
  • 522 次檢視
  • 最近回覆由 ccfred

more options

I upgraded to Firefox 41.01 and now when I open a new tab I only have the option of tiles (which I do not want) or a completely blank page. I want the new tab to open to my homepage, not the suggested tiles or a blank page.

被選擇的解決方法

Firefox 41 no longer uses the browser.newtab.url setting in about:config because it was constantly attacked by malware. Starting in Firefox 41, you need an add-on to change the new tab page.

Here are some options (I learn of more all the time):

  • If you already use either the "Classic Theme Restorer" or "Tab Mix Plus" extension: There is an option somewhere (!) in its extensive settings dialogs to select a different new tab page.

Please only use one of these methods at a time, otherwise there may be conflicts and dysfunctionality.

Setting up New Tab Override and Custom New Tab

After installing one of these extensions, you need to use its Options page to set the desired new tab page (instead of using about:config).

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override or Custom New Tab and click its Options button. (See first screen shot attached.)

New Tab Override

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.

Custom New Tab

Entering your preferred home page address is simple. If you do not check either of the boxes, the extension will set the focus in the page so, for example, the cursor will be in the Google search box. (See third screen shot attached.) I had to exit Firefox and start it up again before Custom New Tab started working, but this may have been due to testing so many extensions back-to-back.

Success?

從原來的回覆中察看解決方案 👍 3

所有回覆 (6)

more options

選擇的解決方法

Firefox 41 no longer uses the browser.newtab.url setting in about:config because it was constantly attacked by malware. Starting in Firefox 41, you need an add-on to change the new tab page.

Here are some options (I learn of more all the time):

  • If you already use either the "Classic Theme Restorer" or "Tab Mix Plus" extension: There is an option somewhere (!) in its extensive settings dialogs to select a different new tab page.

Please only use one of these methods at a time, otherwise there may be conflicts and dysfunctionality.

Setting up New Tab Override and Custom New Tab

After installing one of these extensions, you need to use its Options page to set the desired new tab page (instead of using about:config).

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override or Custom New Tab and click its Options button. (See first screen shot attached.)

New Tab Override

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.

Custom New Tab

Entering your preferred home page address is simple. If you do not check either of the boxes, the extension will set the focus in the page so, for example, the cursor will be in the Google search box. (See third screen shot attached.) I had to exit Firefox and start it up again before Custom New Tab started working, but this may have been due to testing so many extensions back-to-back.

Success?

more options

I had the same problem as Arpig

---

Thank You jscher2000!

Here is what I've done...

Tools

Classic Theme Retorer - 1.4.0

Tabs (1)

...half way down...

New tab page url

(x) Custom new tab page url (deafult: "about:newtab")

[ Your home page here e.g. https://www.google.com/?gws_rd=ssl ]

Dave Hartman

由 mr_speedlight 於 修改

more options

Hi mr_speedlight (Dave), this is purely cosmetic, but you only need https://www.google.com/ -- you can remove the ?gws_rd=ssl (Google adds that to indicate you originally tried to access without a secure connection, on http://www.google.com/ and it redirected you to a secure connection)

more options

I am having the same issue. When I open a new tab, it opens at a blank page. I want Google (my 1st home page) . I tried "Custom New Tab" and "New Tab Override" but neither worked - Google comes up BUT cursor stayed in the address bar at top of screen - I want it at the Google Search bar.

more options

ccfred said

I tried "Custom New Tab" and "New Tab Override" but neither worked - Google comes up BUT cursor stayed in the address bar at top of screen - I want it at the Google Search bar.

There is an option in Custom New Tab to take care of that. To avoid conflicts, disable New Tab Override, then check the Options for Custom New Tab.

Actually, I haven't looked at it for several months, but here's an old screenshot showing where that checkbox is/was:

Has that stopped working?

more options

Problem SOLVED... I re-looked at "Custom New Tab" and found I had missed the small OPTIONS box at bottom left. That allows options that resolve this issue. See attachments.

Solved my own problem.

PS... While was entering this message, jscher2000 added the same solution. Thanks.

由 ccfred 於 修改