搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

User/Passwords no longer autofilled

  • 11 回覆
  • 19 有這個問題
  • 448 次檢視
  • 最近回覆由 gosssamer

more options

Hi, I'm using firefox-37.0.1 on fedora20 and for about the last week or so, input fields that previously would have been autofilled with username and password now do not. I can double-click on the input field to choose a username from a list, but it does not complete with the password when selected.

The username and password are stored in the password manager, but not automatically entered by firefox.

After entering the correct username and password, it also doesn't prompt to store these automatically either.

I really don't have any idea what could have changed to cause this problem.

Any help greatly appreciated. Thanks, Dave

所有回覆 (11)

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

cor-el said

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).
  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Thanks so much for your help.

I checked that I wasn't in Private Browsing mode. I also restarted in Safe Mode (in safe mode as I type), and not only did firefox not supply the login info for this forum, it also didn't prompt me to save it once entered.

Other ideas?

more options

What is the value of the signon.autofillForms pref on the about:config page?

more options

cor-el said

What is the value of the signon.autofillForms pref on the about:config page?

I meant to mention in my initial post that I checked that and the value is 'true'.

I've also visited a handful of other sites that have my user/pass stored in the password manager yet don't autofill them when logging in.

Thank you.

由 gosssamer 於 修改

more options

Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager).

You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password. There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that.


You can try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

cor-el said

Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager). You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password.

I've done this, and it still doesn't provide user/pass or save them when manually entered again.

There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that.

Just to be clear, it simply is not providing any previously entered user/pass in fields where this used to be done automatically, even after double-clicking in the input field.

You can try to create a new profile as a test to check if your current profile is causing the problem.

I've created a new profile, and it does then prompt to save my user/pass in the same site where it previously does not. It also autofills the user/pass when going back a second time.

Does this mean my only recourse is to rebuild my profile, or are there other possible solutions?

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (key3.db and logins.json).

If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward.

Check that the exported (xml) file has all the names and passwords.

more options

cor-el said

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

The user.js file is dated Nov 2009, and the problem only recently started.

It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action.

We went through this already, and it doesn't appear to be related to these files. I renamed them and restarted firefox. Accessing a site I know to have previously stored my password now does not.

I also restarted in safe mode with these new key3.db and logins.json files, and it still doesn't save my passwords.

If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward.

Is there no more troubleshooting that can be done at this point? Is it necessary to export my passwords, create a new profile, then migrate my passwords, bookmarks, history, etc?

What about my open tabs? I have hundreds of open tabs that I can't lose. Do I also just bookmark them and restore them in the new profile?

more options

What is the content of the user.js file (right-click: Open with: Notepad; do not double-click)?

Did you create this user.js file yourself back in 2009?

more options

It only contains the following text:

user_pref("yahoo.homepage.dontask", true);

I don't believe I created it.

You'll also recall signon.autofillforms is true.

more options

Does no one have any other ideas? Or am I missing something in an explanation?

I really don't want to go through the whole profile rebuild process. Does anyone at least able to identify where the actual problem/cause is?