搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why can't firefox save the favicons for websites in bookmarks?

  • 2 回覆
  • 5 有這個問題
  • 46 次檢視
  • 最近回覆由 pcguy

more options

In Firefox 35.0.1 on Windows 7 x64 I have several issues concerning icons. None of the bookmarks on the bookmark toolbar toolbar or in the booksmarks have any of the Favicons/icons showing up for the website even though I have visited a few of these sites. All I see is little squares outlined in dashes.

Also the New Tab page is not show screen snapshots of sites even after I vist them. I only have 2 websites of the 15 sites on the new tab page. The rest of the squares are empty with squares.

This is happening even after creating a new profile, clearling cache.

In Firefox 35.0.1 on Windows 7 x64 I have several issues concerning icons. None of the bookmarks on the bookmark toolbar toolbar or in the booksmarks have any of the Favicons/icons showing up for the website even though I have visited a few of these sites. All I see is little squares outlined in dashes. Also the New Tab page is not show screen snapshots of sites even after I vist them. I only have 2 websites of the 15 sites on the new tab page. The rest of the squares are empty with squares. This is happening even after creating a new profile, clearling cache.

被選擇的解決方法

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

從原來的回覆中察看解決方案 👍 2

所有回覆 (2)

more options

選擇的解決方法

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Ok thanks for the help. Seems that the websites I was having problems with in fact do not have favicons. Duh

Regarding the new tab page thumbnails not populating, I discovered that indeed it was an extension causing the problem. The extension is NoScript and even though NoScript gave no indication that it was blocking scripts it was.

I came across this thread in the Noscript forums describing the problem https://forums.informaction.com/viewtopic.php?f=7&t=20521

The solution is that one has to go to about:config in Firefox and if you do not have the following key then you need to insert a boolean key:

noscript.bgThumbs.allowed

and set it to True. Once that is done the thumbnails populate properly.

由 pcguy 於 修改