搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube videos won't load after updating Flash; audio only with HTML5

  • 4 回覆
  • 1 有這個問題
  • 216 次檢視
  • 最近回覆由 lageographe

more options

I'm running Firefox 34 on Mac OSX Yosemite (10.10). I just updated Flash Player, which is now listed in the add-ons bar as Shockwave 15.0.0.189. Now YouTube videos won't load at all - there's just an empty black box in the video player. I'm also running Adblock Plus 2.6.5 and Flashblock 1.5.17, and have tried disabling both of these, but it doesn't make a difference. I've updated Firefox, uninstalled and reinstalled Flash Player, cleared the cache, and restarted the browser several times with no effect.

YouTube videos play properly in Safari, so I don't think it's a problem with Flash Player. In Firefox, I tried switching to HTML5 for YouTube videos, using the YouTube All HTML5 2.1.3 add-on, but this only allows YouTube to play the audio - the video seems to be missing, and the screen remains black the whole time.

Any help will be much appreciated!

所有回覆 (4)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Hi Debapriya - thanks for this! However, I didn't have hardware acceleration enabled.

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: After resetting Firefox, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Reset Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Reset Firefox" that looks like this: Button reset . Click on it.
  3. Firefox will close and reset. After it is done, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Hi Debapriya - resetting Firefox worked out well! I reinstalled Flashblock afterwards, which caused YouTube to stop working entirely again, but when I disabled Flashblock it began working perfectly. Don't know why disabling Flashblock didn't solve the problem the first time. Anyway, thanks again for your help!