Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube in the hosts file is ignored since version 125.0b1 Developer edition

  • 2 iimpendulo
  • 0 inale ngxaki
  • 29 views
  • Impendulo yokugqibela ngu juandhdez94

more options

It doesn't matter if I add www.youtube.com site to hosts file in Linux and delete cache, Firefox just doesn't block it, bypassing my meassures to prevent me to get hooked up here. It was blocking everything as expected some weeks ago. I also tried redirecting to different IP's and it didn't work.

After some checks, I noticed:

  • It happens only with www.youtube.com, it doesn't happen with youtube.com (without www)
  • Other common pages like other Google pages, Facebook, TikTok or Instagram, get succesfuly blocked by hosts file as expected
  • I have tested creating new profiles with about:profiles, but the issue continues
  • The issue started after Firefox Developer Edition version 125.0b1 as you may notice in the images attached.
  • I also tested with the latest nigthly version and the issue continues.
  • DNS over HTTP (DOH) doesn't seems to be the problem since it seems that my network doesn't met the requirements to enable it, and if I manually make sure it's disabled, the issue still continues.
  • Chromium browser blocks www.youtube.com as expected, so that indicates my PC might be correctly configured
It doesn't matter if I add www.youtube.com site to hosts file in Linux and delete cache, Firefox just doesn't block it, bypassing my meassures to prevent me to get hooked up here. It was blocking everything as expected some weeks ago. I also tried redirecting to different IP's and it didn't work. After some checks, I noticed: * It happens only with www.youtube.com, it doesn't happen with youtube.com (without www) * Other common pages like other Google pages, Facebook, TikTok or Instagram, get succesfuly blocked by hosts file as expected * I have tested creating new profiles with about:profiles, but the issue continues * The issue started after Firefox Developer Edition version 125.0b1 as you may notice in the images attached. * I also tested with the latest nigthly version and the issue continues. * DNS over HTTP (DOH) doesn't seems to be the problem since it seems that my network doesn't met the requirements to enable it, and if I manually make sure it's disabled, the issue still continues. * Chromium browser blocks www.youtube.com as expected, so that indicates my PC might be correctly configured
Iqhotyoshelwe imifanekiso ekwisikrini

Isisombulu esikhethiweyo

Try changing network.dns.native_https_query to false in about:config.

Funda le mpendulo kwimeko leyo 👍 1

All Replies (2)

more options

Isisombululo esiKhethiweyo

Try changing network.dns.native_https_query to false in about:config.

Helpful?

more options

zeroknight said

Try changing network.dns.native_https_query to false in about:config.

Thanks, yes, that makes youtube to get blocked. Just a question, Do you know if it's intended that this happen only with www.youtube.com? Or should it have a ticket or something to fix it?

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.