Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã giải quyết
  • Đã lưu trữ

userChrome.css to disable blue highlight marker on active tab

I am using tab-on-bottom code in userChrome.css that I got from the web. 1. There is a highlight feature of the tabs. A mouse-over will do a subtle enhancement of the top… (xem thêm)

I am using tab-on-bottom code in userChrome.css that I got from the web.

1. There is a highlight feature of the tabs. A mouse-over will do a subtle enhancement of the top portion of the line delineating of the tab. 2. The active tab has a blue bar at the top portion of the line delineating the tab.

I want both to go away. I have code to highlight the background color of the active tab and need no other highlight function.

The userChrome.css is below.

Thanks, Gert

/* TABS: bottom - Firefox 65 and newer; should for now work with XUL @namespace */


  1. TabsToolbar {
 -moz-box-ordinal-group: 1000 !important;
 display: block !important;
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;

}

  1. tabbrowser-tabs {
 width: 100vw !important;

}

  • |*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
 padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/

}

/* position Tab bar with Menu bar and Title bar hidden for Firefox 65-73 - omit in Firefox Nightly */

  • |*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
  1. toolbar-menubar[autohide="true"] ~ #xTabsToolbar{
 bottom: var(--tab-min-height) !important;
 padding-top: calc(var(--tab-min-height) - 0px) !important; /*adjust*/

}

/* TABS: height */

  • |*:root {
 --tab-toolbar-navbar-overlap: 0px !important;
 --tab-min-height: 30px !important; /*adjust to set height or omit to use density*/
 --tab-min-width:  80px !important; /*adjust to set width or omit to use default*/

}

  1. TabsToolbar {
 height: var(--tab-min-height) !important;
 margin-bottom: -0px !important; /*adjust*/
 background-color: #F5F6F7 !important;

}


/* caption buttons - hide */

  • |*:root[tabsintitlebar]:not([inFullscreen="true"])
#toolbar-menubar[autohide="true"] ~ #TabsToolbar
.titlebar-buttonbox-container {display: none !important;}

/* Change Color of active tab */ .tab-background[selected="true"] {

   background-color: #A8FFAD !important;
   background-image: none !important;

}

/* Rounded corners on tabs firefox 58 */ /* http://forums.mozillazine.org/viewtopic.php?f=38&t=3037688# */ .tabbrowser-tab::after, .tabbrowser-tab::before {

  border-left: none !important;

} .tab-background {

 border-radius: 6px 6px 6px 6px !important;
 border-image: none !important;
 border-left: 1px solid !important;
 border-right: 1px solid !important;
 border-top: 1px solid !important;
 border-width: 1px !important;
 border-color: #000080 !important;
 background-attachment: none!important;
 background-color: #DAD7D0 !important;
 background-image: none !important;

}

/* Menu bar (File Edit View) height and background color */

  1. toolbar-menubar, #menubar-items, #main-menubar {
 height: 30px !important;
 background-color: #DAD7D0 !important;
 background-image: none !important;
 font-size: 14px !important;

}

/* Menu bar (File Edit View) text color */ .menubar-text, .tabbrowser-tab:not([selected="true"]) tab-label {

 color: #080808 !important;

}

/* Use Normal top and bottom padding for Compact */

  1. PlacesToolbarItems .bookmark-item {
 padding-top: 10px !important;
 padding-bottom: 6px !important;

}

Đã được hỏi bởi drgert1 2 năm trước

Đã được trả lời bởi jscher2000 - Support Volunteer 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Cannot update self-hosted add-on due to "Certificate issuer is not built-in" error

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not h… (xem thêm)

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not hosted on AMO.

I am on the latest version of Fedora running Firefox 81.0. In the browser console I get this error relating to the URL for the addon when I tell Firefox to check for updates: "Certificate issuer is not built-in".

I have the company CA installed and when I navigate to the site in the browser, Firefox recognizes the cert. I've done some reading on the subject and seen several threads about it. I've tried a few things already, but most of the threads where a couple of years old.

I'm asking the question here hoping to figure out what the current state of the problem is and which settings I should tweak to have it trust the company CA or what my options are.

Thank you in advance for any support on the issue.

Đã được hỏi bởi bplaxco 2 năm trước

Đã được trả lời bởi bplaxco 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

disable app update

Hi, I'm used to deploying/configuring Firefox in an organization with settings in autoconfig.js, etc. Recently, I've seen that some settings are honored, others aren't, s… (xem thêm)

Hi,

I'm used to deploying/configuring Firefox in an organization with settings in autoconfig.js, etc. Recently, I've seen that some settings are honored, others aren't, so I started using policies.json as well as keeping my autoconfig.js. Can they work together?

In any case, I am unable to disable app update with either of them. I have the following in policies.json:

{

   "policies": {

"DisableFirefoxAccounts": true, "DisablePocket": true,

       "DisableAppUpdate": true,

"DontCheckDefaultBrowser": true, "DNSOverHTTPS": { "Enabled": false }, "Certificates": { "ImportEnterpriseRoots": true } "PopupBlocking": { "Allow": ["http://10.215.144.56:8080", "https://intranet.mydomain.org"], "Default": true | false, "Locked": true | false }

   }

}

I'm also showing a snippet of my autoconfig.js file:

lockPref("app.update.auto", false); lockPref("app.update.enabled", false); lockPref("app.update.mode", 0); lockPref("app.update.service.enabled", false); lockPref("app.update.disable_button.showUpdateHistory", false); lockPref("app.update.url", ""); lockPref("app.update.url.details", ""); lockPref("app.update.url.manual", ""); lockPref("signon.rememberSignons", false); lockPref("extensions.update.enabled", false);

The problem is that when I start Firefox 78.3.0 ESR and go to the about Firefox window, I can see that the app update is not disabled.

How can I make sure that all the above settings in autoconfig.js are actually honored?

Thanks

Đã được hỏi bởi vieri 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Updated to Firefox 81. Problem accessing my gmail account so reset Firefox. In Options " Your browser is being managed by your organisation." and I am unable to set a Primary Password. I have no Organization.

How can I take back control of my Firefox from the "Organization"?

Đã được hỏi bởi JoeBristol26 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Fermer plusieurs onglet

Hi, Je n'ai pas trouvé dans About:Config une option pour revenir au fonctionnement précédent avec les options fermer les onglets Fermer les onglets directement accessible… (xem thêm)

Hi,

Je n'ai pas trouvé dans About:Config une option pour revenir au fonctionnement précédent avec les options fermer les onglets Fermer les onglets directement accessibles comme c'est toujours le cas dans Chrome (Voir PJ).

J'utilise beaucoup ces options et je déplore d'avoir à passer par un menu intermédiaire.

Cdt

JPS

Đã được hỏi bởi YBSalaun 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Main menu opens, showing up to the right, partly/mostly out of my screen

I'm using OpenSuSE Leap 15.2 , updated Firefox these days, and now when I click on the menu, it opens and shows up to the right, out of the screen (when maximized). Also … (xem thêm)

I'm using OpenSuSE Leap 15.2 , updated Firefox these days, and now when I click on the menu, it opens and shows up to the right, out of the screen (when maximized). Also when I hover over options close to the right edge of the screen, the bubbles show partly out of the screen, same as the main menu. I've tried Refresh, Safe Mode, downgrading to a previous version, but nothing helps now Mind the menu on the screenshot.

Any ideas?

best, Istvan

Đã được hỏi bởi Pityucount 2 năm trước

Đã được trả lời bởi Pityucount 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Is there any way to hide site status indications?

So Firefox shows site status indications in the lower left corner. I don't know the technical term, since it's not just the one site I've allowed to send notifications. O… (xem thêm)

So Firefox shows site status indications in the lower left corner. I don't know the technical term, since it's not just the one site I've allowed to send notifications. On some pages, these contrast with the background. So these flash as the page loads, and they can flash again if the page tries to load something new every 30 seconds. I am photosensitive and flashing can hurt and I want to either block this or find some way to reduce the contrast, such as showing this in a continuous bottom panel.

Is there any way to block this? And what are they supposed to be called?

Đã được hỏi bởi MarjaE 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Capturing control of the add-on.

Why was one of the add-ons able to take over control of the entire browser and add-ons in it and establish its own rules? At the same time, it deleted all history and ope… (xem thêm)

Why was one of the add-ons able to take over control of the entire browser and add-ons in it and establish its own rules? At the same time, it deleted all history and open tabs and my profile (firefox) did not save anything and did not restore the current session after reinstalling the browser, although it is worth remembering the current session and tabs there. I tried to remove this add-on for a long time, but it blocked all possibilities to do it. The browser began to open with one tab with an incomprehensible address, which was not even displayed correctly, and any attempt to search for something led to the opening of an incomprehensible search engine, but it was possible to go to Google. I don’t remember the name of the search engine, alas, it was several months ago, there was still no time to write to you. Oh yes, on the screenshots everything is in Russian, I'm not sure that you can fully understand them, and if so, write to me about it and I will try to translate the key positions. I would be glad to hear at least some thoughts on this in my profile mail. Here are some screenshots:

Đã được hỏi bởi mr.andersan 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

About Mozilla Maintenance Service

Nice to meet you. I tried to enable the start of Mozilla Maintenance Service, I get an error saying "The fiction is wrong". Looking at the properties, the downloaded Mozi… (xem thêm)

Nice to meet you. I tried to enable the start of Mozilla Maintenance Service, I get an error saying "The fiction is wrong". Looking at the properties, the downloaded Mozilla Maintenance Service is x86. How do I get Mozilla Maintenance Service x 64?

Win 10 HOME 64bit system OS: 19041.508 is.

Đã được hỏi bởi 23tvam 1 năm trước

Đã được trả lời bởi FredMcD 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Deploying Firefox Enterprise on Linux

I use Firefox Enterprise on both Windows and macOS, this alone is the single reason why I gravitate towards Firefox the most, it might be even my main browser, I really d… (xem thêm)

I use Firefox Enterprise on both Windows and macOS, this alone is the single reason why I gravitate towards Firefox the most, it might be even my main browser, I really don't know which is since I have at least 2 opened at any given time, normally 3 or 4. The best part of it is that I don't have to set it up, it's all done. I use Firefox Sync just in case I use Firefox somewhere else, like a phone or Linux, or to push a page to another device (really, it's pulling the history bc push has never worked) but I can live without it.

When I use Firefox on Linux though, it's a night and day experience, it feels like I have to setup Firefox from scratch even after logging into Firefox Sync, it's only synced selectively mostly cares about useless stuff or stuff that I wouldn't let the browser save, like passwords, partly (but very little) because of privacy but mostly because I use a ton of browsers, I can't micromanage each. I even disable all of this via policy and that's what I'm looking to do, find how to deploy policies on Linux clients. I assume is just a config file like the preference list on Macs, even if it's not automated it should be easy to make available centrally a pull it on demand and drop it in the right place with some script but I have to find how's it done first and what settings will there be supported, none of that available in the documentation of Firefox Enterprise.

Fedora Server 32 now comes with an easy GUI for 389 DS (not FreeIPA for some reason) and a deployment tool for desktops both as Cockpit modules, which is also the GUI used by Red Hat in a lot of their products, OpenShift for instance. I wonder if I could use this to deploy Firefox settings. It even connects to Active Directory out of the box, if it could only process Windows policies... anyway. Is there some obscure documentation, maybe in beta, that goes over any of this?

Thanks.

Đã được hỏi bởi senseivita 2 năm trước

Đã được trả lời bởi Wesley Branton 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Quick Find

Every time I type on Firefox without being in a search box, it opens quick find, and I don't have to press control g/f. I want to know how to disable this from happening.… (xem thêm)

Every time I type on Firefox without being in a search box, it opens quick find, and I don't have to press control g/f. I want to know how to disable this from happening. I have search the internet and forums for hours but can't figure out how to disable one simple thing. Thanks

Đã được hỏi bởi tristanjmckean 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

firefox update hid my extensions/add-ons

I can't access my add-on anymore because you guys decided you wanted the look of my browser to change. They are all still installed, just now i can't change their sett… (xem thêm)

I can't access my add-on anymore because you guys decided you wanted the look of my browser to change. They are all still installed, just now i can't change their settings or access their menus. how do i revert the graphical part of this update?

Đã được hỏi bởi webmaster60 1 năm trước

Đã được trả lời bởi webmaster60 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Closing Browser Tabs

it used to be so easy to close multiple tabs in the previous version of Firefox. A right-click and the single key Would close either all other tabs for tabs to the right.… (xem thêm)

it used to be so easy to close multiple tabs in the previous version of Firefox. A right-click and the single key Would close either all other tabs for tabs to the right. I use it all the time.

New method that requires multiple mouse clicks and traversing a drop-down menu is clunky, time-consuming, and annoying. There's no reason both options couldn't be available at the same time.

Is there a way to submit a request for this in the next update?

Đã được hỏi bởi BillTreloar 1 năm trước

Đã được trả lời bởi jscher2000 - Support Volunteer 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

FF75: Disable urlbar expansion

Is there a preference to disable the expansion of the urlbar (aka address bar, awesome bar, mega bar) without disabling its new features? When expanded, it covers part of… (xem thêm)

Is there a preference to disable the expansion of the urlbar (aka address bar, awesome bar, mega bar) without disabling its new features? When expanded, it covers part of my bookmarks bar and makes it harder to click the bookmarks. Also I dislike the chunky UI look.

Things I've tried that did not solve my problem:

  • browser.urlbar.megabar: This is gone in 75.0.
  • browser.urlbar.update1: This disables the expansion, but also disables the new icons, suggestions, etc.
  • browser.urlbar.openViewOnFocus: I don't know what this does but it wasn't it.
  • ui.prefersReducedMotion: This disables the animation, but the bar is still expanded.
  • Search with the Firefox address bar: There is no information there about the expansion.

I'm hoping there is a browser.urlbar.update1.expand or similar that I can toggle off. If there definitely isn't, please confirm so I can submit a bug.

Đã được hỏi bởi P1h3r1e3d13 2 năm trước

Đã được trả lời bởi cor-el 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

"Plugins will be installed shortly" but never actually install (Widevine + H264)

Hi, Problem as described in the title. I've read some similar questions and answers, but nothing ever helped. I already tried the following steps (none of them helped): -… (xem thêm)

Hi,

Problem as described in the title. I've read some similar questions and answers, but nothing ever helped.

I already tried the following steps (none of them helped): - Checking for updates - Toggling DRM on/off - Uninstall Firefox completely (delete profiles, too and so on) - Changing some DRM or Plugin related config in about:config like media.peerconnection.video.h264 (and of course reverting it after that) - Looking for XHR requests when toggling DRM on/off or visting a site with DRM content. I couldn't figure out what I'm actually looking for, though... - Switching off Firewall/Antivirus or the TLS filtering (Eset) for a moment - Looking for suspicious requests in some router protocols or dashboards or whatever

Thanks in advance!

Đã được hỏi bởi Volatilize 2 năm trước

Đã được trả lời bởi bvandyk 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Opening a Command Terminal/Window

I am using a Linux/Ubuntu computer. I downloaded a program that instructs me to "Open a browser window" to enter certain commands. I am fairly new Linux user and am req… (xem thêm)

I am using a Linux/Ubuntu computer. I downloaded a program that instructs me to "Open a browser window" to enter certain commands. I am fairly new Linux user and am requesting assistance on how to open a Firefox browser "command" window and enter a Linux command.

Here is the program's URL: https://frontend.bredbandskollen.se/download/README.txt

See Item: --Browser

Thanks for your assistance!

Đã được hỏi bởi dwaggoner.phd 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Lost extensions

Hi everyone. I hope you can help me. I have installed one extension few days ago. Today i decided to refresh my browser by using mozilla button. After i did it, my extens… (xem thêm)

Hi everyone. I hope you can help me. I have installed one extension few days ago. Today i decided to refresh my browser by using mozilla button. After i did it, my extension is gone and i have a file on my deskop like "old data of firefox" saved. The thing is i need my extension back because i had there some important data that i haven't saved :/ Is it possible to restore my old browser the same as before i refreshed it? Please help !

Đã được hỏi bởi swierk.ubezpieczenia 1 năm trước

Đã được trả lời bởi swierk.ubezpieczenia 1 năm trước