Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

About:home search engine, how can i change it to DuckDuckGo?

  • 5 trả lời
  • 3 gặp vấn đề này
  • 3385 lượt xem
  • Trả lời mới nhất được viết bởi josh522

more options

I want to be able to use the DuckDuckGo search engine on the about:config page, but I've tried everything and I can't get it to work.

I have tried the following: 1. Creating a new Firefox profile with all the default settings, no extensions, plugins, custom settings, NOTHING. 2. made DuckDuckGo my default search engine in the search box 3. verified these settings in about:config

browser.search.selectedEngine;DuckDuckGo browser.search.order.1;DuckDuckGo browser.search.defaultenginename;DuckDuckGo

I have restarted the browser multiple times and all i get is a completely unresponsive search box on the about:home page. Nothing happens at all when i click the search button after i set browser.search.defaultenginename to DuckDuckGo.

Please help

Giải pháp được chọn

It must have been a problem with the search plugin.

My search plugin xml file now reads:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/spec/opensearch/1.1/">
<os:ShortName>DuckDuckGo</os:ShortName>
<os:Description>Search DuckDuckGo (SSL)</os:Description>
<os:InputEncoding>UTF-8</os:InputEncoding>
<os:Image width="16" height="16">data:image/x-icon;base64,*img data removed*</os:Image>
<os:Url type="text/html" method="GET" template="https://duckduckgo.com">
  <os:Param name="q" value="{searchTerms}"/>
  <os:Param name="kd" value="-1"/>
</os:Url>
</SearchPlugin>


The search-box works now!

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (5)

more options

Current Firefox versions use the default search engine (pref: browser.search.defaultenginename) to set the search engine that is used on the about:home page.

Check the browser.search.defaultenginename pref on the about:config page.

  • browser.search.defaultenginename

Currently selected search engine:

  • browser.search.selectedEngine

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

I've already tried all of that, but i tried it again just in case, and the search box still doesn't even function now. I can click search and nothing happens after i changed the browser.search.defaultenginename value to DuckDuckGo.

I've gotten it to change back to google, and i can even get it to change to yahoo, but for some reason when I try to use DuckDuckGo, it just breaks the search box.

help

more options

Do you have DuckDuckGo installed as one of the search engines for the search bar on the Navigation Toolbar?

more options

Yes, it's installed. Here's the xml file:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/"> <ShortName>DuckDuckGo</ShortName> <Description>Search DuckDuckGo (SSL HTML)</Description> <InputEncoding>UTF-8</InputEncoding> <Image width="16" height="16">data:image/x-icon;base64,*removed*</Image> <Url type="text/html" method="POST" template="https://duckduckgo.com/html/">

 <Param name="q" value="{searchTerms}"/>

</Url> </SearchPlugin>

more options

Giải pháp được chọn

It must have been a problem with the search plugin.

My search plugin xml file now reads:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/spec/opensearch/1.1/">
<os:ShortName>DuckDuckGo</os:ShortName>
<os:Description>Search DuckDuckGo (SSL)</os:Description>
<os:InputEncoding>UTF-8</os:InputEncoding>
<os:Image width="16" height="16">data:image/x-icon;base64,*img data removed*</os:Image>
<os:Url type="text/html" method="GET" template="https://duckduckgo.com">
  <os:Param name="q" value="{searchTerms}"/>
  <os:Param name="kd" value="-1"/>
</os:Url>
</SearchPlugin>


The search-box works now!

Được chỉnh sửa bởi cor-el vào