Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Font rendering issue in Windows 7 with Aero

  • 6 trả lời
  • 10 gặp vấn đề này
  • 3550 lượt xem
  • Trả lời mới nhất được viết bởi TheSilentOne

more options

I'm running Windows 7 Home Premium 64-bit, and using Firefox 19.0.2. Aero is enabled, but the ClearType font smoothing is turned off.

At completely random intervals, text is rendered like this in Firefox: http://i49.tinypic.com/vgshv4.png

Sometimes it can be fixed as simply as hovering the mouse pointer over the affected parts. Sometimes I have to mark the text to get it rendered correctly, and sometimes it can be fixed by scrolling the page.

It can happen on any sites with any encoding, regardless of the font size and color, but I noticed it's extremely rarely happens with Japanese text. It never affects the whole page, only random parts of the on-screen text, and sometimes the interface text as well. Also worth mentioning that it never happens when Aero is turned off.

Is this a Firefox bug, or is something wrong with my system? Thanks in advance.

Tất cả các câu trả lời (6)

more options

Try to disable hardware acceleration in Firefox.

more options

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

more options

Thank you all, but unfortunately, none of these have solved the issue.

When hardware acceleration is disabled, all the web page text looks terrible, and the interface text is barely readable.

Setting gfx.content.azure.enabled to false fixes the text problem, but introduces various other graphical glitches.

Setting gfx.direct2d.disabled to true has the same effect as disabling hardware accceleration.

My graphics drivers are up to date, and I use the default theme. The only extension I have is AdBlock Plus, and nothing changes if I remove or disable it.

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

more options
more options

Thanks very much, johndoe678! It solved the problem.

And of course, thank you all for your replies!