X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Sidebar is not persistent

Được đăng

FF 7.0.1 on Win7-64. I can enable the bookmarks sidebar (via menu or CTRL-B) but after closing and restarting FF it's gone again. I have already tried the suggestions from https://support.mozilla.com/en-US/kb/Preferences are not saved (no user.js, deleting prefs.js, fixing localstore.rdf) but nothing helped yet.

FF 7.0.1 on Win7-64. I can enable the bookmarks sidebar (via menu or CTRL-B) but after closing and restarting FF it's gone again. I have already tried the suggestions from https://support.mozilla.com/en-US/kb/Preferences are not saved (no user.js, deleting prefs.js, fixing localstore.rdf) but nothing helped yet.

Giải pháp được chọn

I think I finally got it to work. I have a second computer (same setup) where it works. So I compared the localstore.rdf files and found the problem.

 <RDF:Description RDF:about="chrome://browser/content/browser.xul#sidebar-box"
                  sidebarcommand="viewBookmarksSidebar"
                  width=""
                  src="chrome://browser/content/bookmarks/bookmarksPanel.xul" />

The sidebar was enabled but the width was empty so in effect disabled. Also closing a browser with the sidebar showing didn't change this value. After manually entering a value I can now open a new browser window with sidebar enabled.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 11.0 r1
  • 4.0.60831.0
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.660
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Thông tin chi tiết

John99 971 giải pháp 13138 câu trả lời
Được đăng

I am not sure it is intended to be persistent, unless you use restore previous session rather than a home page. Maybe there is some preference that can be set. Make sure you exit from firefox using Firefox button -> exit

I am not sure it is intended to be persistent, unless you use restore previous session rather than a home page. Maybe there is some preference that can be set. Make sure you exit from firefox using Firefox button -> exit

Người tạo câu hỏi

It used to be persistent in previous versions (don't know exactly when it changed). Of course I exit normally with [X] or Exit. Restoring a previous session is enabled and seems to work. But a new browser window (when there are already some open) again is without sidebar, even if all the other windows have the sidebar enabled.

It used to be persistent in previous versions (don't know exactly when it changed). Of course I exit normally with [X] or Exit. Restoring a previous session is enabled and seems to work. But a new browser window (when there are already some open) again is without sidebar, even if all the other windows have the sidebar enabled.
cor-el
  • Top 10 Contributor
  • Moderator
17564 giải pháp 158866 câu trả lời
Được đăng

Is that a pop-up window that has the sidebar missing?

If it only happens in one window then close that window or tear-off the tabs to a new window to see if that makes the sidebar persist.

Is that a pop-up window that has the sidebar missing? If it only happens in one window then close that window or tear-off the tabs to a new window to see if that makes the sidebar persist.

Người tạo câu hỏi

It's not a pop-up window, just a normal browser after clicking on the FF-icon on the desktop or starting "firefox.exe" on the command line. No, closing and reopeing it doesn't help.

It's not a pop-up window, just a normal browser after clicking on the FF-icon on the desktop or starting "firefox.exe" on the command line. No, closing and reopeing it doesn't help.

Người tạo câu hỏi

Can you tell me where this setting should be saved? Then I can check if it is not stored at all or if it is not active while opening an additional browser window.

If I have a browser with bookmarks sidebar and I do a "open link in new window" then the new browser window does have the bookmarks sidebar. It's only a completely new browser that has no sidebar.

Can you tell me where this setting should be saved? Then I can check if it is not stored at all or if it is not active while opening an additional browser window. If I have a browser with bookmarks sidebar and I do a "open link in new window" then the new browser window does have the bookmarks sidebar. It's only a completely new browser that has no sidebar.
cor-el
  • Top 10 Contributor
  • Moderator
17564 giải pháp 158866 câu trả lời
Được đăng

Such data is stored in the file localstore.rdf in the profile folder.

Such data is stored in the file localstore.rdf in the profile folder. *http://kb.mozillazine.org/localstore.rdf *http://kb.mozillazine.org/Corrupt_localstore.rdf

Người tạo câu hỏi

OK, but what is the name of the setting? I have already tried the fixing as mentioned in the first post. The xml syntax looks well formed.

OK, but what is the name of the setting? I have already tried the fixing as mentioned in the first post. The xml syntax looks well formed.
Hasan 469 giải pháp 5600 câu trả lời
Được đăng

-> Tap ALT key or press F10 to temporarily show the Menu bar

  • go to View Menu -> Sidebar -> select Bookmarks

Check and tell if its working.

-> Tap '''ALT''' key or press '''F10''' to temporarily show the '''Menu bar''' * go to '''View''' Menu -> '''Sidebar''' -> select '''Bookmarks''' Check and tell if its working.

Người tạo câu hỏi

Yes, this works, as written in my first post. That was never the problem but the persistence across browser windows if I open a new one.

Yes, this works, as written in my first post. That was never the problem but the persistence across browser windows if I open a new one.
cor-el
  • Top 10 Contributor
  • Moderator
17564 giải pháp 158866 câu trả lời
Được đăng

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode

Người tạo câu hỏi

Doesn't help, after restarting FF and opening a new browser window the sidebar is gone again (not in the restored windows, only in the new one).

Doesn't help, after restarting FF and opening a new browser window the sidebar is gone again (not in the restored windows, only in the new one).

Giải pháp được chọn

I think I finally got it to work. I have a second computer (same setup) where it works. So I compared the localstore.rdf files and found the problem.

 <RDF:Description RDF:about="chrome://browser/content/browser.xul#sidebar-box"
                  sidebarcommand="viewBookmarksSidebar"
                  width=""
                  src="chrome://browser/content/bookmarks/bookmarksPanel.xul" />

The sidebar was enabled but the width was empty so in effect disabled. Also closing a browser with the sidebar showing didn't change this value. After manually entering a value I can now open a new browser window with sidebar enabled.

I think I finally got it to work. I have a second computer (same setup) where it works. So I compared the localstore.rdf files and found the problem. <RDF:Description RDF:about="chrome://browser/content/browser.xul#sidebar-box" sidebarcommand="viewBookmarksSidebar" width="" src="chrome://browser/content/bookmarks/bookmarksPanel.xul" /> The sidebar was enabled but the width was empty so in effect disabled. Also closing a browser with the sidebar showing didn't change this value. After manually entering a value I can now open a new browser window with sidebar enabled.
John99 971 giải pháp 13138 câu trả lời
Được đăng

Glad it works, congratulations on discovering the solution.

Glad it works, congratulations on discovering the solution.