Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can stop Firefox from re-opening windows after a crash?

  • 4 trả lời
  • 0 gặp vấn đề này
  • 39 lượt xem
  • Trả lời mới nhất được viết bởi zeroknight

more options

Hi, I have the problem that Firefox restarts after a crash, re-opening exactly the same windows that were open at the time of the crash, which most of the time reproduces the crash.

I want Firefox to restart with an empty window, like it is configured.

I have read a support entry that hints setting browser.sessionstore.resume_from_crash to false, which does NOT to the job (anymore).

Hi, I have the problem that Firefox restarts after a crash, re-opening exactly the same windows that were open at the time of the crash, which most of the time reproduces the crash. I want Firefox to restart with an empty window, like it is configured. I have read a support entry that hints setting browser.sessionstore.resume_from_crash to false, which does NOT to the job (anymore).

Giải pháp được chọn

Check that browser.startup.page is 1, browser.sessionstore.resume_from_crash is false and browser.sessionstore.max_resumed_crashes is 0 in about:config.

Does it still happen in a new profile (without signing into sync account)? Alternatively you can refresh your existing profile.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

Add the following line to a file named user.js in your profile folder :

user_pref("browser.sessionstore.resume_session_once", false);

Hữu ích?

more options

zeroknight said

Add the following line to a file named user.js in your profile folder : user_pref("browser.sessionstore.resume_session_once", false);

There was no such file, but I added one. But it didn't change anything.

Hữu ích?

more options

You can set this pref to 0 (zero) on the about:config page to always show the Session Restore (about:sessionrestore) page in case of a crash or when you force a shutdown.

  • browser.sessionstore.max_resumed_crashes = 0 (-1:never ask; 0:always ask)
user_pref("browser.sessionstore.max_resumed_crashes", 0);

Hữu ích?

more options

Giải pháp được chọn

Check that browser.startup.page is 1, browser.sessionstore.resume_from_crash is false and browser.sessionstore.max_resumed_crashes is 0 in about:config.

Does it still happen in a new profile (without signing into sync account)? Alternatively you can refresh your existing profile.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.