Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Won't switch to new tab when right-clicked

  • 15 trả lời
  • 0 gặp vấn đề này
  • 47 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I've searched for answers. I tried the About:config and changing some settings to false and others to true as suggested (e.g. browser.search.context.loadInBackground), etc., and of course I have the option chosen under settings.

This is a new computer. My old computer would switch to the new tab when I right click it, but this new one won't.

Any latest fixes?

I've searched for answers. I tried the About:config and changing some settings to false and others to true as suggested (e.g. browser.search.context.loadInBackground), etc., and of course I have the option chosen under settings. This is a new computer. My old computer would switch to the new tab when I right click it, but this new one won't. Any latest fixes?

Giải pháp được chọn

Try enabling "When you open a link, image or media in a new tab, switch to it immediately" in settings (browser.tabs.loadInBackground set to false in about:config) and disable all your extensions.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (15)

more options

Giải pháp được chọn

Try enabling "When you open a link, image or media in a new tab, switch to it immediately" in settings (browser.tabs.loadInBackground set to false in about:config) and disable all your extensions.

Hữu ích?

more options

Thanks. I thought I had tried that combo. It worked. And better still, when I re-enabled the two extensions I run, it still works.

Hữu ích?

more options

These prefs on the about:config page control whether links are opened with a left-click in the background or get focus: You can toggle the default action for opening a link in the background by holding down the Shift key when you hold Ctrl plus left-click or middle-click a link.

  • browser.tabs.loadInBackground (normal links)
  • browser.tabs.loadDivertedInBackground (javascript)
  • browser.tabs.loadBookmarksInBackground (bookmarks)
  • browser.search.context.loadInBackground (context menu: Search)

Hữu ích?

more options

Thanks, cor-el. I need more info on how these options work. Can you recommend more reading?

Hữu ích?

more options

The setting in "Settings -> General -> Tabs" only affects "browser.tabs.loadInBackground". If you want to control this for more cases like opening a bookmark in the background, you need to go to about:config and search for inbackground. A link opened via JavaScript can specify a target window and this can be diverted to a new tab via "Settings -> General -> Tabs", you normally are switched to this tab and you can't continue reading on the page and check the links at a later time.

Hữu ích?

more options

Thanks for the add'l info, co-rel. Can specific sites be set to always open in a new tab and switched to? On my previous computer, for example, any link I clicked on my Google News site would automatically open in a new tab and switch to without my having to hold the ctrl key. But with my new computer it doesn't. Conversely, on another news site, a clicked link opened in the same tab.

Hữu ích?

more options

The Google Settings page like can be opened for the search page has a setting to open the results in a new window/tab, I assume that the News website has a similar setting or this might be shared among other/all Google services.

Hữu ích?

more options

Pinned tabs open external links in new tabs.

Hữu ích?

more options

Yes, zeroknight, but it won't switch to it automatically.

Hữu ích?

more options

If there is, co-rel, Google makes hard to understand and find.

I may have screwed things up. I compared the setting on my old computer (win 10) with the new Win 11 machine.

Old computer settings… new computer:

• browser.tabs.loadInBackground false…true • browser.tabs.loadDivertedInBackground false...neither false or true, just a box with Boolean highlighted, not number or string • browser.tabs.loadBookmarksInBackground false...neither false or true, just a box with Boolean highlighted, not number or string • browser.search.context.loadInBackground false...a box with 2 quotes followed by a zero, then another browser.search.context.loadInBackground followed by "true" then followed by a box saying browser.search.context.loadInBackground (without the "", followed by zero.

I can't seem to undo what I might have done. Suggestions?

Hữu ích?

more options

I'm not sure I understand what you posted above.

Can you attach a screenshot to make it easier to see what you have done ?

Hữu ích?

more options

First, Co-rel, thanks for hanging in there with me.

Earlier you suggested four "things" (I'm not sure what you call them) that may be impacting my experience:

    browser.tabs.loadInBackground (normal links)
   browser.tabs.loadDivertedInBackground (javascript)
   browser.tabs.loadBookmarksInBackground (bookmarks)
   browser.search.context.loadInBackground (context menu: Search) 

I'm not sure what is in parenthesis needed to be included. I don't think so.

On my old computer with Win 10, ALL were "false."

On my new computer, after implementing some suggestions and perhaps doing something I shouldn't have done, my Win 11 computer shows the attached screenshots when I enter them into about:config:

Does this help?

Hữu ích?

more options

Some of the screenshots show a pref name that starts with quotes and they won't working because of their wrong name, so something went wrong with searching and you likely did click the plus to define such a pref. They have a trashcan at the far right instead of the icon to reset their value to the default, you can click the trash to remove them, you may need to check if their are more such accidentally created prefs. Always check whether you have the name correct and do not click the '+' icon for prefs that should exist, the plus is used to define a pref that doesn't exist by default. You can leave services.sync.prefs icons alone as they specify whether to include the pref it controls in syncing prefs (true: include; false:do not include).

The text between the '(...)' is meant as an explanation of its purpose. The prefs I mentioned are all Boolean prefs with a true/false value that can be toggled with a double-click on its line on about:config.

Hữu ích?

more options

Thanks. I have successfully returned all four of the original lines to false, and my computer seems to be acting as I want, though I haven't tried the javascript function.

It was frustrating journey in large part because I discovered that --sometimes--if I put the entire line in, e.g., browser.tabs.loadDivertedInBackground, and hit return it wouldn't let me change the preference, but if I did not hit return, I could change the preference.

Does that make sense? It doesn't matter. Things are working as I wish, so I'm leaving well enough alone.

I do have one final question: Why are some lines in bold?

Hữu ích?

more options

Bold lines on about:config mean that either the pref has been modified by the user from their default value or the pref was created by Firefox or by the user via the bar at the bottom, see the "Show only modified preferences" filter checkbox at the top of the page. Prefs in the latter category have the Delete (trashcan) at the far right instead of of the Reset (circular arrow) button.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.