Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to Hide the Mute Tab Button?

  • 2 trả lời
  • 2 gặp vấn đề này
  • 326 lượt xem
  • Trả lời mới nhất được viết bởi Tclarke02

more options

I've tried following both methods for dissabling the mute button on tabs, it's a slight annoyance, since it's easy to accidentally mute a tab when it's pinned.

Specifically, the first method I've tried changing the setting in about:config called "browser.tabs.showAudioPlayingIcon" from true to false, which was from 7 years ago it seems, which had no effect.

The second method was by making a new rule in a "userChrome.css" file in a new folder called "chrome" with that exact naming, case sensitive. The code in that file is as follows:

/* Hide the mute/unmute button */
.tab-icon-overlay:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) {
    display: none !important;
}
/* Keep site icon visible on hover */
.tabbrowser-tab:hover .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay), 
     /* for site icon with Compact density */
:root[uidensity="compact"] .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay) {
    opacity: 1 !important; /* overrides full transparency with full opacity */
}

If there's an updated version of the code that's meant to have that effect in modern firefox, then please let me know, or if there's some other new way of removing the mute button on tabs. Thanks.

I've tried following both methods for dissabling the mute button on tabs, it's a slight annoyance, since it's easy to accidentally mute a tab when it's pinned. Specifically, the first method I've tried changing the setting in about:config called "browser.tabs.showAudioPlayingIcon" from true to false, which was from 7 years ago it seems, which had no effect. The second method was by making a new rule in a "userChrome.css" file in a new folder called "chrome" with that exact naming, case sensitive. The code in that file is as follows: <pre><nowiki>/* Hide the mute/unmute button */ .tab-icon-overlay:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) { display: none !important; } /* Keep site icon visible on hover */ .tabbrowser-tab:hover .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay), /* for site icon with Compact density */ :root[uidensity="compact"] .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay) { opacity: 1 !important; /* overrides full transparency with full opacity */ }</nowiki></pre><br> If there's an updated version of the code that's meant to have that effect in modern firefox, then please let me know, or if there's some other new way of removing the mute button on tabs. Thanks.

Được chỉnh sửa bởi cor-el vào

Giải pháp được chọn

I have added a <pre> tag before the </pre> tag after your userChrome.css code to make it easier to read:

/* Hide the mute/unmute button */
.tab-icon-overlay:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) {
    display: none !important;
}
/* Keep site icon visible on hover */
.tabbrowser-tab:hover .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay), 
     /* for site icon with Compact density */
:root[uidensity="compact"] .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay) {
    opacity: 1 !important; /* overrides full transparency with full opacity */
}


Is it working for you on non-pinned tabs? If not, could you double-check your process with setting up the file? I have a "how to" page here regarding where to locate the chrome folder and a setting to change in about:config: https://www.userchrome.org/how-create-userchrome-css.html

To make it apply to pinned tabs as well, you need to remove [pinned] from the first rule:

/* Hide the mute/unmute button */
.tab-icon-overlay:not([sharing], [crashed]):is([soundplaying], [muted]) {
    display: none !important;
}
Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

I have added a <pre> tag before the </pre> tag after your userChrome.css code to make it easier to read:

/* Hide the mute/unmute button */
.tab-icon-overlay:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) {
    display: none !important;
}
/* Keep site icon visible on hover */
.tabbrowser-tab:hover .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay), 
     /* for site icon with Compact density */
:root[uidensity="compact"] .tab-icon-stack:not([pinned], [sharing], [crashed]):is([soundplaying], [muted]) > :not(.tab-icon-overlay) {
    opacity: 1 !important; /* overrides full transparency with full opacity */
}


Is it working for you on non-pinned tabs? If not, could you double-check your process with setting up the file? I have a "how to" page here regarding where to locate the chrome folder and a setting to change in about:config: https://www.userchrome.org/how-create-userchrome-css.html

To make it apply to pinned tabs as well, you need to remove [pinned] from the first rule:

/* Hide the mute/unmute button */
.tab-icon-overlay:not([sharing], [crashed]):is([soundplaying], [muted]) {
    display: none !important;
}

Được chỉnh sửa bởi jscher2000 - Support Volunteer vào

more options

Thanks for a prompt reply, it does work on non-pinned tabs, I was about to mention that as an edit as it happens.

Thanks for the help, I'll try it now.