Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Downloading files

  • 7 trả lời
  • 0 gặp vấn đề này
  • 10 lượt xem
  • Trả lời mới nhất được viết bởi AliceWyman

more options

I want to be able to open, say, pdf files and NOT have them saved in the downloads directory unless I mark them to be saved in the open dialogue. Firefox worked that way for years. I reported this as a bug, I think in V.101. After much palaver, some of it irrelevant, the bug was reported fixed, but it has not been.

The bug number — it changed frequently — I last noted down was 1738574.

I want to be able to open, say, pdf files and NOT have them saved in the downloads directory unless I mark them to be saved in the open dialogue. Firefox worked that way for years. I reported this as a bug, I think in V.101. After much palaver, some of it irrelevant, the bug was reported fixed, but it has not been. The bug number — it changed frequently — I last noted down was 1738574.

Giải pháp được chọn

I'll take a look at that bug, it might be a duplicate of another bug that was fixed in Firefox 102.

As you noticed, Firefox 98 changed from saving downloads in the Windows Temp folder for "Open with [relevant application]" or "Use [relevant application]" to saving them in your default downloads folder (the one next to "Save files to" on the Settings page). It's not possible to pass a file to an application without saving it somewhere.

Firefox 102 added a hidden setting to roll back that change. Here's how you access it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

Giải pháp được chọn

I'll take a look at that bug, it might be a duplicate of another bug that was fixed in Firefox 102.

As you noticed, Firefox 98 changed from saving downloads in the Windows Temp folder for "Open with [relevant application]" or "Use [relevant application]" to saving them in your default downloads folder (the one next to "Save files to" on the Settings page). It's not possible to pass a file to an application without saving it somewhere.

Firefox 102 added a hidden setting to roll back that change. Here's how you access it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

more options

By the way, in order to always get the Open/Save/Cancel dialog for PDF downloads, you need to select "Always ask" as your handling preference. See: View PDF files in Firefox or choose another viewer.

If you prefer to use the viewer -- with the PDF in the web cache or Temp folder after the above about:config change -- and THEN choose to save, the "download" button changed behavior to "Save Page As..." so you can do that.

But this change in download button behavior means it is less convenient to "Open" the PDF from the viewer into Acrobat. You need to use the Downloads list (from the toolbar button or Ctrl+J), right-click your PDF, then open in Acrobat from there.

Hopefully one of the above comments addresses what you are looking for in your PDF workflow.

more options

Many many thanks, jscher2000. Firefox now does exactly what I had wanted it to do.

more options

I'll mention this after FF98 it downloads any links or file you click to open or read online. There was a about:config setting that one can do to restore this back that you can also find online. It more involved but I am using this change since FF98 and links and files I don't want saved does what it used to do before FF98 without issues.

more options

Thanks — earlier post by jscher2000 solved the problem.

more options

browser.download.start_downloads_in_tmp_dir .... Already TRUE Always Ask chosen for Settings / Apps / Port Doc Folder

jscher2000, I can't discern from your Help posts IF there is a way to just VIEW a PDF Bank Statement and NOT have it Dnloaded. I just Clk'd VIEW for my statement - it opened in -- PDF-Xchange -- (didn't ask anything) and it appeared in the Dnloads Folder WITH above settings. Can live with it but actually am more frustrated about Not understanding the meaning of the instructions more than the FF behavior. Many Thanks!!

more options

rcj9 said

Thanks — earlier post by jscher2000 solved the problem.

I marked the first post by jscher2000 as the solution and will close this thread.

To Craig: If the suggestions posted in this thread don't help you, please ask a new question. This thread is for helping rcj9, the question owner, and his problem is solved. See Mozilla Support rules and guidelines on posting support requests.

Được chỉnh sửa bởi AliceWyman vào