Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Logging in to Firefox everytime I open a new window

  • 4 trả lời
  • 1 gặp vấn đề này
  • 22 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I had the old firefox (blue background) on my Mac before and have since upgraded to the one (purple background). Now everytime I open firefox, or open a new window in firefox, I have to sign in to my firefox account. On the previous version (blue one) it just kept me signed in. How can I get it to do this again?

Giải pháp được chọn

Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file.

Open the Firefox Disk Images file and drag the Firefox application to the Applications folder on your hard drive. You shouldn't double-click the Firefox application to run it from the Disk Images, but instead drag it out of the DMG folder.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

I wonder whether that purple color indicates private windows? Could you check whether your Firefox is set to start in automatic private browsing, since that really is like starting over each time. I suggest checking on the Preferences page (Options page for our Windows friends):

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security and then on the right side, scroll down to the History section.

Either of the following will trigger automatic private (amnesia) browsing:

(A) Firefox will: Never remember history

(B) Firefox will: Use custom settings for history + [X] "Always use private browsing mode"

If you have one of those set, switch back to normal browsing, and then we can discuss other ways to manage history if you want Firefox to be more forgetful but still operate mostly normally.

more options

Thanks for your reply.

Sorry, I mean the purple centre to the firefox icon. There is a fox sorrounding a purple sphere. It was a blue sphere on the previous version before I updated firefox.

This is what I have selected under the History section in preferences: Firefox will: Use custom settings for history. Always use private browsing is not selected. Then under the Settings bit I have only selected to automatically clear all cache. The other options are not selected.

When I am logged in to firefox with my firefox account, if I go to File>new window then the new window asks me to sign in again. Is this how it is supposed to work? It doesn't ask me to sign in again if I open a new tab

more options

Oops, sorry, for the confusion, and thank you for checking that. I hadn't noticed that the color in the icon had changed.

You normally don't need to sign in again in a new window in regular windows. Where is this message coming up -- in the tab, in a drop-down from the menu button, or somewhere else?

If it's showing up in the tab, I wonder whether a sign-in page somehow got saved as your home page, or your home page is a service that always needs a fresh sign-in. Could you check your home page setting and see what you have there: How to set the home page.

more options

Giải pháp được chọn

Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file.

Open the Firefox Disk Images file and drag the Firefox application to the Applications folder on your hard drive. You shouldn't double-click the Firefox application to run it from the Disk Images, but instead drag it out of the DMG folder.