Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How do I disable the blue flash when a tab finished loading?

  • 8 trả lời
  • 1 gặp vấn đề này
  • 129 lượt xem
  • Trả lời mới nhất được viết bởi steelpillow

more options

How do I disable the blue flash when a tab finishes loading? I'd like to suggest an option in a future release that disables all these things.

I find it a real distraction, and it's really putting me off using firefox as a broswer. I really don't think this sort of eye candy is needed in order to browse the internet.

Giải pháp được chọn

Hi useruser, for some animations, Firefox now checks with your system on whether you have expressed a preference for reduced motion. If that isn't a thing on your system or you only want reduced motion in Firefox, you can hand-create a preference to force the result of that inquiry:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button to save the change.

Screenshot sequence attached for reference.

I don't remember whether that takes effect immediately or after your next quit/restart of Firefox. Success?

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

hi,

you can disable that animation like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named toolkit.cosmeticAnimations.enabled. double-click it and change its value to false.

Hữu ích?

more options

Hi,

Thanks for your reply but this doesn't work for me. I'm using v77.0.1 x64 (linux)

Hữu ích?

more options

Giải pháp được chọn

Hi useruser, for some animations, Firefox now checks with your system on whether you have expressed a preference for reduced motion. If that isn't a thing on your system or you only want reduced motion in Firefox, you can hand-create a preference to force the result of that inquiry:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button to save the change.

Screenshot sequence attached for reference.

I don't remember whether that takes effect immediately or after your next quit/restart of Firefox. Success?

Hữu ích?

more options

That works for me, thanks! Have a great day everyone!

Hữu ích?

more options

See also:

  • Bug 1478597 - [meta] Respect prefers-reduced-motion for UI animations

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Hữu ích?

more options

I am on Linux and have just upgraded to FF 78.3.0esr (64-bit). Neither of the solutions offered works for me, nor do several other tweaks to about:config settings, suggested in various Internet threads, to reduce unwanted animations including this one. That bug report is 2 years old but the blue flash has only just appeared for me in this latest upgrade. It is really irritating, I have checked and checked about:config and rebooted ad nauseam. What can possibly be overriding those fixes?

Hữu ích?

more options

Hi steelpillow, can you delete the ui.prefersReducedMotion preference -- click the trash can icon at the right end of that row -- and create it again, making sure it is created as a Number and not as a String ?

Hữu ích?

more options

Aha! Magic! Worked a treat. Thank you.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.