Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website formatting messed up

  • 6 trả lời
  • 2 gặp vấn đề này
  • 16 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

Hello,

Just recently there has been issues with how a job search at Glassdoor.com is appearing via my Firefox browser. It seems that the formatting is all messed up, and everything gets shoved to the left margin, and there is no scroll bar. (See first image)

If I reduce the size of the zoom level, I can see the search results actually have appeared, but they are shoved even further to the left margin and no scroll bar again. (See second image)

This only happens with anything connected with a job search at Glassdoor.com. Salary search, company search, etc are all fine, just the job search, which is really inconvenient since I am actively looking for a job.

I've attached images of this for you.

The job search pages work fine in Chrome. Please don't make me use Chrome.

Thank you,

Sheri

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Right, they made a website that works only in Chrome.

You can go to about:config and set network.preload = true, but I'm not sure if it's going to work in your version. It works OK in 78.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (6)

more options

Giải pháp được chọn

Right, they made a website that works only in Chrome.

You can go to about:config and set network.preload = true, but I'm not sure if it's going to work in your version. It works OK in 78.

Hữu ích?

more options

TyDraniu said

You can go to about:config and set network.preload = true, but I'm not sure if it's going to work in your version. It works OK in 78.

I think it is considered buggy in Firefox 76, so turning it on may not be completely glitch-free.

An alternative would be to run a script that switches the <link rel="preload"> tags to <link rel="stylesheet"> tags. It can be fairly simple:

var ss=document.querySelectorAll('link[href][rel="preload"][as="style"][type="text/css"]'); 
for(var i=0;i<ss.length;i++)ss[i].rel='stylesheet';


To apply it to the page, one option is a bookmarklet. That's a script saved to your Bookmarks Toolbar or Bookmarks Menu for quick access. I created one you can install from here:

https://www.jeffersonscher.com/res/sumomarklets.html#loadss

It's only to patch up the problem of "preload" not working in Firefox and can't fix other kinds of errors that can cause style sheets not to load, such as secure connection errors.

Hữu ích?

more options

Thank you both!! This was driving me crazy.

Changing network.preload to "true" worked for me. Hopefully it will continue to work.

Hữu ích?

more options

I also chose the first solution because it was simpler. It worked! On the Canadian federal government website SOME pages were messed up as described by Sheri. Click a link to the next page and formatting was good, click to another page on the same website and it was crap. Why would that be? Is it a fault in the website? There was no problem with the messed up pages in Chrome.

Doug

Hữu ích?

more options

I need to withdraw the above comment. Changing network.preload to "True" is NOT working.

Went to the link in the next solution https://www.jeffersonscher.com/res/sumomarklets.html#loadss but did not see anything about network preload so I have no clue what to do there...

Doug

Hữu ích?

more options

Hi Doug, only a small number of websites use this preload method of loading style sheets. Pages can be messed up for many other reasons, so unfortunately it is necessary to investigate in more detail.

For example, has your Firefox reported any problems making secure connections to sites?

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.