X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

On new laptop the userchrome.css I've been using for years doesn't put the tabs on the bottom anymore.

Được đăng

This exact same userchrome.css still works fine on my pc,both computers are running the same,latest version of Firefox [69]. It also worked fine in my old laptop...like,two days ago before I sold it. I think everything else in the userchrome.css seems to still work on this laptop...spacing,tab height,search box,address bar clear instead of cloudy etc etc...but not the tabs on bottom part.

First pic [capture 1] is the pc with tabs on bottom,how I want them..second pic is this laptop...tabs on top. Any ideas to restore the tabs to the bottom would be greatly appreciated,thanks.

This exact same userchrome.css still works fine on my pc,both computers are running the same,latest version of Firefox [69]. It also worked fine in my old laptop...like,two days ago before I sold it. I think everything else in the userchrome.css seems to still work on this laptop...spacing,tab height,search box,address bar clear instead of cloudy etc etc...but not the tabs on bottom part. First pic [capture 1] is the pc with tabs on bottom,how I want them..second pic is this laptop...tabs on top. Any ideas to restore the tabs to the bottom would be greatly appreciated,thanks.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Hello Haruna, There was a change in Firefox 69.0:

"Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability."

From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Đọc câu trả lời này trong ngữ cảnh 1
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Thông tin chi tiết

RobertJ
  • Top 10 Contributor
108 giải pháp 1188 câu trả lời
Được đăng

Giải pháp được chọn

Hello Haruna, There was a change in Firefox 69.0:

"Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability."

From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Hello Haruna, There was a change in Firefox 69.0: "Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability." From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17673 giải pháp 159870 câu trả lời
Được đăng

Câu trả lời hữu ích

Can you post the content of userChrome.css?

Are the ant @-moz-document url() lines in the userChrome.css file?

You may have to make this change:

@-moz-document url(chrome://browser/content/browser.xul) =>
@-moz-document url(chrome://browser/content/browser.xhtml)
Can you post the content of userChrome.css? Are the ant @-moz-document url() lines in the userChrome.css file? You may have to make this change: @-moz-document url(chrome://browser/content/browser.xul) => @-moz-document url(chrome://browser/content/browser.xhtml)
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

Hi,thanks very much My_Cheese_Is_Slippin',setting that legacy toolkit thing to true fixed it,the tabs are back on the bottom now...excellent! For some reason that was set to true automatically on my pc,but not on the laptop. Thanks a lot.

Hi,thanks very much My_Cheese_Is_Slippin',setting that legacy toolkit thing to true fixed it,the tabs are back on the bottom now...excellent! For some reason that was set to true automatically on my pc,but not on the laptop. Thanks a lot.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
damien.williams7 0 giải pháp 2 câu trả lời
Được đăng

My_Cheese_Is_Slippin' said

Hello Haruna, There was a change in Firefox 69.0: "Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability." From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Having this problem after an update, just last night, and the toggle is already set. Went to bed with the CSS working, woke up with it broken.

''My_Cheese_Is_Slippin' [[#answer-1250905|said]]'' <blockquote> Hello Haruna, There was a change in Firefox 69.0: "Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability." From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew </blockquote> Having this problem after an update, just last night, and the toggle is already set. Went to bed with the CSS working, woke up with it broken.
Bài viết này có hữu ích với bạn không?
Trích dẫn
gyaltnnh 0 giải pháp 16 câu trả lời
Được đăng

Where is this file located? toolkit.legacyUserProfileCustomizations.stylesheets

Where is this file located? toolkit.legacyUserProfileCustomizations.stylesheets
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17673 giải pháp 159870 câu trả lời
Được đăng

toolkit.legacyUserProfileCustomizations.stylesheets is not a file, but one of the many preferences that are listed on the about:config page. You can use the search bar at the top of this page to locate this pref and toggle the pref via a double-click on the line or via the Edit button.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

toolkit.legacyUserProfileCustomizations.stylesheets is not a file, but one of the many preferences that are listed on the <b>about:config</b> page. You can use the search bar at the top of this page to locate this pref and toggle the pref via a double-click on the line or via the Edit button. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Bài viết này có hữu ích với bạn không?
Trích dẫn
damien.williams7 0 giải pháp 2 câu trả lời
Được đăng

damien.williams7 said

My_Cheese_Is_Slippin' said
Hello Haruna, There was a change in Firefox 69.0: "Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability." From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Having this problem after an update, just last night, and the toggle is already set. Went to bed with the CSS working, woke up with it broken.

Found a solution, here, though it comes with the caveat that it apparently won't work on firefox 72

https://www.reddit.com/r/FirefoxCSS/comments/e5o5uq/found_a_fix_for_userchromecss_to_get_the_tabs/

''damien.williams7 [[#answer-1271310|said]]'' <blockquote> ''My_Cheese_Is_Slippin' [[#answer-1250905|said]]'' <blockquote> Hello Haruna, There was a change in Firefox 69.0: "Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability." From - See what’s new in Firefox! https://www.mozilla.org/en-US/firefox/69.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew </blockquote> Having this problem after an update, just last night, and the toggle is already set. Went to bed with the CSS working, woke up with it broken. </blockquote> Found a solution, here, though it comes with the caveat that it apparently won't work on firefox 72 https://www.reddit.com/r/FirefoxCSS/comments/e5o5uq/found_a_fix_for_userchromecss_to_get_the_tabs/
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.