X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox will not load pages, network logs sometimes return status code and nothing else

Được đăng

I'm not too sure how to describe this issue. Firefox will not load any pages, including ones from an HTTP server on localhost. The details for the requests in the Network tab in the devtools are blank (the Headers, Cookies, Params, Response, and Timings tabs are all empty). The console shows the requests, sometimes with a status code. Regardless of the status code, the page doesn't actually load. I tested with some XMLHttpRequests and got the same results. Firefox can successfully render files from the disk (file:///home/user/whatever/idontknow.html), but it will not display any pages from a network.

It can, however, install extensions/themes from the about:addons page. It loads the recommended themes and extensions and can download and install them without trouble.

This issue persists if I disable all plugins/extensions.

I've gone through every relevant-looking support page and tried:

- messing with my DNS settings (unlikely an issue with DNS as even localhost requests are broken)

- changing my proxy settings from "Use system proxy settings" to "No proxy" (I don't use a proxy)

- updating Firefox (Arch Linux had a new version of the package which seemingly only changed the .desktop file used to launch it)

- rebooting

- reinstalling Firefox

I tried to troubleshoot this myself, but had no idea what the issue could possibly be.

I don't have a strange network configuration, and other browsers work fine.

I'm not too sure how to describe this issue. Firefox will not load any pages, including ones from an HTTP server on localhost. The details for the requests in the Network tab in the devtools are blank (the Headers, Cookies, Params, Response, and Timings tabs are all empty). The console shows the requests, sometimes with a status code. Regardless of the status code, the page doesn't actually load. I tested with some XMLHttpRequests and got the same results. Firefox can successfully render files from the disk (file:///home/user/whatever/idontknow.html), but it will not display any pages from a network. It can, however, install extensions/themes from the about:addons page. It loads the recommended themes and extensions and can download and install them without trouble. This issue persists if I disable all plugins/extensions. I've gone through every relevant-looking support page and tried: - messing with my DNS settings (unlikely an issue with DNS as even localhost requests are broken) - changing my proxy settings from "Use system proxy settings" to "No proxy" (I don't use a proxy) - updating Firefox (Arch Linux had a new version of the package which seemingly only changed the .desktop file used to launch it) - rebooting - reinstalling Firefox I tried to troubleshoot this myself, but had no idea what the issue could possibly be. I don't have a strange network configuration, and other browsers work fine.

Được chỉnh sửa bởi Katie vào

Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

Tested with no plugins

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

Thông tin chi tiết

hellosct1
  • Top 25 Contributor
14 giải pháp 145 câu trả lời
Được đăng

Hi,

I think we need to do a safe mode repair to solve all these problems https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Thank's

Hi, I think we need to do a safe mode repair to solve all these problems https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Thank's
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.