X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

How to disable web push notifications in Firefox?

Được đăng

Hi,

how to completly remove/disable web push notifications in Firefox?

about:config > dom.push.enabled > false

Not help with notif sent from "cdn . sendpulse . com"

demo here "thebadbuzz . com" (see attached screenshot).

The only alternative i have find is to block "sendpulse" using Adblock Plus.

Thank you.

Hi, how to completly remove/disable web push notifications in Firefox? about:config > dom.push.enabled > false Not help with notif sent from "cdn . sendpulse . com" demo here "thebadbuzz . com" (see attached screenshot). The only alternative i have find is to block "sendpulse" using Adblock Plus. Thank you.
Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi smed79 vào

Giải pháp được chọn

Hi FirefoxUser72345, the search feature on this site isn't very sophisticated, but in fact this question has been asked and answered several times in several ways in the time between SMed79's question and your follow-up:

If I had seen this thread I would have given the same information I gave in those threads, but I didn't see it.

Đọc câu trả lời này trong ngữ cảnh 2

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4246 giải pháp 59401 câu trả lời
Được đăng
Does this help? https://support.mozilla.org/en-US/kb/push-notifications-firefox

Người tạo câu hỏi

''FredMcD [[#answer-917861|a écrit]]'' <blockquote> Does this help? https://support.mozilla.org/en-US/kb/push-notifications-firefox </blockquote> Sorry, No ! another example here http://i.imgur.com/sfNZ8Rg.png

Được chỉnh sửa bởi smed79 vào

FirefoxUser72345 0 giải pháp 11 câu trả lời
Được đăng

You are absolutely right to ask how to remove this rubbish

If I cannot find a solution I am dumping Firefox, I just had another crash and first site I visited wanted to hassle me with this nonsense

Let's see if my request finally gets an answer on how to disable this or else I will have to ask all over the web.

https://support.mozilla.org/en-US/questions/1144958

You are absolutely right to ask how to remove this rubbish If I cannot find a solution I am dumping Firefox, I just had another crash and first site I visited wanted to hassle me with this nonsense Let's see if my request finally gets an answer on how to disable this or else I will have to ask all over the web. https://support.mozilla.org/en-US/questions/1144958
FirefoxUser72345 0 giải pháp 11 câu trả lời
Được đăng

Good News!

This seems to be the solution:

the-edmeister said

In about:config - dom.push.enabled = double-click to toggle it to false. https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Good News! This seems to be the solution: ''the-edmeister [[#answer-931166|said]]'' <blockquote> In about:config - '''dom.push.enabled''' = double-click to toggle it to false. https://support.mozilla.org/en-US/kb/about-config-editor-firefox </blockquote>
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Giải pháp được chọn

Hi FirefoxUser72345, the search feature on this site isn't very sophisticated, but in fact this question has been asked and answered several times in several ways in the time between SMed79's question and your follow-up:

If I had seen this thread I would have given the same information I gave in those threads, but I didn't see it.

Hi FirefoxUser72345, the search feature on this site isn't very sophisticated, but in fact this question has been asked and answered several times in several ways in the time between SMed79's question and your follow-up: * [https://support.mozilla.org/questions/1140439 I can't find Firefox menu! I'm trying to opt out of Web Push...and want to stop all sites from sending me messages...Please help!] * [https://support.mozilla.org/questions/1140700 disable web notifications] * [https://support.mozilla.org/questions/1141113 in content-how do i make "do not disturb me" fixed] * [https://support.mozilla.org/questions/1141800 How can I suppress web push requests for all websites?] If I had seen this thread I would have given the same information I gave in those threads, but I didn't see it.
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

FirefoxUser72345 said

Good News! This seems to be the solution: the-edmeister said
In about:config - dom.push.enabled = double-click to toggle it to false.
https://support.mozilla.org/en-US/kb/about-config-editor-firefox

For your needs, perhaps, but the original poster reported that did not work on sites where they didn't want notifications. That's because (A) disabling the push mechanism still allows non-push web notifications, and (B) posters here often use the word push as a "catch all" term for web notifications. So my suggestions tend to be focused on the options for taming notifications rather than mechanism(s) Firefox may use for them.

''FirefoxUser72345 [[#answer-931223|said]]'' <blockquote> Good News! This seems to be the solution: ''the-edmeister [[#answer-931166|said]]'' <blockquote> In about:config - '''dom.push.enabled''' = double-click to toggle it to false. <br> https://support.mozilla.org/en-US/kb/about-config-editor-firefox </blockquote> </blockquote> For your needs, perhaps, but the original poster reported that did not work on sites where they didn't want notifications. That's because (A)&nbsp;disabling the push mechanism still allows ''non-push'' web notifications, and (B)&nbsp;posters here often use the word push as a "catch all" term for web notifications. So my suggestions tend to be focused on the options for taming notifications rather than mechanism(s) Firefox may use for them.

Câu trả lời hữu ích

Be sure I did a search before asking my question.

Anyway, fixed by switching dom.webnotifications.enabled to false.

Thank you, I appreciate all the work people do here to help us.

Be sure I did a search before asking my question. Anyway, [https://twitter.com/firefox/status/792860884741787648? fixed] by switching '''dom.webnotifications.enabled''' to '''false'''. Thank you, I appreciate all the work people do here to help us.

Được chỉnh sửa bởi Noah_SUMO vào

jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

SMed79 said

Be sure I did a search before asking my question.

I think you were ahead of your time -- most of the other threads were a couple weeks later. Support volunteers don't often find time to dig back through the unresolved threads more than a few days back.

''SMed79 [[#answer-931350|said]]'' <blockquote> Be sure I did a search before asking my question. </blockquote> I think you were ahead of your time -- most of the other threads were a couple weeks later. Support volunteers don't often find time to dig back through the unresolved threads more than a few days back.
Noah_SUMO
  • Moderator
98 giải pháp 613 câu trả lời
Được đăng

Btw SMed79, I was the one who responded to you on Twitter. ;) Big thanks to Jscher, if not for his answers about this on the other web push threads, I wouldn't have found the answer. :)

Btw SMed79, I was the one who responded to you on Twitter. ;) Big thanks to Jscher, if not for his answers about this on the other web push threads, I wouldn't have found the answer. :)

Người tạo câu hỏi

Noah_SUMO said

I was the one who responded to you on Twitter.

I truly thank you for taking the time that you did to give me answers :)

''Noah_SUMO [[#answer-931366|said]]'' <blockquote> I was the one who responded to you on Twitter. </blockquote> I truly thank you for taking the time that you did to give me answers :)
makaio 0 giải pháp 22 câu trả lời
Được đăng

It seems Firefox developers are forcing users to turn to about:config actions or guesses more and more for browser solutions.

This is hardly user friendly, and at least in the case of notifications, does not speak well of their motivations -- presumably money or some other driver is trumping common sense desires of the general user populace.

I doubt such a priority is part of their vision statement, but then again maybe it is.

It seems Firefox developers are forcing users to turn to about:config actions or guesses more and more for browser solutions. This is hardly user friendly, and at least in the case of notifications, does not speak well of their motivations -- presumably money or some other driver is trumping common sense desires of the general user populace. I doubt such a priority is part of their vision statement, but then again maybe it is.
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Hi makaio, do you need to post in other peoples' threads when you already started a new question? I would think after using this forum for 5 years, you would know the etiquette.

Why is 'Notifications-Do not disturb me' not a constant setting?


Also, as a summary:

Websites can ask you to accept several different kinds of communications and updates:

  • Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site.
  • Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox).
  • Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing.

Site-Specific Permissions/Blocks

If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

(5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point.


Troubleshooting: Site-Specific Permissions Are Forgotten?

Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page.

If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Troubleshooting: Pages still display a permission dialog

Example:

Website scripts can display pre-permission dialogs even if Firefox ultimately won't allow the services. This is beyond the control of Firefox, but could be tamped down with add-ons.

Hi makaio, do you need to post in other peoples' threads when you already started a new question? I would think after using this forum for 5 years, you would know the etiquette. [https://support.mozilla.org/questions/1151939 Why is 'Notifications-Do not disturb me' not a constant setting?] ---- Also, as a summary: Websites can ask you to accept several different kinds of communications and updates: * '''Desktop notifications''' - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site. * '''Web push notifications''' - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen ''even after'' the last tab for the site is closed (until you exit Firefox). * '''Web push updates''' - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing. '''''Site-Specific Permissions/Blocks''''' If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either: * right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. '''''Session Do Not Disturb''''' To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: * Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content * Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content * Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content * Anyone: Type or paste '''about:preferences#content''' in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only. '''''All-Site Persistent Disable''''' There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webno''' and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the '''dom.webnotifications.serviceworker.enabled''' preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site (4) To disable ALL NOTIFICATIONS, double-click the '''dom.webnotifications.enabled''' preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites (5) To also disable BACKGROUND UPDATES, double-click the '''dom.push.enabled''' preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. ---- '''''Troubleshooting: Site-Specific Permissions Are Forgotten?''''' Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page. If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox. '''''Troubleshooting: Pages still display a permission dialog''''' Example: <img src="https://support.cdn.mozilla.net/media/uploads/images/2016-12-26-15-37-08-44a50f.png" width="500"> Website scripts can display pre-permission dialogs even if Firefox ultimately won't allow the services. This is beyond the control of Firefox, but could be tamped down with add-ons.
makaio 0 giải pháp 22 câu trả lời
Được đăng

Câu trả lời hữu ích

I apologize. I've been operating under the misunderstanding that a forum was "a place, meeting, or medium where ideas and views on a particular issue can be exchanged".

Perhaps "just shut up about ongoing bad behavior" is the definition here.

I apologize. I've been operating under the misunderstanding that a forum was "a place, meeting, or medium where ideas and views on a particular issue can be exchanged". Perhaps "just shut up about ongoing bad behavior" is the definition here.
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Hi makaio, we definitely want to hear about your tech support issues, but that's pretty much the extent of what support volunteers address. Every forum has its own scope, and the guidelines are as much to avoid wasting your time as anyone else's. Hopefully you can follow up with one or more of the other avenues.

Hi makaio, we definitely want to hear about your tech support issues, but that's pretty much the extent of what support volunteers address. Every forum has its own scope, and the guidelines are as much to avoid wasting your time as anyone else's. Hopefully you can follow up with one or more of the other avenues.
FirefoxUser72345 0 giải pháp 11 câu trả lời
Được đăng

Hi All

I fully support makaio and his frustrations.

First off do not blame him for what is an issue of the forum, you search for something, do not find a solution so you post. Only then does it offer related posts and in your desperate need to find a solution of course you add a post to relevant (google's key metric BTW), thread.

I also thing makaio makes valid points, why not make it OPT IN rather than OPT OUT, why not put a slider in Privacy,

I still use Firefox every day, not for the browser but for the extensions, however, I have started using Opera because of issues with Firefox, I was pleased to find it loads instantly, has a free VPN and Ad Blocker.

If Firefox wants to sell its soul then do not be surprised to lose users over time.

Thanks to the volunteers who keep this forum alive, wishing you peace and good health in 2017.

Hi All I fully support makaio and his frustrations. First off do not blame him for what is an issue of the forum, you search for something, do not find a solution so you post. Only then does it offer related posts and in your desperate need to find a solution of course you add a post to relevant (google's key metric BTW), thread. I also thing makaio makes valid points, why not make it OPT IN rather than OPT OUT, why not put a slider in Privacy, I still use Firefox every day, not for the browser but for the extensions, however, I have started using Opera because of issues with Firefox, I was pleased to find it loads instantly, has a free VPN and Ad Blocker. If Firefox wants to sell its soul then do not be surprised to lose users over time. Thanks to the volunteers who keep this forum alive, wishing you peace and good health in 2017.
JaneJones 0 giải pháp 2 câu trả lời
Được đăng

Just stop these pop ups The people who make them are paedos who ruin my internet stuff. Stop the pop up crap.

"Would you like to receive notifications?" No, I would like firefox to hunt you down and go all medieval on your ass. {like the scene in Pulp fiction}

Wanker! Waste my time embarrassing.

Just stop these pop ups The people who make them are paedos who ruin my internet stuff. Stop the pop up crap. "Would you like to receive notifications?" No, I would like firefox to hunt you down and go all medieval on your ass. {like the scene in Pulp fiction} Wanker! Waste my time embarrassing.

Được chỉnh sửa bởi JaneJones vào

JaneJones 0 giải pháp 2 câu trả lời
Được đăng

Ok here is the definitive fix. Firefox say: Starting with version 44, Firefox can deliver on-screen notifications even when that site isn’t loaded. Using the Push API, a W3C standard, Firefox receives a push message and can show notifications (if permitted by the user) at any time. Sites can also use Push to update data in the background even without showing you a notification.

This is evil.

Here is the answer: Download Firefox 43 and block updates, for ever. filehippo.com/download_firefox43

Sorted.

'''Ok here is the definitive fix.''' Firefox say: Starting with version 44, Firefox can deliver on-screen notifications even when that site isn’t loaded. Using the Push API, a W3C standard, Firefox receives a push message and can show notifications (if permitted by the user) at any time. Sites can also use Push to update data in the background even without showing you a notification. This is evil. Here is the answer: Download Firefox 43 and block updates, for ever. [http://filehippo.com/download_firefox/65150/ filehippo.com/download_firefox43] Sorted.

Được chỉnh sửa bởi JaneJones vào

cor-el
  • Top 10 Contributor
  • Moderator
17473 giải pháp 157940 câu trả lời
Được đăng

For receiving/accepting push notifications you always need to grant permission if you have enabled this feature.

  • Global setting Push notifications: dom.push.enabled

You can consider to set dom.push.serverURL to an empty String value to prevent Firefox from connecting to the Push server at any time if you are that concerned.


[1] Service workers (and Push) have been disabled in the Firefox 45 Extended Support Release (ESR.
For receiving/accepting push notifications you always need to grant permission if you have enabled this feature. *Global setting Push notifications: dom.push.enabled You can consider to set dom.push.serverURL to an empty String value to prevent Firefox from connecting to the Push server at any time if you are that concerned. ---- *https://developer.mozilla.org/en-US/docs/Web/API/ServiceWorker <blockquote>[1] Service workers (and Push) have been disabled in the Firefox 45 Extended Support Release (ESR.</blockquote>