Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blank background for embedded videos on Firefox

  • 6 trả lời
  • 1 gặp vấn đề này
  • 36 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

This has happened over the the two most current versions of Firefox. When I got to a place like the Detroit News or Detroit Free Press website where they have embedded autoplay videos, I get a gray background even as the videos play. I can even see the video controls to stop and start. I can also view the videos in a seperate window, but no on the page of the news article.

I thought this may have had something to do with Tracking Protection, but it's turned off. Is it possible that Classic Theme Restorer of Status-4-Evar extentions are messing with it? Other than that, I'm not sure why I can watch embedded videos on these media websites.

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (6)

more options

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

It looks that the Shockwave Flash plugin isn't enabled for this website.

Did you click the Lego block icon on the location/address bar to see what plugins are used?

You can check the Web Console ("3-bar" menu button or Tools > Web Developer) if there are error messages about playing media files.

more options

No, that's not the problem. It doesn't ask me to activate it like it does on other sites.

BTW, if you can remove that screengrab, now, that'd be great. Not sure why it's not letting me.

Được chỉnh sửa bởi FireFoxFan1 vào

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

That first part was something I always had as a setting. All the ones I regularly use are set to "Ask" and have been for months.

The second tip seems to have worked, but how where my settings changed in the first place? Do I have to do this with every site where this has happened?

Được chỉnh sửa bởi FireFoxFan1 vào

more options

If the problem was the master setting, probably not. But now you know what to check.

Bad programs / add-ons are known to change settings without the user knowing.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.