X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why are tabs opening in the background all of a sudden?

Được đăng

Since the last upgrade Firefox opens tabs in the background instead of the foreground. I want to change it back, both when clicking links in Web pages with the target set to open a new window, and when opening Firefox via another program that wants to open a link in a browser. How do I set it to only open tabs in the foreground again?

Running Firefox 43.0.4 on a Mac

Since the last upgrade Firefox opens tabs in the background instead of the foreground. I want to change it back, both when clicking links in Web pages with the target set to open a new window, and when opening Firefox via another program that wants to open a link in a browser. How do I set it to only open tabs in the foreground again? Running Firefox 43.0.4 on a Mac

Giải pháp được chọn

Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.13
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.2.6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Version 5.41.3.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 20.0 r0
  • 5.1.40728.0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Ứng dụng

  • Firefox 43.0.4
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/43.0.4/Darwin/en-US/

Tiện ích mở rộng

  • 1Password 4.5.2 (onepassword4@agilebits.com)
  • DblClicker 1.8.0 (dblclicker@byo.co.il)
  • Download Status Bar 12.3.0.1-signed ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • DT Whois 1.7.1-signed (beysim@beysim.net)
  • Evernote Web Clipper 6.1 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Extended Statusbar 2.0.3.1-signed ({daf44bf7-a45e-4450-979c-91cf07434c3d})
  • Favicon Picker 2 0.6.2.15.1-signed ({446c03e0-2c35-11db-a98b-0800200c9a66})
  • FavIconReloader 0.8.1-signed (FavIconReloader@mozilla.org)
  • Firebug 2.0.13 (firebug@software.joehewitt.com)
  • Firefogg 351 (firefogg@firefogg.org)
  • New Tab Override (browser.newtab.url replacement) 2.2.1 (newtaboverride@agenedia.com)
  • NewTabURL 2.2.3.1-signed (newtaburl@sogame.cat)
  • Pearl Crescent Page Saver 2.8.3 ({c151d79e-e61b-4a90-a887-5a46d38fba99})
  • Pocket 3.0.6.1-signed (isreaditlater@ideashower.com)
  • Restart Firefox 0.5.1-signed (restart@restart.org)
  • Restore empty favicon 1.0.1-signed (restoreemptyfavicon@waldi.firefox.com)
  • ScrapBook 1.5.13.1-signed ({53A03D43-5363-4669-8190-99061B2DEBA5})
  • Second Home Page Button 1.2.1-signed (secondhomepagebutton@firefox)
  • Session Manager 0.8.1.8 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Homepage New Tab 1.0.8.1-signed (HomepageNewTab@neocodex.us) (không hoạt động)
  • New Tab Homepage 0.5.0 ({66E978CD-981F-47DF-AC42-E3CF417C1467}) (không hoạt động)
  • Undo Closed Tabs Button 3.9.8 (undoclosedtabsbutton@supernova00.biz) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
FredMcD
  • Top 10 Contributor
4248 giải pháp 59433 câu trả lời
Được đăng

Câu trả lời hữu ích

Are these tabs you are opening, or do they open themselves?

Are these tabs you are opening, or do they open themselves?

Người tạo câu hỏi

They are tabs I open myself.

Some by clicking on links where target is set to _blank Some by using another program that opens the default browser with a link, such as 1password.

In these cases a new tab is opened in the background.

Before the the Firefox update they would open as foreground tabs, and if Firefox was minimized, it would come back into view. Now they oipen in the background and Firefox remains minimized.

They are tabs I open myself. Some by clicking on links where target is set to _blank Some by using another program that opens the default browser with a link, such as 1password. In these cases a new tab is opened in the background. Before the the Firefox update they would open as foreground tabs, and if Firefox was minimized, it would come back into view. Now they oipen in the background and Firefox remains minimized.
FredMcD
  • Top 10 Contributor
4248 giải pháp 59433 câu trả lời
Được đăng

Type about:preferences#general<enter> in the address bar. Under Tabs, turn on When Open New Link, Switch To It.

Type '''about:preferences#general'''<enter> in the address bar. Under '''Tabs,''' turn on '''When Open New Link, Switch To It.'''

Người tạo câu hỏi

Thanks fr your answer. Unfortunately that option was already checked.

After reading your suggestion I unchecked that option and closed Firefox. Then I reopened it and checked the option again. Closed Firefox again, then restarted it and tried again. It didn't change the browser behavior.

Thanks fr your answer. Unfortunately that option was already checked. After reading your suggestion I unchecked that option and closed Firefox. Then I reopened it and checked the option again. Closed Firefox again, then restarted it and tried again. It didn't change the browser behavior.
FredMcD
  • Top 10 Contributor
4248 giải pháp 59433 câu trả lời
Được đăng

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


You have two add-ons that look to do the same thing.

New Tab Override (browser.newtab.url replacement) 2.2.1 (newtaboverride@agenedia.com) NewTabURL 2.2.3.1-signed (newtaburl@sogame.cat)

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ---------- You have two add-ons that look to do the same thing. New Tab Override (browser.newtab.url replacement) 2.2.1 (newtaboverride@agenedia.com) NewTabURL 2.2.3.1-signed (newtaburl@sogame.cat)

Người tạo câu hỏi

Yes, though I thought NewTabUrl was disabled because it stopped working after the upgrade. I just disabled both, but again, with no result.

I don't want to, but do you think uninstalling Firefox and reinstalling from scratch would fix this?

Yes, though I thought NewTabUrl was disabled because it stopped working after the upgrade. I just disabled both, but again, with no result. I don't want to, but do you think uninstalling Firefox and reinstalling from scratch would fix this?

Người tạo câu hỏi

I forgot to say I tried your recommendation of starting in safe mode, but the problem was still there.

I forgot to say I tried your recommendation of starting in safe mode, but the problem was still there.
FredMcD
  • Top 10 Contributor
4248 giải pháp 59433 câu trả lời
Được đăng

Giải pháp được chọn

Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

'''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} Save the file. Then; Using your file browser, open the '''Programs Folder''' on your computer. '''Windows:''' C:\Program Files C:\Program Files (x86) '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. Look for, and rename any Mozilla or Firefox folders by adding '''.old''' to them. After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

Người tạo câu hỏi

Fred, thanks very much! Removing the profile (on a Mac: library/Application Support/Firefox) gave be a new installation. Signing back into my sync account restored add-ons (which I culled -- good time for it). So I don't seem to have lost much, but the tabs are now opening in the foreground where I want them.

Thanks again for sticking with me and getting this solved.

Dan

Fred, thanks very much! Removing the profile (on a Mac: library/Application Support/Firefox) gave be a new installation. Signing back into my sync account restored add-ons (which I culled -- good time for it). So I don't seem to have lost much, but the tabs are now opening in the foreground where I want them. Thanks again for sticking with me and getting this solved. Dan
FredMcD
  • Top 10 Contributor
4248 giải pháp 59433 câu trả lời
Được đăng

Glad to help. Safe Surfing.

BTW, the profile is separate from the program files that were replaced.

Glad to help. Safe Surfing. BTW, the profile is separate from the program files that were replaced.
sskiser 0 giải pháp 1 câu trả lời
Được đăng

I don't want Facebook automatically opening when I open Firefox. It is thus lurking and observing what I am doing and showing that I am on FB constantly. I am going to delete all of FB if I cannot clear this up easily. Thanks.

I don't want Facebook automatically opening when I open Firefox. It is thus lurking and observing what I am doing and showing that I am on FB constantly. I am going to delete all of FB if I cannot clear this up easily. Thanks.