X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox hangs (along with other odd behaviour) due to gifs

Được đăng

Ever since a recent update Firefox has displayed some odd behaviour surrounding gifs. Occasionally, after viewing pages with large numbers of gifs and/or several very large gifs, Firefox will do things like not animate gifs, or even not load images at all,a and won't stop until I restart Firefox. What is more concerning is that sometimes in these situations Firefox will simply hang and stop responding, forcing me to kill the process. This page shows the hanging behaviour pretty consistently: http://www.neogaf.com/forum/showthread.php?t=1021843&page=21 It seems more likely to happen when I scroll through the page quickly. The behaviour persists when I restart Firefox in Safe Mode.

Ever since a recent update Firefox has displayed some odd behaviour surrounding gifs. Occasionally, after viewing pages with large numbers of gifs and/or several very large gifs, Firefox will do things like not animate gifs, or even not load images at all,a and won't stop until I restart Firefox. What is more concerning is that sometimes in these situations Firefox will simply hang and stop responding, forcing me to kill the process. This page shows the hanging behaviour pretty consistently: http://www.neogaf.com/forum/showthread.php?t=1021843&page=21 It seems more likely to happen when I scroll through the page quickly. The behaviour persists when I restart Firefox in Safe Mode.

Giải pháp được chọn

Firefox 39 seems to have fixed the issue.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • DivX Web Player version 1.4.0.233
  • This is the DjView-4.9 version of the DjVu plugin.See DjVuLibre.
  • Version: 5.41.0.0
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Unity Player 5.0.1f1
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Ứng dụng

  • Firefox 37.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/37.0.1/Linux/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Context Search 0.6.3 ({902D2C4A-457A-4EF9-AD43-7014562929FF})
  • DownThemAll! 2.0.18 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flagfox 5.0.13 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Form History Control 1.4.0.3 (formhistory@yahoo.com)
  • GNotifier 1.8.8 (jid1-OoNOA6XBjznvLQ@jetpack)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • MathML-fonts 2.1 (MathML-fonts@mozilla.com)
  • Mozilla Archive Format 3.0.4 ({7f57cf46-4467-4c2d-adfa-0cba7c507e54})
  • Multiple Tab Handler 0.8.2015030601 (multipletab@piro.sakura.ne.jp)
  • Open With 5.7.2 (openwith@darktrojan.net)
  • Places Maintenance 1.3 (places-maintenance@bonardo.net)
  • Print Edit 15.4 (printedit@DW-dev)
  • Restartless Restart 9 (restartless.restart@erikvold.com)
  • SPDY indicator 2.2 (spdyindicator@chengsun.github.com)
  • Tab Scope 1.6.1 (tabscope@xuldev.org)
  • Translate This! 3.0.2 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • UAControl 0.1.3.1 (uacontrol@qz.tsugumi.org)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2014.07.01.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})
  • URL Fixer 4.1 ({0fa2149e-bb2c-4ac2-a8d3-479599819475})
  • webmFF 0.6 (jid1-jC0Q82QgwC1EJQ@jetpack)
  • Y U no validate 2013052401 ({20d36f97-15da-47ed-9f0a-13cbe85bdc84})
  • Zotero 4.0.26.4 (zotero@chnm.gmu.edu)
  • Zotero LibreOffice Integration 3.5.9 (zoteroOpenOfficeIntegration@zotero.org)
  • Flash Video Downloader - YouTube HD Download [4K] 7.2.3 (artur.dubovoy@gmail.com) (không hoạt động)
  • Lightbeam 1.2.1 (jid1-F9UJ2thwoAm5gQ@jetpack) (không hoạt động)
  • NoScript 2.6.9.21 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (không hoạt động)
  • Print pages to PDF 0.1.9.3 (printPages2Pdf@reinhold.ripper) (không hoạt động)
  • Shumway 0.10.344 (shumway@research.mozilla.org) (không hoạt động)
  • YouTube ALL HTML5 2.1.3 (jid1-qj0w91o64N7Eeg@jetpack) (không hoạt động)
  • YouTube Center 2.1.0 (jid1-cwbvBTE216jjpg@jetpack) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.3.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
guigs 1072 giải pháp 11697 câu trả lời
Được đăng

Is Shockwave Flash 17.0 r0 compatible with linux?

Try Safe Mode first to see if its hardware acceleration or an issue with an installed add on.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Is Shockwave Flash 17.0 r0 compatible with linux? Try Safe Mode first to see if its hardware acceleration or an issue with an installed add on. '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Người tạo câu hỏi

guigs2 said

Is Shockwave Flash 17.0 r0 compatible with linux? Try Safe Mode first to see if its hardware acceleration or an issue with an installed add on. Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem.

As stated above, I already tried safe mode. The problem persisted.

Also, I have Shockwave Flash 17.0 r0 installed via pipelight, which is a wrapper that allows me to use Windows plugins via wine on Linux. That said, I am confident that that isn't causing the problem, since I made sure all my plugins were set to "ask to activate", and I did not authorize Flash to load.

''guigs2 [[#answer-717742|said]]'' <blockquote> Is Shockwave Flash 17.0 r0 compatible with linux? Try Safe Mode first to see if its hardware acceleration or an issue with an installed add on. '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. </blockquote> As stated above, I already tried safe mode. The problem persisted. Also, I have Shockwave Flash 17.0 r0 installed via pipelight, which is a wrapper that allows me to use Windows plugins via wine on Linux. That said, I am confident that that isn't causing the problem, since I made sure all my plugins were set to "ask to activate", and I did not authorize Flash to load.
guigs 1072 giải pháp 11697 câu trả lời
Được đăng

Flash had another update yesterday. Also do you have the recommended driver for your version of Linux,

The one above might be too general, try to disable hardware acceleration when you load the page, then reload it to see if there is an immediate difference on that page--> Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Another recommendation I can give is to dry a beta or nightly version of Firefox to see if there were improvements on the release train:

Flash had another update yesterday. Also do you have the recommended driver for your version of Linux, *[[Firefox hangs or is not responding - How to fix]] The one above might be too general, try to disable hardware acceleration when you load the page, then reload it to see if there is an immediate difference on that page--> [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] Another recommendation I can give is to dry a beta or nightly version of Firefox to see if there were improvements on the release train: *[https://nightly.mozilla.org/]

Người tạo câu hỏi

guigs2 said

Flash had another update yesterday. Also do you have the recommended driver for your version of Linux, The one above might be too general, try to disable hardware acceleration when you load the page, then reload it to see if there is an immediate difference on that page--> Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems Another recommendation I can give is to dry a beta or nightly version of Firefox to see if there were improvements on the release train:

Since I have Flash set to "Ask to Activate", I can confirm that it has not been running when theses issues occur.

I am using the latest graphics drivers from the repositories for my Linux Distro.

Disabling hardware acceleration has no effect. Also, as a side note, I was under the impression that hardware acceleration didn't work on Linux yet.

I tried loading the page in Nightly. While I could not reproduce the hangs in Nightly, I was able to reproduce all of the other odd behaviour. In case it matters, Nightly told me that "Process Separation (e10s)" was on.

''guigs2 [[#answer-718372|said]]'' <blockquote> Flash had another update yesterday. Also do you have the recommended driver for your version of Linux, *[[Firefox hangs or is not responding - How to fix]] The one above might be too general, try to disable hardware acceleration when you load the page, then reload it to see if there is an immediate difference on that page--> [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] Another recommendation I can give is to dry a beta or nightly version of Firefox to see if there were improvements on the release train: *[https://nightly.mozilla.org/] </blockquote> Since I have Flash set to "Ask to Activate", I can confirm that it has not been running when theses issues occur. I am using the latest graphics drivers from the repositories for my Linux Distro. Disabling hardware acceleration has no effect. Also, as a side note, I was under the impression that hardware acceleration didn't work on Linux yet. I tried loading the page in Nightly. While I could not reproduce the hangs in Nightly, I was able to reproduce all of the other odd behaviour. In case it matters, Nightly told me that "Process Separation (e10s)" was on.

Người tạo câu hỏi

Are there any more troubleshooting steps I can try? None of the provided ones have helped.

Are there any more troubleshooting steps I can try? None of the provided ones have helped.
Aleksej
  • Locale Leader
3 giải pháp 41 câu trả lời
Được đăng

Câu trả lời hữu ích

Somebody filed a bug report about a similar issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1155482

Somebody filed a bug report about a similar issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1155482

Giải pháp được chọn

Firefox 39 seems to have fixed the issue.

Firefox 39 seems to have fixed the issue.