Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot change default search engine from DuckDuckGo to something else

  • 2 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 6 views
  • Last reply by Vladimir G. Ivanović

Even in safe mode, I cannot make a change to my default search engine stick; it always reverts to DuckDuckGo.

After changing the default search engine in Preferences->Search to, say, Ecosia Search, typing a space character in the address+search bar goes from a generic world favicon to DuckDuckGo. Restarting with a cleared cache doesn't help.

None of my addons are related to search except Ecosia Search. Even with Ecosia Search removed, I get the same behavior, the default search engine reverts to DuckDuckGo. In any case, safe mode with all addons disabled doesn't change that behavior.

If i remove DuckDuckGo from the list of search engines, I cannot search at all and I cannot choose a default search enigne from the drop down list in Preferences->Search.

Note that I can always choose an alternate search engine in the drop down search menu, and that works. Setting a default search engine doesn't work.

Any suggestions on how to make a search engine other than DuckDuckGo be my default search engine would be appreciated. As a bonus, an explanation of why I'm having this difficulty would be wonderful.

TIA.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi, you appear to be using Firefox from the repositories (distributionID: archlinux), so it is possible this is related

You can try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


You can rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild search.json.mozlz4 from the builtin search engines.

Read this answer in context 👍 0

All Replies (2)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi, you appear to be using Firefox from the repositories (distributionID: archlinux), so it is possible this is related

You can try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


You can rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild search.json.mozlz4 from the builtin search engines.

Helpful?

You are correct, I am using the Arch Linux distribution, but your solution of quitting Firefox, deleting the file search.json.mozlz4 worked. (There was a momentary hiccup when Firefox seemed to want to insist on using Google, but some antiacid in the the form or a restart cured the problem.)

Thanks.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.