Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

drop down url box

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el

the "new firefox" keeps filling my screen (slightly annoyingly) with what I am guessing is recent dropdown url suggestions

I dont want the dropdown suggestions - I dont want to delete history

I'd just like to revert back to the behaviour that......that previous version of firefox had

not possible?

All Replies (4)

Hello quartz,

This is a temporary fix, but I am hoping that they will change their mind and give us the option to permanently disable this new behavior.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :


and set its value to false

Do the same with these preferences :




Then close and restart Firefox.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

In case you have a userChrome.css file (or are willing to create one), please see this, what I call "masterpiece", written by fellow contributor jscher2000 :

You can set this pref to 0 on the about:config page or disable all suggestions that are shown in the location/address bar drop-down list.

  • browser.urlbar.maxRichResults = 0

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the address bar, suggest:

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

I'll try those, thanks. can't restart firefox for a while, because....I'm using firefox. :)

big trick being missed here from the devs. - all you need on each dropdown entry is a 'X', where you can remove the dropdown entry. shift-delete didn't remove them

also if I "removed" the item from the dropdown, I *dont* want to remove it from the history. I just don't want it being on the dropdown. (!) I'm actually really not sure why some of those entries were there. some of them were url's that I didn't even have open in current tabs

quartz மூலமாக திருத்தப்பட்டது

You probably do not need to close and restart Firefox for the suggestions I posted (not sure about the prefs that McCoy posted, but those may work in a new window). You can't remove an item only from the location bar drop-down list and not from the history. This list is generated from the history (places.sqlite database) via specific queries, so as long as a history or bookmark (with star) item exists it will be shown as long as it meets the query parameters.