Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No sound in Firefox only

  • 10 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 199 views
  • Last reply by jscher2000

Since Firefox Quantum 60, i have no sound in Firefox at all, also most videos don't play, except for WEBM & Ogg (But still no sound on either)

I have reinstalled flash 5 times to no avail. I have followed every support page i could find, did not fix it. I have started firefox in safemode, still no cigar, i have reset firefox completely with a fresh profile, still not fixed.

Yes, volume sliders are checked and are on full volume, but there is no audio output shown at all from firefox. I have disabled tracking protection, hardware acceleration, and everything there is to mess with in the general settings, still no sound. I have also set the all sandbox.content.levels to 0 or 1 as a test, which unfortunately did not fix the issue either.

I'm using Windows 7 x64

Console errors: Youtube: No decoders for some of the requested formats: video/webm; codecs="vp09.02.51.10.01.09.16.09", video/mp4; codecs="avc1.42001E mp4a.40.2", video/mp4; codecs="avc1.4d4015", video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401f", video/mp4; codecs="avc1.4d401f", video/mp4; codecs="avc1.640028", audio/mp4; codecs="mp4a.40.2", video/mp4; codecs="avc1.4d400c"

Soundcloud: No decoders for some of the requested formats: audio/mpeg, audio/mpeg, audio/mp4; codecs="mp3", audio/ogg; codecs="opus", audio/mpeg, audio/mpeg, audio/mp4; codecs="mp3", audio/ogg; codecs="opus", audio/mpeg, audio/mpeg, audio/mp4; codecs="mp3", audio/ogg; codecs="opus"

All Replies (10)

Hi, Flash has nothing to do with most Sound and Video now as it is HTML5

Do you have a Check Mark in the Box to allow playing DRM Content ? DRM Rights Management in Options - General the page that opens

Is WIldvine installed in Plug-ins ( go to Add-ons then plugins) ?

VIDEO AUDIO

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Yes i forgot to add that i also cannot play any flash videos, or use any flash content at all for that matter in addition to the missing sound, but maybe that should be another topic.

I have added screenshots of the Youtube test, and it shows H.264 & MSE & H.264 as faulty. The rest are also checked, and widewine is installed and always activated.

And yes i have both tried to run safe mode, and doing a complete refresh, with a new profile.. also did a complete reinstall of firefox to a different location, and also with a fresh profile... still no luck.

Hadong மூலமாக திருத்தப்பட்டது

Anyone ? It's been months now, please help me get Firefox back. Chrome is so damn slow, and crashing all the time.

Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Thanks, but i already stated in my prior comment above, that i have done a complete refresh/reset, and a new profile to no avail, and in addition to a full re-install, and install to another location, with yet another new profile.

My cookies and cache have always been cleared on exit.

Anyone ? Please!

Hadong மூலமாக திருத்தப்பட்டது

Unable to display map: browser does not support WebGL

Bump

Hadong said

Unable to display map: browser does not support WebGL Bump

I've called for help - hang in there  !

Hadong said

I have added screenshots of the Youtube test, and it shows H.264 & MSE & H.264 as faulty. The rest are also checked, and widewine is installed and always activated.

If after a Refresh Firefox cannot handle MPEG-encoded media, please check: Fix video and audio playback problems on Firefox for Windows.

Hadong said

Unable to display map: browser does not support WebGL

What site is that on? Please check: Upgrade your graphics drivers to use hardware acceleration and WebGL.

Also: If a site is generally known to work in Firefox, these are general suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?