Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is blocking popups that I want to see, even after I have unchecked the Block Popup Windows in Options.

  • 3 majibu
  • 48 wana tatizo hili
  • 7 views
  • Last reply by cor-el

more options

There are several sites that provide popups that I want to see. Firefox had not been blocking them previously. Then today it did. I went to Options and listed these sites as exceptions. It still blocked them. I went to options and unchecked Block Popup Windows. It still blocked them. I uninstalled Firefox and reinstalled a new copy. It still blocks them. What do I do now?

BTW, this does not occur when I access the same sites with Internet Explorer.

There are several sites that provide popups that I want to see. Firefox had not been blocking them previously. Then today it did. I went to Options and listed these sites as exceptions. It still blocked them. I went to options and unchecked Block Popup Windows. It still blocked them. I uninstalled Firefox and reinstalled a new copy. It still blocks them. What do I do now? BTW, this does not occur when I access the same sites with Internet Explorer.

Modified by crisismode

All Replies (3)

more options

Which security software (firewall) do you have?

Some can block pop-ups, so you need to check there as well.


It is possible that you run into this maximum (the default value is 20):

more options

I have the same issue. I am using windows 7 ultimate and have it on a laptop which has no issues. It is only one pop up i want to come up and it blocks it. I am using zone alarm as well, and I turn it off and it makes no difference. IE works and I HATE Microsoft. I wish Mozilla would come up with a fix.

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Another possibility is that you run into this maximum (the default value is 20):