Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

about:config browser.fullscreen.animateUp has no effect

  • 5 svar
  • 8 har detta problem
  • 1 visning
  • Senaste svar av cor-el

more options

My original problem: I wanted to stop the molasses-like animation pulling the browser tabs and navbar off screen when I press F11. Unrelated to the fade-in/fade-out with fullscreen videos (which I'd already fixed).

I saw the preference browser.fullscreen.animateUp described in http://kb.mozillazine.org/Browser.fullscreen.animateUp and mentioned in https://support.mozilla.org/en-US/questions/1066680 . This seems to be what I'm looking for, or it used to …

My about:config did not have this preference by default. I added a preference with the proper name and tried setting it to string values "0", "1", and "2" and integer values 0, 1, and 2 with no effect either immediate or on Firefox restart. That is, the F11 animation did not change. After refreshing my Firefox through Troubleshooting Information, I tried all six again with still no effect.

My original problem: I wanted to stop the molasses-like animation pulling the browser tabs and navbar off screen when I press F11. Unrelated to the fade-in/fade-out with fullscreen videos (which I'd already fixed). I saw the preference browser.fullscreen.animateUp described in http://kb.mozillazine.org/Browser.fullscreen.animateUp and mentioned in https://support.mozilla.org/en-US/questions/1066680 . This seems to be what I'm looking for, or it used to … My about:config did not have this preference by default. I added a preference with the proper name and tried setting it to string values "0", "1", and "2" and integer values 0, 1, and 2 with no effect either immediate or on Firefox restart. That is, the F11 animation did not change. After refreshing my Firefox through Troubleshooting Information, I tried all six again with still no effect.

Vald lösning

Maybe try to set this pref to false:

  • toolkit.cosmeticAnimations.enabled = false

Some reading:

  • bug 1352069 - Introduce a pref that allows for disabling animations (toolkit.cosmeticAnimations.enabled)

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Läs svaret i sitt sammanhang 👍 7

Alla svar (5)

more options

You can modify these prefs on the about:config page to disable the full screen fade in and fade out. Leave out the quotes around the value (enter only two zeros separated by a space).

  • full-screen-api.transition-duration.enter: "0 0"
  • full-screen-api.transition-duration.leave: "0 0"

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

cor-el said

You can modify these prefs on the about:config page to disable the full screen fade in and fade out. Leave out the quotes around the value (enter only two zeros separated by a space).
  • full-screen-api.transition-duration.enter: "0 0"
  • full-screen-api.transition-duration.leave: "0 0"
You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Thank you, cor-el, for your answer. However, as I said in my question, my problem is "Unrelated to the fade-in/fade-out with fullscreen videos (which I'd already fixed)." It has rather to do with the dragging animation when entering fullscreen using F11 when, for example, Firefox is open to a local TXT file.

more options

Vald lösning

Maybe try to set this pref to false:

  • toolkit.cosmeticAnimations.enabled = false

Some reading:

  • bug 1352069 - Introduce a pref that allows for disabling animations (toolkit.cosmeticAnimations.enabled)

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Ändrad av cor-el

more options

cor-el said

Maybe try to set this pref to false:
  • toolkit.cosmeticAnimations.enabled = false
Some reading:
  • bug 1352069 - Introduce a pref that allows for disabling animations (toolkit.cosmeticAnimations.enabled)
(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Setting

  • toolkit.cosmeticAnimations.enabled = false

did indeed solve my problem. Thank you for the answer and links, cor-el!

more options

You're welcome.

This was new to me as well.