Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Message field too narrow

  • 27 replies
  • 0 have this problem
  • 88 views
  • Last reply by Toad-Hall

more options

The message field is too narrow for all messages, except pure text messages. A screenshot is attached. How can I modify the userChrome.css so that all available space gets used?

The message field is too narrow for all messages, except pure text messages. A screenshot is attached. How can I modify the userChrome.css so that all available space gets used?
Attached screenshots

All Replies (7)

more options

Thank you! ... I tried 'Simple HTML' and 'plain text' ... but this is not usable for me, because too much information gets lost.

I want to stay with 'Original HTML' and just set a default zoom level. ... How can I do that?

Helpful?

more options

okay, in config editor, available at settings>general, look for zoom.minpercent I think the default is 30. Increase in increments to find what works for you. You may have to restart thunderbird to see results.

Helpful?

more options

Ok, just tried it. ... But this zoomes the whole UI. ... I want to zoom only the messages.

Helpful?

more options

The reason you see some messages only using a smaller section of the available width is due to the html css code which the sender deliberately used to attempt to control how they want their message to look and the Font Size you choose to use. The example image you posted - that sender chose to use a table to contain the detail of the content which does not use most of the available space. It is set at a specific size. Using Ctrl + + you can 'zoom' that message content so that the pixel size is increased and thus everything becomes larger expanding until you stop increasing the zoom.

So as an example the width of the table may be set at 600px in the html css code. When you use 'zoom' you are not increasing the number of pixels they are still 600px, but you are increasing the size of an individual pixel so basically the same number of pixels is now using more space.

Basically, the fact that under normal settings some emails do not use all the space is because sender created email to look like that and if combined with reader choosing the widest option for Message Pane then even more unused space will be displayed. Obviously, no one can predict what a sender will put in their email, some use tables to control content and you cannot predict what table settings they choose or whether they set tables within tables. This means it's likely to be different for each email.

Currently, I've not investigated a way to control table elements of received emails which can be used in a userChrome.css file because it's not possible to rewrite the code for every email that contains a table with preset width settings. There is an addon called Header Tools Lite which I use to correct bad emails, but it's risky and not something for the average user as you may end up corrupting an email. It's not a general setting in Thunderbird. That's the problem - it's code put in by the sender and not code generated by Thunderbird. Hence why Zoom works because it can control pixel size.

If you use 'Simple HTML' then you will never have an issue. I'm not sure why you think data is lost because it isn't. You should just see less structural layout eg: it removes the tables.

However, if you are contantly needing to increase the Font Size in the Message Pane by manually using Zoom, for all emails in general because you find it difficult to read incoming mail then your Font Size settings for reading and writing email maybe too small.

  • Settings > General
  • scroll to 'Language & Appearance'
  • click on 'Advanced'.

Whatever size you are currently see you need to increase it. You need to set same setting for both 'Latin' (western encoding) and 'Other Writing Systems' (unicode encoding).

  • Select 'Fonts for: choose 'Latin'
  • Set 'Proportional Size' to eg: 18
  • Set 'Monospace Size' to 18
  • Set minimum size to 16 (allows a bit smaller but stops smaller font size)
  • Now set identical settings for 'Fonts for:' and select 'Other Writing Systems' (bottom of drop down list).
  • Finally, ReSelect 'Fonts for: choose 'Latin'
  • click on 'OK' to save new settings.

From now onwards the 'medium' font displayed in Message Pane and when you compose a message will be size 18px. If you need a larger size than 18, then follow same instructions, but increase the sizes to use eg: 20

Helpful?

more options

Thank you, Toad-Hall, for trying to help! ... I really appreciate this. ... I have been using Thunderbird for 25 years now, loving it all the time, and I don't want to leave it behind.

Now to your points:

1. Simple HTML

Toad-Hall said

If you use 'Simple HTML' then you will never have an issue. I'm not sure why you think data is lost because it isn't. You should just see less structural layout eg: it removes the tables.

Embedded pictures are missing which sometimes contain important information and the structural layout itself sometimes also provides valuable context. Therefore 'Simple HTML' is unfortunately not an option for me.

2. I tried your method of increasing the font size. Please have a look at Screenshot 1. The result is horrible, not readable.

3. Ok, I understand that using css to change the emails may not be the way to go. ... But since the zoom-function gives me a perfect result (Screenshot 2): How can I set a default zoom-level for all messages?

Helpful?

more options

Since the problem got narrowed down to the default zoom level, ... I open a new thread specifically for this question. Thank you for trying to solve this issue!

Helpful?

more options

Thomas likes to learn said

Since the problem got narrowed down to the default zoom level, ... I open a new thread specifically for this question. Thank you for trying to solve this issue!

For anyone reading this question who wants to know how to set up your Ctrl++ zoom so that it has a larger set of increments which can be set up as a personal choice then go to the new question posted by same person to see a solution.

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.