X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Google Earth Plugin Outdated Version

Размещено

I checked my plug-in and was told the Google Earth Plugin was outdated. I clicked on the "Update" option but nothing happened. Usually when I clicked on that option, it'll open the developer's website so I can proceed the update. But this one just sat there and nothing happened. So how could I update this plug-in?

Thank you.

I checked my plug-in and was told the Google Earth Plugin was outdated. I clicked on the "Update" option but nothing happened. Usually when I clicked on that option, it'll open the developer's website so I can proceed the update. But this one just sat there and nothing happened. So how could I update this plug-in? Thank you.

Выбранное решение

Open up Add-Ons and disable the Google Earth one. Go to http://www.google.com/intl/en_us/earth/explore/products/plugin.html and install the new one over the old one, which will need enabling - simples!

Прочитайте этот ответ в контексте 43

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 11.2 r202
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Version 2.8.7.6830
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • Foxit Reader Plug-In For Firefox and Netscape
  • IE Tab Plug-in for Mozilla/Firefox
  • Photosynth 2.109.1002.1657
  • NPWLPG
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Rhapsody Player Engine Plugin
  • 1.7.0036.0
  • np-mswmp
  • 1.6.0021.0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

Дополнительная информация

TonyE
  • Moderator
1044 решений 8863 ответов
Размещено

A couple of choices, if you want the latest version of Google Earth and the plugin, get it from http://www.google.com/earth/index.html

If you just want the plugin, you can get it from http://www.google.com/intl/en_us/earth/explore/products/plugin.html

A couple of choices, if you want the latest version of Google Earth and the plugin, get it from http://www.google.com/earth/index.html If you just want the plugin, you can get it from http://www.google.com/intl/en_us/earth/explore/products/plugin.html
Размещено

Задавший вопрос

I opened my Google Earth to check if there's any new update, none.

The 2nd link you sent me wasn't for Firefox. I am talking about the Firefox Plug-in. Usually, when I checked the Plug-in update, if there's any is out-of-date, I can just clicked the "Update" option and it'll bring me to the developer site and I'll proceed the update from there. But for 'Google Earth', it didn't do that. When I clicked on 'Update', nothing happened.

I opened my Google Earth to check if there's any new update, none. The 2nd link you sent me wasn't for Firefox. I am talking about the Firefox Plug-in. Usually, when I checked the Plug-in update, if there's any is out-of-date, I can just clicked the "Update" option and it'll bring me to the developer site and I'll proceed the update from there. But for 'Google Earth', it didn't do that. When I clicked on 'Update', nothing happened.
richlaughlin 4 решений 146 ответов
Размещено

Полезный ответ

Hi

I have exactly the same problem. I have an outdated plugin but the "Update" link doesn't do anything. When i browse to the plugin link suggested by TonyE it says "Good news – you already have the Google Earth Plug-in installed. (Version 6.1.0.5001)" There appears to be no link to download the up-to-date plugin

thanks ...

Hi I have exactly the same problem. I have an outdated plugin but the "Update" link doesn't do anything. When i browse to the plugin link suggested by TonyE it says "Good news – you already have the Google Earth Plug-in installed. (Version 6.1.0.5001)" There appears to be no link to download the up-to-date plugin thanks ...
1 решений 2 ответов
Размещено

Выбранное решение

Open up Add-Ons and disable the Google Earth one. Go to http://www.google.com/intl/en_us/earth/explore/products/plugin.html and install the new one over the old one, which will need enabling - simples!

Open up Add-Ons and disable the Google Earth one. Go to http://www.google.com/intl/en_us/earth/explore/products/plugin.html and install the new one over the old one, which will need enabling - simples!
richlaughlin 4 решений 146 ответов
Размещено

Well not quite 'simples' i'm afraid. After installing the plugin, I still have 6.1.0.5001 listed, and when i enable it, firefox plugin checker tells me it's still outdated.

Well not quite 'simples' i'm afraid. After installing the plugin, I still have 6.1.0.5001 listed, and when i enable it, firefox plugin checker tells me it's still outdated.
richlaughlin 4 решений 146 ответов
Размещено

A restart of my machine has now fixed the problem. 6.2.0.5788 is listed and ticked by the checker.

thanks for your help....

A restart of my machine has now fixed the problem. 6.2.0.5788 is listed and ticked by the checker. thanks for your help....
1 решений 2 ответов
Размещено

Glad it worked. Sorry I forgot to mention that I did the 'upgrade' with Firefox closed so didn't need a restart.

Glad it worked. Sorry I forgot to mention that I did the 'upgrade' with Firefox closed so didn't need a restart.
Размещено

Задавший вопрос

pineman -- Thank you for the tip. I went to the link and downloaded the plug-in, then restart FF and now I have the latest version of Google Earth plug-in.

pineman -- Thank you for the tip. I went to the link and downloaded the plug-in, then restart FF and now I have the latest version of Google Earth plug-in.
ribroast 0 решений 16 ответов
Размещено

How do you download the new plugin ...i see no download....sorry not savy..I have disabled the incompatible one .

How do you download the new plugin ...i see no download....sorry not savy..I have disabled the incompatible one .
Размещено

Задавший вопрос

ribroast -- Did you open the link that pineman posted (the solution I chose)? After you open that link, you should see "Download Google Earth Plug-in" option on the right.

ribroast -- Did you open the link that pineman posted (the solution I chose)? After you open that link, you should see "Download Google Earth Plug-in" option on the right.
ribroast 0 решений 16 ответов
Размещено

Oh yes. but it has not corrected the plugin . still the old one disabled. i will have another go.thank you.

Oh yes. but it has not corrected the plugin . still the old one disabled. i will have another go.thank you.
silkphoenix 91 решений 1257 ответов
Размещено

ribroast -- For some strange reason, to update the Google Earth Plug-in, you'll have to either RESTART your FF or your PC. In my case, I have to restart my FF before the plug-in will show the latest version. richlaughlin said he has to restart his PC.

You can try to restart your FF to see if it works, if not, then restart your PC.

ribroast -- For some strange reason, to update the Google Earth Plug-in, you'll have to either RESTART your FF or your PC. In my case, I have to restart my FF before the plug-in will show the latest version. richlaughlin said he has to restart his PC. You can try to restart your FF to see if it works, if not, then restart your PC.
ribroast 0 решений 16 ответов
Размещено

Thank you I see it now in my add on manager but it is still disabled so I will enable and see what happens ...if anything. Thank you.

Thank you I see it now in my add on manager but it is still disabled so I will enable and see what happens ...if anything. Thank you.