Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Full screen video does not fill screen horizontally Mac

  • 1 ответ
  • 1 имеет эту проблему
  • 1 просмотр
  • Последний ответ от zeroknight

more options

When I watch fullscreen videos in another browser (Chrome, Safari, etc.) on my Mac the video fills the entire screen. For some reason when doing the same in firefox the video does not reach to fill the entire screen and instead only occupies the middle. I tried screenshotting to illustrate this behavior but the screenshot was restricted to this middle zone as well. It seems like somehow firefox is shrinking the display size when no other browser exhibits the same behavior.

It also seems like if I want I can drag the video window around in fullscreen moving the whole video player around my display. I shouldn't have to drag the thing around to get the video to play right.

When I watch fullscreen videos in another browser (Chrome, Safari, etc.) on my Mac the video fills the entire screen. For some reason when doing the same in firefox the video does not reach to fill the entire screen and instead only occupies the middle. I tried screenshotting to illustrate this behavior but the screenshot was restricted to this middle zone as well. It seems like somehow firefox is shrinking the display size when no other browser exhibits the same behavior. It also seems like if I want I can drag the video window around in fullscreen moving the whole video player around my display. I shouldn't have to drag the thing around to get the video to play right.

Выбранное решение

Go to about:config and change full-screen-api.macos-native-full-screen to true.

Прочитайте этот ответ в контексте 👍 7

Все ответы (1)

more options

Выбранное решение

Go to about:config and change full-screen-api.macos-native-full-screen to true.