Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Time Zone not updating

  • 10 ответов
  • 4 имеют эту проблему
  • 35 просмотров
  • Последний ответ от zeroknight

more options

I have a macbook pro. For some reason the time zone in the browser is one hour behind. Every page I go to asks me to use my current location, but still, the time zone doesn't update. The other browsers work just fine. I uninstalled and reinstalled Firefox, deleted cookies, but nothing worked.

Please advice

thx

I have a macbook pro. For some reason the time zone in the browser is one hour behind. Every page I go to asks me to use my current location, but still, the time zone doesn't update. The other browsers work just fine. I uninstalled and reinstalled Firefox, deleted cookies, but nothing worked. Please advice thx

Все ответы (10)

more options

Go to about:config and make sure privacy.resistFingerprinting is default false.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

WARNING from the moderator team: Changing Firefox preferences from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing. Please read Firefox Advanced Customization and Configuration Options to learn more.

Изменено Paul

more options

It didn't fix the problem. Odd thing is that my ios Firefox's time zone is correct.

more options

Which website are you using to check the time?

A few countries (such as the UK) change their clocks around this time of year by an hour.

more options

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

No VPN I am using Firefox on macos sonoma 14.0. I am also using Firefox macbook pro mid 2012 macos catalina, and the time zone works just fine. The website has the correct time zone, in all browsers, except Firefox. Deleted and re-installed firefox multiple times, clear history, cookies, cache. The time zone is still one hour behind. I allowed for the site to use my location. Then I blocked. Problem persists.

more options

mm.nacho said

The website

Do you see this on a different website like https://webbrowsertools.com/timezone/?

more options

I tried all the options from the drop-down list. The time was 1 hour behind than mine. It must be a problem with Firefox and macos sonoma. Because every other browser and app is in sync.

more options

This is not caused by the privacy.resistFingerprinting since I have it set to False.

I have this same issue. When searching for the issue on the internet, I found that this is related to MacOS Sonoma indeed. In my machine only Safari displays the time correctly. Both Firefox and Chrome are 1 hour behind. I tested this by visiting https://everytimezone.com website on the three browsers.

This hasn't broken web browsing. However, in apps such as MS Teams, Gmail, Slack, etc., where message times are displayed, all times are 1 hour behind.

At this point this is a known issue and I was able to see that Chrome will be fixing the root cause in their next update. It might be a low level OS API call that might have either changed or deprecated in MacOS Sonoma that can be causing this behavior.

more options

Paste each of these one at the time in the command line, press Enter to see the result if Firefox doesn't already shows this after pasting/replacing.

  • "3-bar" menu button or Tools -> Web Developer
(new Date());

(new Date()).toString();

(new Date()).toLocaleString("en-US",{weekday:"long",day:"numeric",month:"long",year:"numeric",hour:"numeric",minute:"numeric",second:"numeric",hour12:false,timeZoneName:"short"});

more options

This should be fixed in Firefox 119 (Bug 1856428).