Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Video autoplay blocking issue

  • 6 ответов
  • 2 имеют эту проблему
  • 58 просмотров
  • Последний ответ от zeroknight

more options

Autoplay media blocking does not work. I've tried to block autoplay on sites settings and also done this about:config fix without results.

   media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
   media.autoplay.blocking_policy = 2
   media.autoplay.allow-extension-background-pages = false
   media.autoplay.block-event.enabled = true '

Videos still start playing in some websites. I've noticed that when reloading the page, then autoplay blocking works.

Example: https://www.iltalehti.fi/formulat/a/35242327-7699-45a2-a1b5-75ff330a9d13 When i go to page first time, it shows on the left of address bar, that autoplay function is not even enabled (no autoplay block icon). When i reload/refresh the page, then it shows that autoplay is disabled and autoplay block is working properly (icon appears).

So it's only issue when visiting the page first time, if page is refreshed, no issues.

Autoplay media blocking does not work. I've tried to block autoplay on sites settings and also done this about:config fix without results. media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll] media.autoplay.blocking_policy = 2 media.autoplay.allow-extension-background-pages = false media.autoplay.block-event.enabled = true '''' Videos still start playing in some websites. I've noticed that when reloading the page, then autoplay blocking works. Example: https://www.iltalehti.fi/formulat/a/35242327-7699-45a2-a1b5-75ff330a9d13 When i go to page first time, it shows on the left of address bar, that autoplay function is not even enabled (no autoplay block icon). When i reload/refresh the page, then it shows that autoplay is disabled and autoplay block is working properly (icon appears). So it's only issue when visiting the page first time, if page is refreshed, no issues.
Приложенные скриншоты

Все ответы (6)

more options

I suppose the last line contains a typo ( ').

Try setting this value also. media.block-autoplay-until-in-foreground = false

Полезно?

more options

Yes, it was a typo and was already set to: false. This issue is somehow related to page loading, because page refresh does correct it.

Полезно?

more options

Autoplay is blocked for me on your example site with those settings, regardless of navigation method.

The blocked autoplay icon only appears if something tries to autoplay. Animated images are not treated as playable media and will never be blocked.

Does it still happen in Troubleshoot Mode?

Полезно?

more options

This autoplay issue happens also in troublehoot mode. Only page refresh stops video autoplay.

I just noticed that the ink in my starting post (if i click the direct link) video autoblock works. But when i go example to: https://www.iltalehti.fi/ and click any news link, videos start autoplaying until i refresh the page.

Изменено P X R I

Полезно?

more options

Just noticed that direct link that i posted first, if i click the link, autoplay block does work.

If i go to https://www.iltalehti.fi/ and click any news link, then video autoplay block does not work. Blocking works only after page refresh.

This happens in many other sites as well.

Изменено P X R I

Полезно?

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.