Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Cannot send emails from Thunderbird, except from my Default one

  • 31 ответ
  • 2 имеют эту проблему
  • 34 просмотра
  • Последний ответ от Marilou

more options

Hello, I have 5 email addresses - four I use regularly: TalkTalk1 (Default) and 2, Free-online and Googlemail (haven't upgraded to gmail), and one I haven't for ages (YahooMail). I cannot send emails from any, except from my TalkTalk(TT) default one. I have updated the TalkTalk new Outgoing server settings to the best of my ability, for TalkTalk2 (TT2), Free-online (FOL) and Googlemail (GM) - I can send screenshots for each if necessary: - Server names: all smtp.domain name.net, except FOL: relay.free-online.net (verified on several google searches) - Outgoing port: all changed to 587 - Connection security: all STARTTTLS - Authentication method: all 'Normal password' (I am assuming these would be the same as the ones in the saved login passwords section of Privacy & Security, except for GM which has Incoming server authentication OAuth2 but a normal password in the saved login Passwords) - User name: my email addresses, except for FOL: my name Details: Email providers: TalkTalk, Free-online (Plusnet), Googlemail ISP: Talktalk.net Operating system: MacOS Catalina 10.15.7 Thunderbird version: 102.8.0 Many thanks for your help, it is now the 8th day I spend on this (I am a senior not very techy person).

Hello, I have 5 email addresses - four I use regularly: TalkTalk1 (Default) and 2, Free-online and Googlemail (haven't upgraded to gmail), and one I haven't for ages (YahooMail). I cannot send emails from any, except from my TalkTalk(TT) default one. I have updated the TalkTalk new Outgoing server settings to the best of my ability, for TalkTalk2 (TT2), Free-online (FOL) and Googlemail (GM) - I can send screenshots for each if necessary: - Server names: all smtp.domain name.net, except FOL: relay.free-online.net (verified on several google searches) - Outgoing port: all changed to 587 - Connection security: all STARTTTLS - Authentication method: all 'Normal password' (I am assuming these would be the same as the ones in the saved login passwords section of Privacy & Security, except for GM which has Incoming server authentication OAuth2 but a normal password in the saved login Passwords) - User name: my email addresses, except for FOL: my name Details: Email providers: TalkTalk, Free-online (Plusnet), Googlemail ISP: Talktalk.net Operating system: MacOS Catalina 10.15.7 Thunderbird version: 102.8.0 Many thanks for your help, it is now the 8th day I spend on this (I am a senior not very techy person).

Все ответы (20)

more options

It would be clearer if you could post the following:

In Thunderbird Menu icon > Help > More TRoubleshooting Information Scroll down to the 'Mail and News Accounts section.

Either copy all the text in that section and post it in this forum OR better still post an image showing that section.

This will tell us exactly which account is using what server settings. I have often found server settings not necessarilly set up for the specific account. eg: One smtp server for TalkTalk being used by more than one account and it causes issues. Or people editing the wrong SMTP server for the account.

Then it would be a case of resetting one at a time. Post the info and I will get back to you, but not today.

more options

Wow, I didn't know about this section, thank you so much for pointing it out to me. I am attaching a screenshot below this message.

However, having checked my present settings in Thunderbird > Settings > Privacy & Security, I note the following (in the order chosen by Mail and News Accounts'): 1. Account 1: only Incoming server details (but strange ones) - no Outgoing details 2. Account 2, Free-online: In, all correct - Out, 'relay.free-online.net' instead of smtp (verified with research). But also this is not my default account as far as I know (see Point 3 below) all others correct 3. Account 3, TalkTalk, assuming it is my Default address: In, all correct - Out, Server name shows '(Default)' at the end of the smtp address, all others correct 4. Account 4, TalkTalk, assuming it is my second TT address: In, all correct - Out, all correct except this is not my default account as far as I know (see Point 3 above) 5. There is no Account 5 6. Account 6, Googlemail: In, all correct - Out, all correct except this is not my default account as far as I know (see Point 3 above) 7. Account 7, Yahoo: this one is tricky, which is why I haven't used it until I had sorted it out (I get an error when signing in and everything I have tried so far has failed, so since I don't use it I'm not that fussed). And I have been getting this notification window when Thunderbird starts: 'Login to server smtp.mail.yahoo.com with username gfinley66@yahoo.com failed', which the option 'Enter new password'. However... In: all correct - Out, all correct except this is not my default account as far as I know (see Point 3 above). And the Authentication is 'Normal password' v OAuth2 in the Incoming settings

I do hope this makes sense to you, I have tried to be as complete but clear as I can. I can also send you screenshots of the various Outgoing server settings if you want. Don't worry about not being able to reply straight away, I am utterly grateful for the help you are giving me, plus I can do with not spending the whole day trying to sort this mess out.

With best wishes.

more options

The gmail and the yahoo accounts are not using the correct settings.

But I believe you want to get the TalkTalk2 account working first. The Account 3 and 4 is what we are talking about. You believe Account 3 is the default account and it's working ok. The server settings for both Account 3 and 4 look ok, but....is Account4 really using it's own smtp? Let's sort out that query first.

In Account Settings Left Pane - scroll down to the bottom below the 'Local Folders' account will be 'Outgoing Server (SMTP)' - click on that option. On the right you will see a list of your outgoing servers. You should have one for each email address - five in total. Starting at the top, select each one in turn and you will see the details of each one below. You are looking for the one which has User Name = the talktalk2 email address which does not send. When you have selected it, click on 'Edit' button (If you find the smtp for the TT2 does not exist then click on 'Add' button) It opens in a new window.

  • Description: Please type the email address which is the same as the User Name and it should be the TalkTalk2 email that is not sending.
  • 'User Name' - please make sure this is the full TT2 email address and there are no typos

Other settings should be:

  • smtp outgoing server name: smtp.talktalk.net
  • port: 587
  • Connection Security: STARTTLS
  • Authentication Method: Normal Password.

click on OK

Now please check to see if that TT2 account is set up to use that TT2 SMTP server.

In Account Settings In Left Pane - select the name of the TT2 mail account Look bottom right for 'Outgoing Server (SMTP)' The email address you entered in the 'Decription' field should be displaying. it should be identical to the selected TT2 account email address. DO NOT click on on the 'Edit SMTP_Server' button. Click on the drop down arrow to see other smtp servers in list and select the correct one which has TT2 email address.

This will confirm the TT2 account really is using it's own smtp server specifically for that email address.

Now you need to confirm you know the correct password for that TT2 email address. There is only one way of doing this. Logon to the TT2 webmail account via a browser. If the password you enter gets you access to that TT2 webmail account then you know it is good.

REport back when you can confirm the TT2 account is really using it's own smtp server and confirm you can get access to the TT2 webmail account.

more options

You're wonderful! I changed the Description, selected the correct Outgoing server, checked my password by accessing my Webmail account, and finally sent myself an email from this address, which I received. So this is a success (which left me wondering why TalkTalk couldn't give me this information...).

Btw, I had contacted TT on Facebook Messenger a few days ago about the whole issue and have received a reply telling me my issue has been escalated, my TT2 would be restored (1) and all others would follow suit (2). (1) I tried it before replying to you, without success (2) I tried sending an email from FOL (Account 2) to TT1 after restoring TT2 thanks to you, without success.

So... TT1 and TT2 (both private email addresses) work, shall we try FOL (my public email address), ie Account 2?

I love the way you present things, as I also work by bullet points, reading the lot then going through one after the other, slowly.

With huge thanks yet again.

more options

re: FOL (my public email address), ie Account 2

I notice you are using the Pop server name 'mail.free-online.net' which I believe is an older plusnet account. This could be for a Plusnet address (yourname@username.free-online.com) or a hosted domain address (yourname@yourdomain.co.uk).


The password required by Thunderbird will be the one you use to access the webmail account for that email address. So, it's always a good idea to double check by confirming you can get access to the webmail account for that email address.

  • In Account Settings
  • Left Pane - scroll down to the bottom
  • below the 'Local Folders' account will be 'Outgoing Server (SMTP)' - click on that option.
  • On the right you will see a list of your outgoing servers.

I'm not sure if you already have an smtp outgoing server in the list for that FOL email address, but check anyway.

  • Select each smtp in turn - You are looking for one that has the 'User Name' of the FOL email address.
  • If it exists - select it and click on 'Edit'
  • Then use the server setting info below to get all the correct information.
  • If it does not exist - click on 'Add' to create a new one and enter all the server setting info as set out below.

Be careful when typing server name and User Name - no typos :)

Outgoing SMTP Server

  • Description : Type FOL or email address which should be same as User Name
  • Server Name: relay.free-online.net
  • Port: 587
  • Connection Security : STARTTLS
  • Authentication MethodL: Normal Password
  • User Name : full email address
  • Click on 'OK'

Then set up the FOL account to use that SMTP server setting.

  • In Account Settings
  • In Left Pane - select the name of the FOL mail account
  • Look bottom right for 'Outgoing Server (SMTP)'
  • Click on the drop down option and select the FOL smtp server which should be clearly visible if you typed FOL in the Description.
more options

Hello again.

I am receiving emails from my free-online account, and have just checked my webmail, which both received and sent an email to my Thunderbird TT1 account. So that I assume that confirms both free-online and my password.

The outgoing server smtp is not smtp but relay.free-online.net (see attached). I have checked on various sites and that seems to be the correct address.

I have changed the Description to my FOL email address, as it worked wonders for my TT2 account yesterday.

I have changed the User name to my FOL email address too, although the one I use in my Webmail is gf (my initials).

I have selected my FOL email address - relay.free-online.net in the Outgoing Server (SMTP) drop down option.

However: When I tested sending an email from T'bird FOL to TT1: - I was asked: 'Enter your password for "your FOL address" on relay.free-online.net' - so I entered my normal password - But then got: 'Login to server relay.free-online.net with username "my FOL address" failed.'

I thought I would try changing the Description and the User name back to my initials, as it is on the Webmail, to see if that made a difference. Also checked that the Outgoing Server (SMTP) drop down option shows my initials - relay.free-online.net, which it does

Tested sending an email from T'bird FOL to TT1 again.

That worked, fantastic, thank you!

Do you feel like having a look at my Googlemail account? Tried a version of what we just did (Description, User name, Outgoing Server (SMTP) drop down option:

Result: 'Login to server smtp.googlemail.com with username "my GM address" failed.'

Not doing so well on my own, fancy having a look?

All the best.

more options

RE GMAIL. I just thought I'd check my GM password by sending an email to my TT1 account (although the T'bird 'From' shows my address as gmail.com, as opposed to googlemail.com, which is the registered on - are they interchangeable?). So my password is ok.

Изменено Marilou

more options

re : Googlemail account

The following will get you up to date using the current servers etc. Although you are currently using OAuth2 for incoming, the outgoing is not, but it's not so simple to just adjust the smtp as in previous methods. Why not? Because gmail will prompt for password, but because OAuth is already set up for incoming, it will say the password is wrong. The incoming Oauth and outgoing Oauth need to be set up together. This will involve changing some Incoming server settings and some Outgoing SMTP server settings, checking cookies are allowed and removal of all old passwords before a restart of Thunderbird and then following the gmail prompt to allow thunderbird.

Start by changing both incoming and outgoing server settings.

  • 'Account Settings' > select gmail account name - see image below as guide.
  • Bottom right look for 'Outgoing Server (SMTP)'

The info you previously posted says this account is correctly set up to use a gmail smtp, so this time...

  • Click on 'Edit SMTP_Server' button

Then edit the settings so they match as follows:

  • Decription: Google Mail
  • Server name: smtp.gmail.com
  • Port: 465
  • Connection Security: SSL/TLS
  • Authentication method: OAuth2
  • User Name: full gmail email address
  • Click on 'OK'
  • Select: 'Server Settings' for the gmail account - see image below as guide

Set the following, some may aleady be correct, but I'll list all the settings.

  • Server Name: imap.gmail.com
  • User Name: full gmail email address
  • Connection Security: SSL/TLS
  • Authentication method: OAuth2

If you get any prompt from gmail to enter password - click on Cancel and continue checking settings as below.

Next Check these Settings: I'm assuming you already have the following, but check anyway.

  • Menu icon > Settings > Privacy & Security
  • Under 'Web Content'
  • Select checkbox: 'Accept cookies from sites'

Also set up this for same section:

Now, whilst in 'Privacy & Security', you need to remove the current saved passwords for the gmail account. This is because you are going to force a new connection and new oauth which will then function for both incoming and outgoing.

  • Scroll to 'Passwords' section
  • Click on 'Saved Passwords'
  • For any entry that is set up for the gmail account, so this means imap://...smtp://..oauth
  • Select each line and click on 'Remove'
  • click on 'Close'

Exit Thunderbird and wait a few moments for background processes to complete. Start Thunderbird.

You will get a prompt from gmail to enter email address and password - that means enter the normal password - same one you would use to access gmail webmail account. This is done to give permission and allow Thunderbird to access your gmail account.

Then you should automatically get an Oauth2 password stored in the usual place where passwords get stored in thunderbird. From then onwards Thunderbird will use that Oauth password to connect to server. It's only Thunderbird who will use that OAuth password. If you ever need to logon to the gmail webmail account via a browser then you would use your normal password.

See images below as guide. I have a gmail imap account - see my settings.

more options

Hello, and thank you for your reply.

1. I'm still getting confused between googlemail and gmail. You refer to gmail - so I have changed all my 'googlemail' to 'gmail'. Hope this will work ok. If not, can change them back (noted where they have been changed).

2. Managed ok up to 'You will get a prompt from gmail to enter email address and password - that means enter the normal password - same one you would use to access gmail webmail account. This is done to give permission and allow Thunderbird to access your gmail account.' - I didn't get that prompt - Tried to send email from new gmail to TT1 > stuck on 'Sending'. - Eventually got a notification telling it failed, Cancel, Retry, and to Enter new password. Which I clicked but then that notification disappeared and I can't see it anywhere. - Will try and send another email, wait for that notification again, and try Enter new password again > same result, see attached notification.


Other notes: 3. In Server Settings, Local Directory, it shows: ........Library/Thunderbird/Profiles/i9olj98j.default/ImapMail/imap.googlemail-1.com - Could changing 'imap.googlemail-1.com' to 'imap.gmail.com' help with the above? If so how would I do that?

4. I am finding it difficult to read your screenshots on a black background. Please confirm 993 is the correct Incoming port?

more options

re :Please confirm 993 is the correct Incoming port?

Yes ...993

Have you accessed the saved Passwords and deleted all the lines that mention gmail? It is important to get rid of any line that mentions the User name = gmail email address.

Menu icon > Settings > Privacy & Security

  • Scroll to 'Passwords' section
  • Click on 'Saved Passwords'
  • You can use the bottom right corner to expand that window to display iunfo better.
  • For any entry that is set up for the gmail account, so this means imap://...smtp://..oauth
  • Select each line and click on 'Remove'
  • click on 'Close'

Immediately, Exit Thunderbird and wait a few moments for background processes to complete. Start Thunderbird. As there are no stored passwords for the imap then it should prompt to get one.

It may help to post images of the Account Settings that show your incoming server settings and outgoing smtp settings. So I can see if they look like my settings.

Изменено Toad-Hall

more options

Good morning, 1. I can confirm there are no mentions of either gmail or googlemail in the Saved Passwords section. Only TT, FOL & Yahoo, Mailbox and smtp 2. Attaching screenshots of both Incoming and Outgoing settings. 3. Have also tried to send a message from Gmail address, but taking a long time, (10 mins?) 'sending' (see also attached). 4. Got notification of failure (see also attached). 5. I selected 'Enter new password', but the notification disappeared so the page went back to 'sending' 6. After 10 mins, got notification of 'Send message error' (attached) > OK 7. Have Quit T'bird (had chosen Restart previously) just to make sure, opened it again 8. Got Google notification to sign in with password, confirmed on mobile 9. Confirmed Google has access to T'bird, on mobile and mac 11. Tried sending email, with same result as above in Points 3 and 4 - except this time it's been around 30 mins and it's still 'sending'. Thank you again, and all the best.

more options

re: Incoming and Outgoing settings.

They are correct.

re : 3. Have also tried to send a message from Gmail address, but taking a long time, (10 mins?) 'sending' (see also attached). 4. Got notification of failure (see also attached). 5. I selected 'Enter new password', but the notification disappeared so the page went back to 'sending' 6. After 10 mins, got notification of 'Send message error' (attached) > OK

I'm slightly confused...

After setting up account settings - then removing the stored passwords, you needed to Exit Thunderbird, wait a few moments and then Start Thunderbird. Then Thunderbird should have auto tried to access accounts. Gmail/Google should have auto prompted to allow access.

But you seem to be trying to send an email before that process occured and tried the 'Enter new password' which basically means entering the usual normal password. This is something you should not be able to do because you are not using it anymore. It should be using Oauh2.


re : Quit T'bird (had chosen Restart previously) just to make sure, opened it again 8. Got Google notification to sign in with password, confirmed on mobile 9. Confirmed Google has access to T'bird, on mobile and mac

You mention you finally 'Got Google notification...' after Exit and then Start Thunderbird - as per my instructions. That should have set up the Oauth2 password. Is there a new gmail OAuth2 password saved in Settings > Privacy & Security > Saved Passwords ? If yes, thats good.

BUT Is there an imap and/or smtp for gmail account visible as well as Oauth? I'm concerned you have saved another password when you used the 'Enter new Password' option. If yes, then please remove them. You should only have the Oauth password for gmail. Then Exit Thunderbird. This forces all the background processes and updates to files to get written. then Start Thunderbird.

more options

Good morning!

1. I did follow your initial instruction 'After setting up account settings - then removing the stored passwords, you needed to Exit Thunderbird, wait a few moments and then Start Thunderbird.' I wasn't sure how to 'Exit' TB, so I chose Restart, I assumed that was OK. For my 2nd attempt, I chose to Quit. The email exercise was after that. My apologies if I was unclear.

2. Re my previous Point 8: aahhh, I'd forgotten we had changed the password and entered my old one. Again, my apologies for the confusion.

3. 'Is there a new gmail OAuth2 password saved in Settings > Privacy & Security > Saved Passwords ?' >>> No, the password is gobbledegook, not surprising since I entered the wrong one.

4. 'BUT Is there an imap and/or smtp for gmail account visible as well as Oauth? ' >>> I've checked everything: Saved Passwords: Provider, oauth.//google.com - Username, my GM email address - Nothing else, ie no smtp Incoming settings: Outgoing, at bottom of page: Google Mail - smtp.gmail.com - Server settings: imap.gmail.com - Authentication: OAuth2 Outgoing settings: smtp.gmail.com

5. 'You should only have the Oauth password for gmail. Then Exit Thunderbird.' >>> I Removed the gmail entry, Quit Thunderbird and waited a bit.

6. Started TB and entered Oauth in Google password notification > got 'Wrong password' (see attached). Quit TB again, waited a bit, Started again, entered oauth (in case the 1st letter needed to be small) > ditto. Checked all settings entries were as in Point 4. above, in case they had changed in the meantime - they hadn't. Realised the Authentication method was OAuth2 so decided to redo the procedure with OAuth2 as a password > still 'Wrong password'. Will attach all present settings in case you spot something I missed... no, I can't for some reason. I have to go now, so will send this for now and will try attaching the screenshots later. All the best.

more options

Will quickly retry sending the attachments...

more options

EDITED: re :6. Started TB and entered Oauth in Google password notification > got 'Wrong password' (see attached).

First you need to check you know the correct password. Remember it is case sensitive, so make sure the keyboard 'Caps Lock' is not accidentally switched on. Logon to the gmail webmail account via a browser to get access. If you cannot get access then use the 'Forgotten Password' link and follow instructions to get access and set up a password.


You said :

3. 'Is there a new gmail OAuth2 password saved in Settings > Privacy & Security > Saved Passwords ?' >>> No, the password is gobbledegook, not surprising since I entered the wrong one.

then below you say the oauth password is set up

4. 'BUT Is there an imap and/or smtp for gmail account visible as well as Oauth? ' >>> I've checked everything: Saved Passwords: Provider, oauth.//google.com - Username, my GM email address - Nothing else, ie no smtp

When the oauth password is set up, it gets used for both receiving and sending. It is stored in the 'Saved Passwords'.

It looks like this: oauth://accounts.google.com (https://mail.google.com/) It will say the User Name = full gmail email address It will say the Password is something really weird and long a load of letters and numbers - it will not resemble any normal password. This oauth password cannot be used by you for anything. Only Thunderbird program can use this.

You would have to remove the google oauth password line if you intend to try again. Further attempts will not work if the old incorrect password or oauth is still stored.

After removing any google password and that includes the oauth line. Exit Thunderbird. Wait for background processes to complete. Start Thunderbird Thunderbird checks accounts. Do not under any circumstances try to send anything. Oauth is not set up during sending. The Oauth password gets set up at the start when Thunderbird tries to get access to 'Get Messages' off the gmail server to do the incoming of emails. You should get that google page asking for email and password to set up and allow Thunderbird. You have to enter the normal password - same one you use when you logon to the webmail account. Hence why I advised you check that you can get access to the webmail account so you know what is the correct password.

Once the oauth password gets stored in the Saved Passwords then Thunderbird should use it to get mail and to send mail. You should not need to enter anything when sending an email.

Изменено Toad-Hall

more options

If this does not work then I'm going to advise you to completely remove all google/gmail stored passwords and then remove the gmail account via Account Settings. As it's an imap account , all emails are stored on server.

  • Account Settings
  • Select name of gmail account in left pane
  • Click on 'Account Actions'
  • select 'Remove account'

Exit Thunderbird Start Thunderbird

  • Menu icon > New > Existing Mail Account
  • Enter Name
  • Enter full gmail email address
  • Enter Password - same one as used to access webmail
  • Select the checkbox to remember password
  • Click on 'Continue'

Thunderbird by default will get the server settings for the imap server. click on 'Done' to create.

Allow set up - complete the Google prompt using email address and normal webmail password to allow Thunderbird access.

The oauth password will get set up.

more options

1. OK, I think I'm getting confused by the mentions of password (my webmail password), and the Authorisation passwords (sometimes referred to as oauth, sometimes OAuth and sometimes OAuth2). When I last responded to Google's invitation to enter my password, I thought it wanted me to enter the Authorisation password, so I entered the various versions, which didn't seem to work. It didn't occur to me I should perhaps enter my webmail password, so before going through your latest reply in detail, I thought I should try that, which appeared to work, as Google asked me to identify myself on my mobile, which I did. But the saved password in Settings/Saved logins is still gobbledegook. So now I'm totally lost. (I checked the webmail password again, and the browser automatically opened on my page, so I can't check the password, I assume it's the same as the one I've always use, A....3).

2. You say: 'It looks like this: oauth://accounts.google.com (https://mail.google.com/) It will say the User Name = full gmail email address It will say the Password is something really weird and long a load of letters and numbers - it will not resemble any normal password. This oauth password cannot be used by you for anything. Only Thunderbird program can use this. ' >>> Ah, this password is what I meant by 'gobbledegook', which is why I got confused in Points 3 & 4 in my previous reply. OK, so I don't need to worry about that.

3. I have not sent anything since you previously told me not to, and will not until you tell me I can.

I have checked the last 4 screenshots I sent you and they are still the same - EXCEPT, I just noticed I wrongly sent you GMAIL, INCOMING P.2 - just attaching the correct one below.

I had also forgotten to send you GMAIL, SETTINGS, PRIVACY & SECURITY, SAVED LOGINS, so am sending it to you too - the password is indeed gobbledegook ('something really weird and long a load of letters and numbers').

If everything looks correct to you, am I right in thinking I don't need to either: - 'You would have to remove the google oauth password line if you intend to try again.' or - 'remove all google/gmail stored passwords and then remove the gmail account via Account Settings.'

With many thanks again, and best wishes. PS - Just out of curiosity, where are you based? I note that you replied at 5.12am (which is incredibly early) and 10.18am (although the times in my Inbox are 12.12 and 17.18). I live in the UK.

more options

Also forgot to say Gmails arrive in a separate gmail folder, not in my Inbox, as opposed to TT and FOL

more options

This time you definity have the oauth saved. But now to check it is working in both directions.

Send an email from FOL or TT to gmail. Confirm it gets displayed in the gmail imap account.

Then attempt to reply to that received email, so sending back to FOL or TT.

more options

Toad-Hall said

This time you definity have the oauth saved. But now to check it is working in both directions. Send an email from FOL or TT to gmail. Confirm it gets displayed in the gmail imap account. Then attempt to reply to that received email, so sending back from Gmail to FOL or TT.
  1. 1
  2. 2