Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

The Built-In pdf viewer is missing in 54.0.1 (64-bit)

  • 4 respostas
  • 18 têm este problema
  • 43 visualizações
  • Última resposta por dflanagand

more options

I'm running Windows 7 SP 1 on a Dell Laptop.

I want to use the Firefox built in PDF viewer as opposed to always downloading a PDF file. When I go to Tools--> Applications and view any of the Adobe Acrobat document types, the only options are Always Ask (which never does!), Save File, Use Adobe Acrobat or Acrobat Reader DC.

My understanding is the old Adobe Acrobat Plug in is 32 bit only and no longer applicable?

I checked the about:config settings per other posts and see...

    pdfjs.disabled = default [false]
    plugin.disable_full_page_plugin_for_types = application/pdf

I tried clearing the application/pdf value and restarting Firefox.

What do I need to do to enable the reported built-in PDF viewer?

Solução escolhida

Right, I understand, but assumed the plugins could still be installed since they showed up as choices. I assume you uninstalled the plugin previously, or no Adobe entry would evershow up in the dialog. You are right about them being supported for 32-bit only.

To answer your questions:

1) I’m not sure, but have seen the issue before. I’d say it just seems that these settings do not get restored to their defaults when external plugins get uninstalled or are no longer detected as working ones. Even if unsupported for 64-bit, they may still show up in the actions, perhaps because you had a 32-bit Firefox installed previously, or used a profile for both 32-bit and 64-bit?

2) Probably the same issue: the action is not registered or restored properly. Try to imagine the plugin registering the actions, possibly even replacing the Always Ask choice or only "stealing" its action, or working properly in 32-bit Firefox and the profile will be used for a 64-bit Firefox afterwards. The plugin will never recheck for proper registration and neither for Firefox being 32 or 64-bit, so anything can happen.

3) According to the note at the bottom of this support article (that I should have linked to above), "There is no way to identify or delete a bad entry in the list", so it would be best to remove the mimeTypes.rdf file for a quick solution. I suggest you do that - it is just a small text file that will be restored to defaults and adapt to any new actions when needed.

Note that some plugins may not show up in Firefox’s Add-on Manager but are part of some software suite and should be disabled from within that software (I’m not sure if this applies to Adobe software though.) If you are sure there is no more Adobe software on your system, my bet is that the mimetypes file indeed has an issue with its registrations. If the info quoted above is included in any support article, it’s usually not without a reason and provided for the best solution(s) based on previous support questions or bug reports. Removing the file would probably help even if you still had some Adobe software installed, probably requiring the Adobe plugin to be reinstalled (or some option to get disabled and re-enabled in such software) in order to get its actions for them registered properly, e.g. if you ever decide to do so in a 32-bit version as long as they are supported.

This page may also be helpful - note that there were related bugs in the past.

Does this answer your questions and of course, fix your issue?

Ler esta resposta no contexto 👍 1

Todas as respostas (4)

more options

In order to use the internal PDF viewer, Acrobat should not be selected in the drop-down described and (perhaps) even uninstalled. The Acrobat plugin however is a) a 32-bit plugin that’s not recognized by the 64-bit version, and b) a NPAPI plugin and should no longer work in Firefox 52+ releases - see Use Adobe Reader to view PDF files in Firefox support article for more info. Therefor: have they been disabled automatically in Firefox’s Add-ons overview?

Your 2 preferences should be fine; the first one is default (and about disabling the internal viewer when set to true); the second one may show up as bold and user set, but that happens even with new profiles.

What happens if you disable, or rather uninstall the Acrobat Reader plugin, then restart Firefox and open a link to a pdf file?

If that doesn’t help, you can open up your Firefox profile folder and look for the file mimeTypes.rdf. Deleting the file when Firefox is closed (!) will reset all download actions to the default settings.

more options

Sorry I wasn't clear,,, 1) I have no PDF plug ins / add-ons installed. My understanding is that the PDF plug ins are 32 bit only and not supported in 64 bit Firefox. 2) For the Tools--> Applications file types from reading other posts I expected to find an option "Preview in Firefox". That is not a choice in any of the PDF file type drop downs. I attached a jpg of what the choices are. 3) Not wanting to select Acrobat (an external application) I select "Always Ask".

I have three questions: 1) Why is "Preview in Firefox" missing? 2) Why doesn't "Always Ask" ask? Selecting a PDF always downloads the pdf to my downloads folder? 3) What do I need to do to be able to preview PDFs within Firefox?

more options

Solução escolhida

Right, I understand, but assumed the plugins could still be installed since they showed up as choices. I assume you uninstalled the plugin previously, or no Adobe entry would evershow up in the dialog. You are right about them being supported for 32-bit only.

To answer your questions:

1) I’m not sure, but have seen the issue before. I’d say it just seems that these settings do not get restored to their defaults when external plugins get uninstalled or are no longer detected as working ones. Even if unsupported for 64-bit, they may still show up in the actions, perhaps because you had a 32-bit Firefox installed previously, or used a profile for both 32-bit and 64-bit?

2) Probably the same issue: the action is not registered or restored properly. Try to imagine the plugin registering the actions, possibly even replacing the Always Ask choice or only "stealing" its action, or working properly in 32-bit Firefox and the profile will be used for a 64-bit Firefox afterwards. The plugin will never recheck for proper registration and neither for Firefox being 32 or 64-bit, so anything can happen.

3) According to the note at the bottom of this support article (that I should have linked to above), "There is no way to identify or delete a bad entry in the list", so it would be best to remove the mimeTypes.rdf file for a quick solution. I suggest you do that - it is just a small text file that will be restored to defaults and adapt to any new actions when needed.

Note that some plugins may not show up in Firefox’s Add-on Manager but are part of some software suite and should be disabled from within that software (I’m not sure if this applies to Adobe software though.) If you are sure there is no more Adobe software on your system, my bet is that the mimetypes file indeed has an issue with its registrations. If the info quoted above is included in any support article, it’s usually not without a reason and provided for the best solution(s) based on previous support questions or bug reports. Removing the file would probably help even if you still had some Adobe software installed, probably requiring the Adobe plugin to be reinstalled (or some option to get disabled and re-enabled in such software) in order to get its actions for them registered properly, e.g. if you ever decide to do so in a 32-bit version as long as they are supported.

This page may also be helpful - note that there were related bugs in the past.

Does this answer your questions and of course, fix your issue?

more options

Thanks!

Deleting mimeTypes.rdf worked. When I restart Firefox the "Preview in Firefox" option is back and works as expected.

This also restored the expected behavior for "Always Ask" (it does) and Acrobat (it launches Acrobat and displays file).

You are correct that in the past I changed from 32 bit Firefox to 64 bit and reused the profile; removing the offending 32-bit only plug ins. This is no doubt the issue.