Não consigo instalar extensões

A partir do Firefox versão 57, só funcionam extensões construídas usando APIs WebExtensions. Não tem certeza se suas extensões foram afetadas? Consulte o artigo A tecnologia das extensões do Firefox está se modernizando e essas Perguntas Frequentes para mais informações.

Não conseguir instalar uma extensão pode ser o resultado de problemas com a extensão, as preferências do Firefox ou a versão do Firefox que você esta usando. Este artigo descreve várias causas de problemas de instalação e o que você pode fazer para corrigi-los.

A extensão não é compatível

Versões do Firefox com o qual a extensão é compatível. No site de Extensões para o Firefox da Mozilla você poderá encontrar informações sobre a compatibilidade de cada extensão disponível.

Se sua versão do Firefox estiver entre as versões compatíveis, a instalação da extensão resultará em um erro, indicando que ela não é compatível. Se sua versão do Firefox é incompatível com a extensão, você pode:

  • Atualizar para a versão mais recente do Firefox. Para mais informações, veja Atualize o Firefox.
  • Encontrar um versão da extensão que é compatível com a sua versão do Firefox. O site Mozilla Extensões normalmente oferece a versão mais atualizada de cada extensão.
  • Use uma extensão diferente. Para várias extensões há extensões similares que oferecem a mesma funcionalidade. Para mais informações, visite o Mozilla Extensões.

O Firefox impediu esse site de instalar uma extensão não verificada

As versões mais novas do Firefox lhe protegem contra malwares e sequestradores de navegador bloqueando extensões de terceiros que não estão assinadas e verificadas digitalmente pela Mozilla. Para mais informações, veja Extensões assinadas do Firefox.

A extensão tem um alto risco de causar problemas de estabilidade ou segurança e não pode ser instalada

Algumas extensões foram bloqueadas pela Mozilla por serem inseguras. Para mais informações, consulte Extensões que causam problemas de estabilidade ou segurança são incluídas em uma lista de bloqueio.

O Firefox impediu o site de instalar a extensão

Por padrão, o Firefox permite instalar extensões somente de sites confiáveis. Se o site do qual você está instalando a extensão não está na lista de sites confiáveis, uma barra aparecerá no topo da página com uma mensagem parecida com a seguinte:

Este site (www.exemplo.com.br) tentou instalar uma extensão.

Para permitir a instalação, clique no botão Permitir.

Para adicionar um site à lista de sites confiáveis:

  1. Clique no menu New Fx Menu Fx57Menu e selecione Opções.Preferências.
  2. Selecione o painel SegurançaPrivacidade e Segurança descendo até a seção Permissões.
  3. Ao lado de Alertar se sites tentarem instalar extensões,Alertar você quando sites tentarem instalar extensões, clique Exceções….
  4. No diálogo Sites permitidos - Instalação de extensõesSites permitidos - Instalação de extensões , uma lista de sites será exibida. A URL do atual site será inserida dentro da caixa de texto.
  5. Para permitir o site, clique em Permitir. Em seguida, clique em FecharSalvar Alterações.
  6. Feche a janela about:preferences. Quaisquer alterações feitas serão salvas automaticamente. .

Você é perguntado se deseja baixar a extensão em vez de instalá-la

Alguns sites servem as extensões como downloads, pedindo que você baixe o arquivo da extensão para seu computador antes de instalá-la.

  • Esses arquivos são geralmente .xpi ou .jar.
  1. Baixe o arquivo para o seu computador.
  2. Clique no menu Fx57menu , clique em Fx57Addons-icon Extensões e selecione Extensões.
  3. Para adicionar uma extensão baixada à lista de extensões disponíveis, arraste e solte o arquivo no Gerenciador de extensões. A extensão será adicionado à lista.
  4. O processo de instalação deve começar.

Falha no download -228

Cache desativado

Esse erro pode ocorrer quando o cache do Firefox está desativado. Para reativar o cache do Firefox:

  1. Clique no menu New Fx Menu Fx57Menu e selecione Opções.Preferências.
  2. Selecione o painel Avançado.
  3. Clique na aba Rede.
  4. Na seção Cache de conteúdo web, o tamanho do cache deve ser de no mínimo 1 MB.
  5. Feche a janela about:preferences. Quaisquer alterações feitas serão salvas automaticamente. .

Outros programas

Às vezes, firewalls ou spywares podem causar a mensagem de erro - 228. Se você usa o firewall CA, Windows Defender, ou a opção Residente do Spybot S&D (recurso "Teatimer"), você deve desativar o programa temporariamente para ver se seu sistema permite a instalação de extensões. Para mais informações, veja a documentação que veio com o programa.

Nada acontece quando você clica no link de instalação

Se você clica em um link de instalação e nada acontece, você deve verificar se o JavaScript está ativado. Para mais informações, leia Configurações e preferências do JavaScript para páginas web interativas.

Arquivos de extensões corrompidos

Arquivos de configurações de extensões corrompidos podem causar problemas ao tentar instalar uma extensão. Excluir esses arquivos fará com que o Firefox os crie novamente (removendo qualquer corrupção) na próxima vez que for iniciado. Você não perderá suas extensões ou suas configurações ao excluir esses arquivos.

  1. Abra a pasta do seu perfil:

    Clique no menu Fx57menu , depois em Ajuda e selecione Informações para resolver problemas.No menu Ajuda, escolha Informações para resolver problemas. Será aberta a aba Dados para suporte.

    • Na seção Informações básicas sobre o aplicativo, linha Diretório do perfil, clique em Abrir pastaMostrar no FinderAbrir pasta. Será aberta uma janela contendo sua pasta de perfil.Sua pasta de perfil será aberta.
    Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções de como Encontrar seu perfil sem abrir o Firefox.

  2. Clique no menu New Fx Menu e depois em SairFechar Close 29 .

    Clique no menu Fx57Menu do Firefox e depois em Sair. Clique no menu do Firefox no topo da tela, depois clique em Fechar Firefox.Clique no menu Fx57Menu do Firefox e depois em Fechar.

  3. Apague os seguintes arquivos:
    • extensions.sqlite
    • extensions.sqlite-journal (se for encontrado)
    • extensions.ini
    • extensions.json
  4. Reinicie o Firefox.

Conflito com outras extensões

Outra extensão instalada pode interferir na instalação de novas extensões. Instale a nova extensão no Firefox em modo de segurança como uma solução alternativa.



Baseado em informações do artigo Unable to install themes or extensions - Firefox (mozillaZine KB)

// Contribuidores que ajudaram a escrever esse artigo:Fernando Pereira Silveira, cristianomr, user917725, André Marcelo Alvarenga, André Marinho, Jhonatas Rodrigues . Você também pode ajudar - descubra como.

Este artigo foi útil? Por favor, aguarde...

Contribua com o suporte da Mozilla