Extensões que causam problemas de estabilidade ou segurança são incluídas em uma lista de bloqueio

A partir do Firefox versão 57, só funcionam extensões construídas usando APIs WebExtensions. Não tem certeza se suas extensões foram afetadas? Consulte o artigo A tecnologia das extensões do Firefox está se modernizando e essas Perguntas Frequentes para mais informações.

Incluir em lista de bloqueio é uma ação tomada como último recurso para proteger os usuários do Firefox contra extensões, temas e plugins que violam as Diretrizes de Extensões da Mozilla.

O que a lista de bloqueio faz?

Uma vez que um bloqueio é implementado, o Firefox bloqueia o carregamento da extensão não segura. Bloqueios podem ser emitidos em vários níveis, dependendo da severidade dos problemas encontrados.

  • Bloqueios flexíveis desativam por padrão uma extensão, mas permitem que você desconsidere e continue usando a extensão. Bloqueios flexíveis são emitidos para extensões não maliciosas.
  • Bloqueios rígidos desativam uma extensão e não permitem que você a ative ou desconsidere o bloqueio. Bloqueios rígidos são usados quando são descobertas extensões maliciosas.
  • Bloqueios do tipo clique-para-ativar desativam por padrão um plugin, mas permitem que você ative o plugin em determinados sites. Este tipo de bloqueio é emitido para plugins não maliciosos.

Como saber se uma extensão foi bloqueada?

Aparece uma notificação do Firefox com a seguinte mensagem:

O Firefox constatou que essas extensões são conhecidas por causar problemas de estabilidade ou segurança


Add-ons Blocklist Mac1

Para impedir que essas extensões funcionem, clique em Reiniciar o Firefox.

Se a extensão recebeu um bloqueio rígido, você não consegue desconsiderar o bloqueio.

Posso instalar uma extensão após ter sido bloqueada?

Uma vez bloqueada, uma extensão não aparece mais na galeria de addons.mozilla.org até que o desenvolvedor envie uma nova versão que resolva todos os problemas que resultaram no pedido de bloqueio.

Além disso, o Firefox impede que você instale uma extensão não segura que esteja na lista de bloqueio e exibe esta mensagem:

A extensão tal não pôde ser instalado porque tem um elevado risco de causar problemas de estabilidade ou segurança.

Se a instalação de uma extensão foi bloqueada, verifique se há uma versão atualizada da extensão que você está tentando instalar. Esteja ciente que alguns bloqueios podem ser permanentes e você pode precisar encontrar uma extensão alternativa.

Plugins são impedidos de funcionar automaticamente

O Firefox pode impedir que um plugin funcione automaticamente (o que evita muitos problemas). Quando o Firefox bloqueia um plugin, aparece uma mensagem similar a esta:

Click to play 1 new

Você pode então escolher executar o plugin ou atualizá-lo (se houver uma atualização disponível). Saiba mais em Por que eu tenho que clicar para ativar plugins?

O suporte terminou para todos os plugins NPAPI, exceto para o Adobe Flash, no Firefox versão 52. Veja este documento de compatibilidade e este artigo para mais detalhes.

O que fazer se aparecer uma notificação de bloqueio

Se a extensão instalada estiver desativada

Aceite a notificação e reinicie o Firefox. Caso escolha desconsiderar um bloqueio flexível, o faça por sua própria conta e risco.

Plugins

Verifique se há uma versão atualizada do plugin. Se não houver atualizações disponíveis, pode ser necessário entrar em contato com o desenvolvedor do plugin que foi bloqueado.

Bloqueios podem ser suspensos?

Dependendo da severidade da violação, do histórico do desenvolvedor e de outros fatores relevantes, alguns bloqueios podem ser suspensos quando o desenvolvedor envia uma nova versão aprovada. Se isso acontecer, os usuários que tinham anteriormente baixado a extensão poderão imediatamente usar novamente assim que ela volte a aparecer em addons.mozilla.org.

Para garantir que você esteja sempre usando a versão mais atualizada de uma extensão ou tema:
  1. Clique no menu Fx57menu , clique em Fx57Addons-icon Extensões e selecione Extensões.
  2. Clique no ícone de configurações Add-on Tools Icon (no topo, ao lado do campo de pesquisa) e certifique-se de que o item de menu Atualizar automaticamente esteja marcado.

Quais extensões não seguras estão na lista de bloqueio?

Veja a lista de extensões bloqueadas.

// Contribuidores que ajudaram a escrever esse artigo:Ralph Daub, Ale Galliard, user917725, André Marinho, Wolfgang Marcos, Cynthia Pereira, Thiago Policena, Marcelo Ghelman, Jhonatas Rodrigues. Você também pode ajudar - descubra como.

Este artigo foi útil? Por favor, aguarde...

Contribua com o suporte da Mozilla