Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Seeing Question Marks Instead of Text on Web Pages

  • 4 balasan
  • 1 ada masalah ini
  • 10 paparan
  • Balasan terakhir oleh JeffGates

more options

I often see a series of question marks instead of simple text on webpages in Firefox. I'm using Big Sur OS on a Mac. But this started with Monterey. See attached screenshot.

I used my Inspector to see exactly what those question marks should say. And it was text in an

tag using Verdana, Arial, san-serif. That should resolve. So, what's happening? I looked at it in Troubleshooting Mode and the question marks were still there.

I often see a series of question marks instead of simple text on webpages in Firefox. I'm using Big Sur OS on a Mac. But this started with Monterey. See attached screenshot. I used my Inspector to see exactly what those question marks should say. And it was text in an <h3> tag using Verdana, Arial, san-serif. That should resolve. So, what's happening? I looked at it in Troubleshooting Mode and the question marks were still there.
Lampirkan skrinsyot

All Replies (4)

more options

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".
more options

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

I used Inspector and I can see it's Arial that's causing the issue. I had a number of Arial fonts in use in various places so I got rid of them. But it's still happening. So, perhaps I haven't gotten rid of all of them. Sigh.

more options

Okay, after doing some researching and looking to see if Arial was showing a conflict in FontBook (it wasn't), I decided to see if I could clear my font cache in the font management system app I use (RightFont). I emptied the cache and restarted my Mac and it *seems* to be working correctly now.

It may take me awhile to see if that really solved the problem as it had been happening in other applications, other than Firefox. But that may have done the trick. Don't know if I should click "Solved the problem" just yet though.

Thanks all.