Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prime Video: "Your browser does not support High-Definition playback due to content restrictions"

  • 17 replies
  • 1 has this problem
  • 431 views
  • Last reply by benzo

more options

Since 88.0.1 all Amazon Prime Video content displays this message: "Your browser does not support High-Definition playback due to content restrictions. Please update your browser for the best Prime Video experience".

I've tried turning off vpn, adblocker, and set tracking protection back to 'standard', nothing helps.

I'm on W10 1909 Home which is technically not supported by MS as from this week so I did consider that as a possible (but unlikely) reason for it. However, the content plays fine in MS Edge. The content also plays fine from a laptop running Chrome on 1909 Enterprise (similar build to mine albeit not out of support yet).

I see widevine was updated in 88.0.1 - could this be the issue?

Thanks

Attached screenshots

Chosen solution

Resolved. I was about the reinstall and then considered clearing all cookies and data.

Once that was done, content is playing correctly again.

Read this answer in context 👍 0

All Replies (17)

more options

Is it really 88.0.1? It should be fixed in this version.

Helpful?

more options

Yes. I didn't have any issues with 88.0 - content played fine for me.

The bug report for 88.0 seemed to be for bought Amazon content, which I don't have. Maybe the bought stuff is handled slightly differently to the included with Prime stuff that I'm trying to watch.

Helpful?

more options

I can confirm it has nothing to do with 1909 as I've updated to 20H2 and the problem is still there.

Anyway to rollback to a functioning version of Firefox?

Helpful?

more options

What Widevine version are you using (about:addons -> Plugins) ?

Helpful?

more options

It's 4.10.2209.1

Helpful?

more options

Chosen Solution

Resolved. I was about the reinstall and then considered clearing all cookies and data.

Once that was done, content is playing correctly again.

Helpful?

more options

On macOS, Firefox 89.0.2 (64 bit), i can't still view hd videos even with all cookies/cache/data cleared. Using Safari hd videos are in right definition instead. In Troubleshoot mode same issue :/

Modified by benzo

Helpful?

more options

@ benzo

Did you updated to Widevine 4.10.2209.1 as that is the only version currently supported ? See: "Add-ons -> Plugins" and the about:plugins page

Helpful?

more options

Widevine version is 4.10.2209.1, and the plugin and the plugins auto-update are both enabled.

Helpful?

more options

Any related messages in the Web Console ?

Helpful?

more options

Only this notice

"Il cookie “csm-hit” verrà presto rifiutato in quanto l’attributo “SameSite” è impostato a “None” o un valore non valido, senza l’attributo “secure”. Per ulteriori informazioni sull’attributo “SameSite”, consultare https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite"

But i think not relevant :/

Helpful?

more options

This thread is about playing DRM protected HD videos.

If your issue also with DRM or are unprotected videos like on YouTube affected as well ?

Helpful?

more options

YouTube has no problems. I tried also to change DNS to google dns, i was using AdGuard dns, but not even this resolve the issue unfortunately.

Helpful?

more options

I tried also a second instance on Firefox on macOS, without extensions and default settings, but the issue still persists.

Helpful?

more options

So there's nothing to do? If the issue comes with clean Firefox installation too i think there's a problem in the latest version considering working well on Safari. Some times ago there was no issues, but i cannot say when precisely.

Modified by benzo

Helpful?

more options

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

[https://support.mozilla.org/en-US/que.../1342711] I opened a new question.

However i tried all the mentioned above things to do, but no luck. I tried also the latest nightly disabling all privacy settings :/

Modified by benzo

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.