Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 84.0.2 not playing embedded Youtube videos.

  • 11 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

Getting errors messages like;

An error occurred. Please try again later. (Playback ID: esTXxYqBr25ETVYS)

Tried resetting FF, clearing cache and cookies etc. to no avail.

This started about a week ago.

Youtube webpage is working properly, just embedded videos are fubar.


Chosen solution

Great. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Read this answer in context 👍 0

All Replies (11)

more options
more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Safe mode - no fix, problem still there

Cleared cookies and cache - no fix, problem still there


No problems with Chrome but I don't like that browser  :P

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Started PC in safe mode.

Problem persists !

Firefox won't play embedded videos, playback direct from Youtube page OK

more options
more options

New profile works !

Thanks  :)

Short-lived joy - broke again


Modified by audio_downunder

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

more options

Latest FF85 update appears to have fixed the problem !

more options

Chosen Solution

Great. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Modified by FredMcD