Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

disable "recent" list

  • 6 replies
  • 1 has this problem
  • 28 views
  • Last reply by cor-el

more options

I have the Firefox icon pinned to the taskbar, and I want to disable the "Recent" list from the menu there. How can I do that? I'm running Windows 10.

Chosen solution

You can type or paste about:config in the location/address bar to open this page in a tab. You can accept the warning and click "I accept the risk!" to continue. See also:

Read this answer in context 👍 1

All Replies (6)

more options

You can look at some browser.taskbar.lists prefs on the about:config page.

Setting browser.taskbar.lists.enabled to false removes everything from the jump list. Setting browser.taskbar.lists.tasks.enabled to false just removes the tasks (leaves the history).

  • browser.taskbar.lists.enabled
  • browser.taskbar.lists.frequent.enabled
  • browser.taskbar.lists.recent.enabled
  • browser.taskbar.lists.tasks.enabled

Helpful?

more options

If you mean the 'frequent sites' listing that is displayed in the menu when you right-click the Firefox icon, you can disable it by changing a Windows 10 setting.

  1. Go to Windows 10 Settings (Right click on the start menu -> Settings)
  2. Using the search box, search for 'Show recently opened items in Jump Lists and in File Explorer' (see image attached)
  3. Click on this item to be taken to that setting
  4. Turn the 'Show recently opened items in Jump Lists and in File Explorer' setting off.

Keep in mind this is system-wide setting, so it'll apply to other items in your start menu and task bar as well. I'm not aware of a way to only turn it off for Firefox.

Modified by t.r.ernst

Helpful?

more options

I wasn't asking about how to disable the "Frequent sites" list in Firefox. I was asking about how to disable the "Recent" list.

Helpful?

more options

Did you try to set browser.taskbar.lists.recent.enabled = false on the about:config page ?

Helpful?

more options

I don't know how to do that.

Helpful?

more options

Chosen Solution

You can type or paste about:config in the location/address bar to open this page in a tab. You can accept the warning and click "I accept the risk!" to continue. See also:

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.