X
Tap here to go to the mobile version of the site.

Support Forum

Just-added bookmark editor doesn't show up

Posted

In previous versions of Firefox I had the option to edit the URL of a bookmark right after creating a bookmark with Ctrl-D. Now, I get the bookmark dialog as in the attached image.

And although that [v] is ticked for the option "Show editor when saving", I see no editor showing up. Above all, I wish I'd be able to edit the URL of a bookmark I just added.

In previous versions of Firefox I had the option to edit the URL of a bookmark right after creating a bookmark with Ctrl-D. Now, I get the bookmark dialog as in the attached image. And although that [v] is ticked for the option "Show editor when saving", I see no editor showing up. Above all, I wish I'd be able to edit the URL of a bookmark I just added.
Attached screenshots
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Helpful Reply

To be more specific, I want to see the dialog as in the image attached.

To be more specific, I want to see the dialog as in the image attached.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

The first screenshot shows a "Show editor when saving" checkbox that you can tick.

The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done".

See "How do I change the name or location of a bookmark?"

The first screenshot shows a "Show editor when saving" checkbox that you can tick. The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done". See "How do I change the name or location of a bookmark?" *https://support.mozilla.org/en-US/kb/bookmarks-firefox
Was this helpful to you? 0
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5433 solutions 40564 answers

"Just-added bookmark editor doesn't show up"

Specifically, which "bookmark editor" did you install? The name of the extension that you installed.

'''"Just-added bookmark editor doesn't show up"''' Specifically, which "bookmark editor" did you install? ''The name of the extension that you installed.''
Was this helpful to you? 0
Quote

Question owner

the-edmeister said

"Just-added bookmark editor doesn't show up" Specifically, which "bookmark editor" did you install? The name of the extension that you installed.

I installed no external addon for editing bookmarks.

cor-el said

The first screenshot shows a "Show editor when saving" checkbox that you can tick. The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done".

I've finally found a screenshot of Firefox from 2012 with the bookmark edit dialog I'm missing, see image attached.

The ghacks article that image was taken from ( https://www.ghacks.net/2012/03/31/edit-bookmark-plus-makes-bookmarking-more-comfortable-in-firefox/ ) says that double clicking the star icon should bring up that dialog, but that does not happen at least for me, as of today.

In the past, the meaning of that [v] for "Show editor when saving" was to bring up that dialog when clicking the "Done" button.

cor-el said

See "How do I change the name or location of a bookmark?"

That doesn't show me how to edit a *URL* of a bookmark. Currently, the only way to do that (which is quiet annoying) is to search the bookmark in the Library, right click it, click "Properties" and then change the URL.

''the-edmeister [[#answer-1299082|said]]'' <blockquote> '''"Just-added bookmark editor doesn't show up"''' Specifically, which "bookmark editor" did you install? ''The name of the extension that you installed.'' </blockquote> I installed no external addon for editing bookmarks. ''cor-el [[#answer-1299065|said]]'' <blockquote> The first screenshot shows a "Show editor when saving" checkbox that you can tick. The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done". </blockquote> I've finally found a screenshot of Firefox from 2012 with the bookmark edit dialog I'm missing, see image attached. The ghacks article that image was taken from ( https://www.ghacks.net/2012/03/31/edit-bookmark-plus-makes-bookmarking-more-comfortable-in-firefox/ ) says that double clicking the star icon should bring up that dialog, but that does not happen at least for me, as of today. In the past, the meaning of that [v] for "Show editor when saving" was to bring up that dialog when clicking the "Done" button. ''cor-el [[#answer-1299065|said]]'' <blockquote> See "How do I change the name or location of a bookmark?" *https://support.mozilla.org/en-US/kb/bookmarks-firefox </blockquote> That doesn't show me how to edit a *URL* of a bookmark. Currently, the only way to do that (which is quiet annoying) is to search the bookmark in the Library, right click it, click "Properties" and then change the URL.
Was this helpful to you?
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5433 solutions 40564 answers

Sorry, I misunderstood the "just-added" part of your title for this thread and I wasn't sure why you red-circled the image of the page that is bookmarked. That was a new feature added last year; although I can't recall exactly when it was added, but my guess is Firefox 68 or so.

I rarely use the Library for working with Bookmarks; I really only use the Library for referring to browsing History. Never got used to the Library since it was implemented in Firefox 3.0 back in June 2008. Opening in a new window, rather than a tab, seemed silly when Firefox has had a Tab interface since very early on; all the other browsers out there didn't have Tabs until years after Firefox added the Tab UI.


You can use Ctrl + B to open the Bookmarks Sidebar to gain access to the Properties to be able to edit the URL.

Sorry, I misunderstood the "just-added" part of your title for this thread and I wasn't sure why you red-circled the image of the page that is bookmarked. That was a new feature added last year; although I can't recall exactly when it was added, but my guess is Firefox 68 or so. I rarely use the Library for working with Bookmarks; I really only use the Library for referring to browsing History. Never got used to the Library since it was implemented in Firefox 3.0 back in June 2008. Opening in a new window, rather than a tab, seemed silly when Firefox has had a Tab interface since very early on; all the other browsers out there didn't have Tabs until years after Firefox added the Tab UI. ----------------------- You can use '''Ctrl + B''' to open the Bookmarks Sidebar to gain access to the Properties to be able to edit the URL.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Note that you shouldn't double-click the star. You can click the star once to bookmark the current tab and the star gets highlighted. If you haven't ticked the box in the dialog to show the editor ("Show editor when saving") like I posted above then you need to click the highlighted star another time to open the "Edit this Bookmark" dialog.

Alternatively you can set this pref to true (default; not bold) on the about:config page.

  • browser.bookmarks.editDialog.showForNewBookmarks = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Note that you shouldn't double-click the star. You can click the star once to bookmark the current tab and the star gets highlighted. If you haven't ticked the box in the dialog to show the editor ("Show editor when saving") like I posted above then you need to click the highlighted star another time to open the "Edit this Bookmark" dialog. Alternatively you can set this pref to true (default; not bold) on the <b>about:config</b> page. *browser.bookmarks.editDialog.showForNewBookmarks = true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Was this helpful to you? 0
Quote

Question owner

the-edmeister said

You can use Ctrl + B to open the Bookmarks Sidebar to gain access to the Properties to be able to edit the URL.

The whole point of this thread is that I don't want to go through this long process, because it means I need to search for the bookmark I just added.

cor-el said

Note that you shouldn't double-click the star. You can click the star once to bookmark the current tab and the star gets highlighted. If you haven't ticked the box in the dialog to show the editor ("Show editor when saving") like I posted above then you need to click the highlighted star another time to open the "Edit this Bookmark" dialog.

@cor-el Do you see no difference between the dialog as in the image attached to my 1st post vs this post?? I want to get this dialog. No matter whether I click it once or double, I still get the dumber dialog where there's no option to edit a URL. Both image attached again to this comment for your reference.

cor-el said

Alternatively you can set this pref to true (default; not bold) on the about:config page.
  • browser.bookmarks.editDialog.showForNewBookmarks = true

That's already set to true on my config.

''the-edmeister [[#answer-1299201|said]]'' <blockquote> You can use '''Ctrl + B''' to open the Bookmarks Sidebar to gain access to the Properties to be able to edit the URL. </blockquote> The whole point of this thread is that I don't want to go through this long process, because it means I need to '''search''' for the bookmark I just added. ''cor-el [[#answer-1299270|said]]'' <blockquote> Note that you shouldn't double-click the star. You can click the star once to bookmark the current tab and the star gets highlighted. If you haven't ticked the box in the dialog to show the editor ("Show editor when saving") like I posted above then you need to click the highlighted star another time to open the "Edit this Bookmark" dialog. </blockquote> @cor-el Do you see no difference between the dialog as in the image attached to [[#question-1282424|my 1st post]] vs [[#answer-1299091|this post]]?? I want to get [[#answer-1299091|this dialog]]. No matter whether I click it once or double, I still get the dumber dialog where there's no option to edit a URL. Both image attached again to this comment for your reference. ''cor-el [[#answer-1299270|said]]'' <blockquote> Alternatively you can set this pref to true (default; not bold) on the <b>about:config</b> page. *browser.bookmarks.editDialog.showForNewBookmarks = true </blockquote> That's already set to true on my config.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Did you already placed a checkmark in the "Show editor when saving" at the bottom of the dialog that opens if you click the star ?

This item is at the bottom just above "Remove Bookmark" and "Done".

See "How do I change the name or location of a bookmark?"


If you want to hide the extra content at the top of the dialog then you need to use code in userChrome.css.

/* BOOKMARK EDIT - InfoArea */
*|div#editBookmarkPanelInfoArea { display:none !important; }

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted above.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Did you already placed a checkmark in the "Show editor when saving" at the bottom of the dialog that opens if you click the star ? This item is at the bottom just above "Remove Bookmark" and "Done". See "How do I change the name or location of a bookmark?" *https://support.mozilla.org/en-US/kb/bookmarks-firefox ----- If you want to hide the extra content at the top of the dialog then you need to use code in userChrome.css. <pre><nowiki> /* BOOKMARK EDIT - InfoArea */ *|div#editBookmarkPanelInfoArea { display:none !important; }</nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a plain text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted above. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file. See also: *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true See: *https://www.userchrome.org/firefox-changes-userchrome-css.html
Was this helpful to you?
Quote

Question owner

cor-el said

Did you already placed a checkmark in the "Show editor when saving" at the bottom of the dialog that opens if you click the star ? This item is at the bottom just above "Remove Bookmark" and "Done".

YES.

cor-el said

See "How do I change the name or location of a bookmark?"

You've already told me about that in a previous answer and I explained to you in my reply that this edit dialog is too dumb in comparison to the other dialog (as in the image attached here).

cor-el said

If you want to hide the extra content at the top of the dialog then you need to use code in userChrome.css.

That's irrelevant.

@cor-el DO YOU READ MY REPLIES??? I hope it's not a bot I'm talking to.. For the last time, there is an edit dialog for bookmarks that doesn't show up and it used to show up in previous versions of Firefox. It is attached to the current comment and it was attached to previous comments as well. If this edit dialog is no longer available, I'd be happy to be confirmed Firefox removed it from the codebase. If it's possible to re-enable it via something in about:config, I'd be satisfied. Please don't repeat yourself @cor-el if you don't understand my point. You are wasting your time.

''cor-el [[#answer-1299340|said]]'' <blockquote> Did you already placed a checkmark in the "Show editor when saving" at the bottom of the dialog that opens if you click the star ? This item is at the bottom just above "Remove Bookmark" and "Done". </blockquote> YES. ''cor-el [[#answer-1299340|said]]'' <blockquote> See "How do I change the name or location of a bookmark?" *https://support.mozilla.org/en-US/kb/bookmarks-firefox </blockquote> You've already told me about that in [[#answer-1299065|a previous answer]] and [[#answer-1299091|I explained to you in my reply]] that this edit dialog is too dumb in comparison to the other dialog (as in the image attached [[#answer-1299091|here]]). ''cor-el [[#answer-1299340|said]]'' <blockquote> If you want to hide the extra content at the top of the dialog then you need to use code in userChrome.css. </blockquote> That's irrelevant. @cor-el DO YOU READ MY REPLIES??? I hope it's not a bot I'm talking to.. For the last time, there is an edit dialog for bookmarks that doesn't show up and it used to show up in previous versions of Firefox. It is attached to the current comment and it was attached to previous comments as well. If this edit dialog is no longer available, I'd be happy to be confirmed Firefox removed it from the codebase. If it's possible to re-enable it via something in <code>about:config</code>, I'd be satisfied. Please don't repeat yourself @cor-el if you don't understand my point. You are wasting your time.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

That extra info area with favicon and preview image at the top is the #editBookmarkPanelInfoArea and that area can only be hidden via code in userChrome.css.

Screenshots attached without this CSS code and with this CSS code in userChrome.css. You can clearly see the checkbox I mentioned and the hidden info area in the second screenshot.

That extra info area with favicon and preview image at the top is the #editBookmarkPanelInfoArea and that area can only be hidden via code in userChrome.css. *https://support.mozilla.org/en-US/search/advanced?q=editBookmarkPanelInfoArea&asked_by=&answered_by=&w=2&a=1&sortby=1 *[[/questions/1265182]] How can I change the obnoxious new Bookmarks format? Screenshots attached without this CSS code and with this CSS code in userChrome.css. You can clearly see the checkbox I mentioned and the hidden info area in the second screenshot.
Was this helpful to you? 0
Quote

Question owner

As you can see cor-el, with and without that css snippet in userChrome.css, you can't edit the url of the bookmark. Do you understand I want to edit the URL of a bookmark just added? There's a different dialog I've mentioned numerous times already.

As you can see cor-el, with and without that css snippet in userChrome.css, you can't edit the url of the bookmark. Do you understand I want to edit the '''URL''' of a bookmark just added? There's a different dialog I've mentioned numerous times already.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

No problems here to click the location line and edit the URL in the Edit This Bookmark dialog.

Does that at least work for you in the Library ?


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
No problems here to click the location line and edit the URL in the Edit This Bookmark dialog. Does that at least work for you in the Library ? ----- Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Question owner

I've checked with another computer running Mac and with my own computer with a completely new profile (no styles applied). None of them had that dialog opened. I'm quiet reassured now this dialog was removed.

cor-el if you are positive you can bring that dialog on _your_ computer, I'd be happy to see a screenshot / screencast of you making that dialog appear.

I've checked with another computer running Mac and with my own computer with a completely new profile (no styles applied). None of them had that dialog opened. I'm quiet reassured now this dialog was removed. cor-el if you are positive you can bring that dialog on _your_ computer, I'd be happy to see a screenshot / screencast of you making that dialog appear.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Did you try this in a new profile ?

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


The normal procedure to create a new bookmark is:

  1. You click the star on the Navigation Toolbar or press "Ctrl/Command + D" and the star would get highlighted blue
  2. If the browser.bookmarks.editDialog.showForNewBookmarks pref is true then you will get the "Edit This Bookmark" dialog where you can edit Name and Location and Folder where to create the new bookmark (default is Other Bookmarks).

Note that the dialog will close if you click outside the dialog or close automatically after three seconds if you use "Ctrl/Command + D" to create the bookmark and do not hover the mouse on the dialog or click a field. If you do not get the dialog automatically then a left click on the highlighted star should open the dialog.

How far do you get ? Do you get a highlighted star when you click the star to create the bookmark ? Do you get a highlighted star when you use Ctrl+D to create the bookmark ? Does the dialog open, but you aren't able to set focus to the location field and can't modify its value ? Does the dialog always open if you click the highlighted star ?

Did you try this in a new profile ? You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile ----- The normal procedure to create a new bookmark is: # You click the star on the Navigation Toolbar or press "Ctrl/Command + D" and the star would get highlighted blue # If the <b>browser.bookmarks.editDialog.showForNewBookmarks</b> pref is true then you will get the "Edit This Bookmark" dialog where you can edit Name and Location and Folder where to create the new bookmark (default is Other Bookmarks). Note that the dialog will close if you click outside the dialog or close automatically after three seconds if you use "Ctrl/Command + D" to create the bookmark and do not hover the mouse on the dialog or click a field. If you do not get the dialog automatically then a left click on the highlighted star should open the dialog. How far do you get ? Do you get a highlighted star when you click the star to create the bookmark ? Do you get a highlighted star when you use Ctrl+D to create the bookmark ? Does the dialog open, but you aren't able to set focus to the location field and can't modify its value ? Does the dialog always open if you click the highlighted star ?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.