X
Tap here to go to the mobile version of the site.

Support Forum

Your Mac update deleted all my email homepage logins

Posted

The home page for fastmail.com lists my four accounts there and acts as the FFox browser's home page on my Mac. After today's FFox update – as has happened in the past – the saved account names and passwords have vanished and I am currently having to login to each account manually. Even after setting them up again, because I have Firefox set to clear the cache when logging out, these Fastmail logins are being deleted. Unlike google.com's efficient generic home page which remembers the several google accounts it holds.

The home page for fastmail.com lists my four accounts there and acts as the FFox browser's home page on my Mac. After today's FFox update – as has happened in the past – the saved account names and passwords have vanished and I am currently having to login to each account manually. Even after setting them up again, because I have Firefox set to clear the cache when logging out, these Fastmail logins are being deleted. Unlike google.com's efficient generic home page which remembers the several google accounts it holds.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4127 solutions 57590 answers

Are you saying the browser lost your passwords, or were you logged out of everything?

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.

Are you saying the browser lost your passwords, or were you logged out of everything? Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out. ------------ In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
4127 solutions 57590 answers

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 66.0.1 March 22, 2019

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''66.0.1''' March 22, 2019
Was this helpful to you?
Quote

Question owner

Hi Fred - You misunderstand. The menu displaying the names of each email account where I long into Fastmail is empty when I open the FFox browser. Just as with a Googlemail login, the panel usually shows the names of your accounts in a stored dropdown menu, and you chooose the one you want by clicking on it, then doing the same for its password. After today's FFox update to 66.0.1 which instigated itself (I did not initiate an update as my browser is set to respond automatically to updates) the mail menu was completely blank. Yes I can manually type in the full name of an email account, then type in its relevant password and go through to use mail. But it is Fastmail's own home page greeting panel which did/does not automatically show the menu of accounts. Even when you start to type an account name it does not autocomplete. This identical phenomenon did occur a year or so ago after an update and Mozilla did offer another update to remedy it a few days later.

Hi Fred - You misunderstand. The menu displaying the names of each email account where I long into Fastmail is empty when I open the FFox browser. Just as with a Googlemail login, the panel usually shows the names of your accounts in a stored dropdown menu, and you chooose the one you want by clicking on it, then doing the same for its password. After today's FFox update to 66.0.1 which instigated itself (I did not initiate an update as my browser is set to respond automatically to updates) the mail menu was completely blank. Yes I can manually type in the full name of an email account, then type in its relevant password and go through to use mail. But it is Fastmail's own home page greeting panel which did/does not automatically show the menu of accounts. Even when you start to type an account name it does not autocomplete. This identical phenomenon did occur a year or so ago after an update and Mozilla did offer another update to remedy it a few days later.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4127 solutions 57590 answers

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8434 solutions 68835 answers

Helpful Reply

Setting Firefox to clear ONLY your cache shouldn't affect form history, cookies, or saved logins. Which setting are you using to clear your cache? If it's the "Clear history when Firefox closes" feature, click the Settings button and uncheck the categories of data you want to preserve.

Setting Firefox to clear ONLY your cache shouldn't affect form history, cookies, or saved logins. Which setting are you using to clear your cache? If it's the "Clear history when Firefox closes" feature, click the Settings button and uncheck the categories of data you want to preserve.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4127 solutions 57590 answers

Helpful Reply

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache leaving the others off.

Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn off '''Always Use Private Browsing Mode''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' leaving the others off.
Was this helpful to you? 1
Quote

Question owner

Thanks jscher2000 for clarifying those settings. BUT what is so annoying is that this pain resulted from the automatic Mozilla update – nothing I had done personally. As I've said above, this has happened following another previous update. Thanks also to Fred - you got there in your last line!

LATER THE SAME DAY: Oops! Spoke too soon. I've adjusted the Preferences as you both advised. But the dropdown menu of Fastmail Usernames sometimes offers a list, yet just now again offers no cached usernames and I've had to type one in afresh. Having done that it does actually offer the password correctly!

As I've said this kind of glitch did require Mozilla to put out a further update last year. I await their action.

Thanks jscher2000 for clarifying those settings. BUT what is so annoying is that this pain resulted from the automatic Mozilla update – nothing I had done personally. As I've said above, this has happened following another previous update. Thanks also to Fred - you got there in your last line! LATER THE SAME DAY: Oops! Spoke too soon. I've adjusted the Preferences as you both advised. But the dropdown menu of Fastmail Usernames sometimes offers a list, yet just now again offers no cached usernames and I've had to type one in afresh. Having done that it does actually offer the password correctly! As I've said this kind of glitch did require Mozilla to put out a further update last year. I await their action.

Modified by J1709

Was this helpful to you?
Quote

Question owner

Yet another FF update has wiped the four Fastmail accounts from the Fastmail dropdown menu set as my home page. This is my 24/7 working browser equipped with all necessary bookmarks and passwords. If Mozilla is going to disrupt my daily life so much I've got to switch to another browser though which one I do not know. Firefox's compulsion to keep replacing my chosen search engine with Yahoo is a thought crime I cannot tolerate. Why won't you people stop trying to second-guess my needs by imposing your own favourite engine??? Yes I've posed this question elsewhere without any solution being offered.

This long saga has demolished any respect I had for Mozilla's support service.

Yet another FF update has wiped the four Fastmail accounts from the Fastmail dropdown menu set as my home page. This is my 24/7 working browser equipped with all necessary bookmarks and passwords. If Mozilla is going to disrupt my daily life so much I've got to switch to another browser though which one I do not know. Firefox's compulsion to keep replacing my chosen search engine with Yahoo is a thought crime I cannot tolerate. Why won't you people stop trying to second-guess my needs by imposing your own favourite engine??? Yes I've posed this question elsewhere without any solution being offered. This long saga has demolished any respect I had for Mozilla's support service.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8434 solutions 68835 answers

Hi J1709, Yahoo is not the default search engine in Firefox 57-68, or even included as an option in any version of Firefox any more. Most likely the change was caused by an add-on, external configuration file, or malware.

What is the exact name of the unwanted Yahoo-based search engine, and what is the URL of a sample results page? This may provide clues to why it is there.

Malware Sweep

I suggest starting with a cleaning using: https://www.malwarebytes.com/mac/

Extension Cleanup

Next, you can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Usually that is enough to restore your ability to remove the unwanted search engine and assign your preferred default. See: Change your default search settings in Firefox.

Autconfig Removal

If your preferred search engine is switched to Yahoo again again at your next Firefox startup, could you check the following location, which allows files to override normal Firefox behavior:

/Applications/Firefox.app/Contents/Resources/defaults/pref

A file named channel-prefs.js is normal here. Any other file in this folder is suspicious if you do not remember creating it yourself. Remove any such files to a neutral location for further analysis at your leisure.

Hi J1709, Yahoo is not the default search engine in Firefox 57-68, or even included as an option in any version of Firefox any more. Most likely the change was caused by an add-on, external configuration file, or malware. What is the exact name of the unwanted Yahoo-based search engine, and what is the URL of a sample results page? This may provide clues to why it is there. '''''Malware Sweep''''' I suggest starting with a cleaning using: https://www.malwarebytes.com/mac/ '''''Extension Cleanup''''' Next, you can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? Usually that is enough to restore your ability to remove the unwanted search engine and assign your preferred default. See: [[Change your default search settings in Firefox]]. '''''Autconfig Removal''''' If your preferred search engine is switched to Yahoo again again at your next Firefox startup, could you check the following location, which allows files to override normal Firefox behavior: /Applications/Firefox.app/Contents/Resources/defaults/pref A file named '''channel-prefs.js''' is normal here. '''Any other file''' in this folder is suspicious if you do not remember creating it yourself. Remove any such files to a neutral location for further analysis at your leisure.
Was this helpful to you? 0
Quote

Question owner

Hi jscher2000 - I'm afraid you've answered a different question about Yahoo that I had posed on another page. This page is about "Mac update deleted all my email homepage logins" – more than once so I am manually having to type in each username in order to open each email account with fastmail.

Hi jscher2000 - I'm afraid you've answered a different question about Yahoo that I had posed on another page. This page is about "Mac update deleted all my email homepage logins" – more than once so I am manually having to type in each username in order to open each email account with fastmail.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8434 solutions 68835 answers

Actually, you mentioned the Yahoo problem in your reply immediately before my reply. I didn't realize there was a different thread going on that.

When I look at Fastmail's support pages, I think I see what you are referring to as the expected behavior:

When you go to our homepage, you will be shown any currently logged in accounts. Select one to go to the account's Inbox. To log in to another account, click the "Log in to another account" link at the bottom of this list.

From: https://www.fastmail.com/help/account/showlogin.html

The diagnosis that cookies are being cleared or invalidated for some reason is the most likely one. Has this thread exhausted all the possible ways that cookie-based sign-in could be going wrong? I recently made a long post you could double-check:

https://support.mozilla.org/questions/1257524#answer-1217280

(One thing you won't see listed is "Firefox updated" because that shouldn't affect cookies. If it does, I don't have an explanation for that.)

Actually, you mentioned the Yahoo problem in your reply immediately before my reply. I didn't realize there was a different thread going on that. When I look at Fastmail's support pages, I think I see what you are referring to as the expected behavior: <blockquote>When you go to [https://www.fastmail.com/ our homepage], you will be shown any currently logged in accounts. Select one to go to the account's Inbox. To log in to another account, click the "Log in to another account" link at the bottom of this list.</blockquote> ''From:'' https://www.fastmail.com/help/account/showlogin.html The diagnosis that cookies are being cleared or invalidated ''for some reason'' is the most likely one. Has this thread exhausted all the possible ways that cookie-based sign-in could be going wrong? I recently made a long post you could double-check: https://support.mozilla.org/questions/1257524#answer-1217280 (One thing you won't see listed is "Firefox updated" because that ''shouldn't'' affect cookies. If it does, I don't have an explanation for that.)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17204 solutions 155449 answers

Can you clarify whether you still see the usernames and passwords listed in the Password Manager and that they only do not show on the website as an auto-fill choice?

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"
Can you clarify whether you still see the usernames and passwords listed in the Password Manager and that they only do not show on the website as an auto-fill choice? *Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"
Was this helpful to you? 1
Quote

Question owner

Hi Cor-el - Yes all four Fastmail usernames and passwords are listed in the manager and are ticked to autofill. When I open FFox from scratch with Fastmail as my home page, the username slot does now offer the four username accounts it has been set up to deliver for years. I can click one and its password will fill automatically and can go through to use email. If I then close that first account "A", it then remains the only username visible to access via a hotlink now on the home page. The other three are no longer showing because there is no longer a letterbox slot. Only by closing FFox and reloading it can I then see all four possible usernames and choose one such as "B" and go through to use it successfully. All of this remains erratic at best.

Hi Cor-el - Yes all four Fastmail usernames and passwords are listed in the manager and are ticked to autofill. When I open FFox from scratch with Fastmail as my home page, the username slot does now offer the four username accounts it has been set up to deliver for years. I can click one and its password will fill automatically and can go through to use email. If I then close that first account "A", it then remains the only username visible to access via a hotlink now on the home page. The other three are no longer showing because there is no longer a letterbox slot. Only by closing FFox and reloading it can I then see all four possible usernames and choose one such as "B" and go through to use it successfully. All of this remains erratic at best.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.