Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incorrect display of information on NatWest Bank Online Banking

  • 11 replies
  • 1 has this problem
  • 62 views
  • Last reply by cor-el

more options

Hi,

On most occasions, when I visit my on line bank account, I find the information displayed incorrectly; also many services, which are selectable, are missing.

The attached image (with account identification and personal information removed), was taken using MS Edge, shows the opening page, as it should appear.

When I open my account, using the latest version of Firefox, I find that all four of my accounts show the transactions, as if the "Down Arrow" has been clicked - But there is no "Down Arrow" visible with Firefox (To set, or Reset).

Furthermore, with the accounts open, showing the transactions, there should be additional "Down Arrows" to show pending transactions (ones that have not yet been processed) - These "Down Arrows" are not present, either.

I have entered Privacy & Security and selected:-

(1) Accept cookies and site data from web sites (recommended)

(2) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too)

(3) Accept cookies and site data from web sites (recommended) - Set to Always - ( I have tried all of the other options, too)

(4) Selected Never, for Tracking Protection - ( I have tried all of the other options, too)

(5) Selected Only when using Tracking Protection, in the Send web sites a “Do Not Track” signal that you don’t want to be tracked, option - - ( I have tried all of the other options, too)

(6) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too), in Block pop-up windows.

(7) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too), in Warn you when web sites try to install add-ons

None of these issues arise with Google Chrome, Internet Explorer, or MS Edge - All work perfectly, with the default setting.

Appreciate any thoughts on this matter

Hi, On most occasions, when I visit my on line bank account, I find the information displayed incorrectly; also many services, which are selectable, are missing. The attached image (with account identification and personal information removed), was taken using MS Edge, shows the opening page, as it should appear. When I open my account, using the latest version of Firefox, I find that all four of my accounts show the transactions, as if the "Down Arrow" has been clicked - But there is no "Down Arrow" visible with Firefox (To set, or Reset). Furthermore, with the accounts open, showing the transactions, there should be additional "Down Arrows" to show pending transactions (ones that have not yet been processed) - These "Down Arrows" are not present, either. I have entered Privacy & Security and selected:- (1) Accept cookies and site data from web sites (recommended) (2) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too) (3) Accept cookies and site data from web sites (recommended) - Set to Always - ( I have tried all of the other options, too) (4) Selected Never, for Tracking Protection - ( I have tried all of the other options, too) (5) Selected Only when using Tracking Protection, in the Send web sites a “Do Not Track” signal that you don’t want to be tracked, option - - ( I have tried all of the other options, too) (6) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too), in Block pop-up windows. (7) Listed my Bank web link details in Exceptions to "Allow" ( I have tried all of the other options, too), in Warn you when web sites try to install add-ons None of these issues arise with Google Chrome, Internet Explorer, or MS Edge - All work perfectly, with the default setting. Appreciate any thoughts on this matter
Attached screenshots

Modified by Brian

Chosen solution

For those experiencing a similar problem, I think that I have found a solution:-

Open in a New Private Window

This has worked without any problems; not sure why!

Read this answer in context 👍 0

All Replies (11)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Good morning, Fred,

Thank you for your message, and suggestions.

Immediately after clearing the Cache and removing the Cookies, my first log on to my bank, was successful.

However, after logging out from my bank, closing Firefox, restarting Firefox and then logging on to my bank, again, the problem was present, again.

Also tried disabling graphics hardware acceleration in Firefox, and again the problem was still present.

So sadly, problem not resolved

more options

Puncball said

Immediately after clearing the Cache and removing the Cookies, my first log on to my bank, was successful.

Interesting Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History.

more options

Hi Fred,

A bit of a mixed bag.

Yes, if I follow your advice, and include Cookies in your:-

"At the far right, press the Settings button. Turn on Cache and Form And Search History.

Then my on-line banking account functions as it should.

However, with these settings, I now find that I have to log on, every time, when I visit other sites, where I have chosen to stay logged on too.

Also, I find that many other web sites now require me to select that I accept cookies.

I can live with these new occurrences, but they are a bit of a disappointment, as they don't happen with other browsers

more options

Is this only happening on those pages when you are logged in?

Does the website use local storage?

Did you try to enable third-party cookies (temporarily) to see if that has effect?

Did you check the Web Console to see if there are errors reported?

more options

Hi Cor-el,

Most grateful for your input, but I have given up, having played around with all of the options, including enabling third-party cookies (temporarily) .

Clearing one issue, introduces another, as I mentioned, above.

Sadly, as much as I like the speed and layout, of Firefox, it is turning out to be too problematic.

So with some disappointment I have returned to MS Edge, as my default browser, which has less issues for me, except for that dreadful Bing Search Engine.

I shall try Firefox again, in the future to see if the developers have got around the issues, which bug me!

Kindest Regards to you and Fred

more options

Sorry we could not help you.

Puncball said

except for that dreadful Bing Search Engine.

See if you can change the default search engine/homepage.

more options

Chosen Solution

For those experiencing a similar problem, I think that I have found a solution:-

Open in a New Private Window

This has worked without any problems; not sure why!

more options

Using Private Windows also activates Tracking Protection; https://support.mozilla.org/en-US/kb/tracking-protection

more options

FredMcD said

Using Private Windows also activates Tracking Protection; https://support.mozilla.org/en-US/kb/tracking-protection

Thanks for this info, Fred, but I've tried activating Tracking Protection, as an alternative to Open in a New Private Window, and sadly this does not resolve the issue

more options

A Private Browsing mode doesn't use the regular cookies and doesn't use the disk cache. Either (or both) of these are much more likely candidates for issues.