Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove bing search

  • 84 replies
  • 15 have this problem
  • 6618 views
  • Last reply by KeithElmer

more options

Home page is Google. When I search I get bing results. How do I stop this

Modified by guigs

Chosen solution

Hi KeithElmer, thanks for the list. This is the one mufngruf was saying you need to remove:

SafeSearch Incognito 0.1.8 true @safesearchincognito

Can you find that on the Add-ons page? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. See whether you can remove "SafeSearch Incognito" (look for a Remove button). If you do not find a Remove button, that usually indicates it was installed in a shared folder, and I can suggest a roundabout way to track down where that is.

Of course, all extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Success?

Read this answer in context 👍 3

All Replies (20)

more options

mufngruf said

And, no, I no longer get Bing results.

Problem solved then   .........   Yippee   !

more options

It’s very sad, but many of the software downloaders / installers will trick you into installing not only their program, but other programs as well. You have heard of the fine print in shady contracts, right? Well, some installers you need to look at the itsy bitsy teeny weeny fine print. You are thinking you are giving the installer permission to install the program you want by using the recommended option. But if you use the Manual Option Instead, you discover all kinds of stuff that you do not even know what it is or what it does. From now on, everyone needs to Use The Manual Option to put a stop to this.

more options

Very well said   !!!

more options

Hi I have been away from my computer for a while. I have read with interest the communications, since I last replied. I have just tried searching about.config for browser.search.order.3. This gives a value of Bing. So I suspect this is the problem, but the reply from FredMcD suggested that if you right chick on it you can rest it. However this is not an available option. The options are Modify, copy copy name copy value or new as reset is greyed out.

more options

Okay, change it to another search engine.

more options

To   KeithElmer   and   FredMcD:

I was led to believe that  'search.order.3'   means it's   'third in line',   so to speak.
To be ignored until,   for some weird reason,   nr. 1   and   nr. 2   should disappear.

Modified by Happy112

more options

I suppose, since my initial problem was fixed, I just just kinda shut up, go away and be happy... BUT.. for me, I still wanna get rid of all those bing options. It has no place in my browser and it seems like it's just... lurking there, y'know? Any idea how I could just get rid of them altogether?

Modified by mufngruf

more options

In   'about:config'   do  not   click on anything,   unless you're absolutely sure that you know what you're doing   !

more options

mufngruf said

I suppose, since my initial problem was fixed, I just just kinda shut up, go away and be happy... BUT.. for me, I still wanna get rid of all those bing options. It has no place in my browser and it seems like it's just... lurking there, y'know? Any idea how I could just get rid of them altogether?

I understand where you're coming from,   considering what you've been through,   but there will be so many things on your computer that you neither need nor want;  as long as they're not doing any harm:   just ignore them and carry on   .......

Modified by Happy112

more options

yes - but this crap isn't on my COMPUTER.. it's in my BROWSER..

is the answer really "just put up with it, it could be worse?"

more options

So at the risk of being boring, this is what I put at the start. Home page is Google. When I search I get bing results. How do I stop this?

more options

Keith - look for that pesky "safesearch" thing... that's what finally worked for me.

more options

KeithElmer said

So at the risk of being boring, this is what I put at the start. Home page is Google. When I search I get bing results. How do I stop this?

Are you kidding me   ? You're problem was solved   ........   (?) What happened   ?

more options

mufngruf said

yes - but this crap isn't on my COMPUTER.. it's in my BROWSER.. is the answer really "just put up with it, it could be worse?"

Your browser is on your computer   .......
Again:   I understand where you're coming from and I know why this keeps bothering you so much.
Suggestion:   since this thread has been marked as solved,   not many people will be looking at it.
Why don't you post a new question,   start your own thread,   and who
knows:   maybe someone will come up with the perfect solution for you   .......

more options

Hi KeithElmer, is the problem with a Firefox search box in one of these places --

  • Search bar (usually toward the right end of the main toolbar)
  • Address bar
  • Built-in Firefox home page
  • Built-in Firefox new tab page

-- or in Google's own site at https://www.google.com/ or somewhere else?

If you follow a link to a Google results page, do you get Google results?

https://www.google.com/search?q=firefox&ie=utf-8&oe=utf-8&client=firefox-b

If that gives you Google results, does searching in the search box on that page stay on Google or switch to Bing?

99% of the replies in this thread assume the problem is that you have used one of Firefox's search boxes, and that your default search engine is set to Google (see Change your default search settings in Firefox), so it would be useful to know if the discussion is on track.

more options

mufngruf said

I suppose, since my initial problem was fixed, I just just kinda shut up, go away and be happy... BUT.. for me, I still wanna get rid of all those bing options. It has no place in my browser and it seems like it's just... lurking there, y'know?
Any idea how I could just get rid of them altogether?

Some preferences are included in the program and can't be removed. If you want to know about specific preferences, please copy/paste their exact names for discussion.

When not hijacked by bad add-ons, malware, or external "cleaners," your default search engine setting should remain unchanged indefinitely, and can be changed back in a few seconds if needed (Change your default search settings in Firefox). Dormant preferences have no effect on that.

more options

Reply to jscher 2000 The problem occurs whether I use the search bar, the address bar or google search box. It occurs with the built in firefox homepage and with a new tab and firefox homepage. It does not occur when I use internet explorer

more options

Hi KeithElmer, do you mean --

The problem occurs whether I use the search bar, the address bar or google search box.

-- Google's own page gives you Bing results? This thread is very long now, so apologies for the likely repetition, but have you already ruled out these potential culprits for this problem:

(1) Extension(s): don't limit your scrutiny to extensions that have Bing in the name. Do you want to post a list for comment? The easiest way is to copy/paste the list from the troubleshooting information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Then scroll down to Extensions and just below that heading, select and copy the table, then paste that into a reply. It will look a bit messy, but we're used to it.

(2) Connection settings: please check for a proxy server problem on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that helps.

more options

Sorry for the long delay. Facebook 0.0.1 true @fecebookcolorchange Google Analytics Opt-out Browser Add-on 0.9.8 true {6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65} Kaspersky Protection 4.6.3-9 true light_plugin_ACF0E80077C511E59DED005056C00008@kaspersky.com Multi-process staged rollout 1.3 true e10srollout@mozilla.org Pocket 1.0.5 true firefox@getpocket.com SafeSearch Incognito 0.1.8 true @safesearchincognito Skype 8.0.0.9103 true {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A} Web Compat 1.0 true webcompat@mozilla.org Firefox Hotfix 20160826.01 false firefox-hotfix@mozilla.org Logitech SetPoint 6.5 false {F003DA68-8256-4b37-A6C4-350FA04494DF}

more options

Changing to no proxy had no effect

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5