Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove bing search

  • 84 replies
  • 15 have this problem
  • 6618 views
  • Last reply by KeithElmer

more options

Home page is Google. When I search I get bing results. How do I stop this

Modified by guigs

Chosen solution

Hi KeithElmer, thanks for the list. This is the one mufngruf was saying you need to remove:

SafeSearch Incognito 0.1.8 true @safesearchincognito

Can you find that on the Add-ons page? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. See whether you can remove "SafeSearch Incognito" (look for a Remove button). If you do not find a Remove button, that usually indicates it was installed in a shared folder, and I can suggest a roundabout way to track down where that is.

Of course, all extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Success?

Read this answer in context 👍 3

All Replies (20)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Right-click browser.search.order.3 and select reset

Does that do anything?


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

the reset option is greyed out. I do NOT have mayware on my computer.

more options

Shot in the dark:

What if you removed these two extensions:

  • Traffic Light Settings
  • Xmarks
more options

as I already said - I have taken each add on, one by one, and disabled it until they were all disabled. But the problem persists. Whereas, if I start in safe mode (with add ons turned off), the issue is solved., There MUST be something in the latest FF update - I have changed nothing else. And what about those bing choices in the about:config panel.. why are they greyed out?

more options

no offence, but isn't there a way to get Mozilla to respond to these questions? No-one in this forum seems to have a solution that works.

more options

Hi mufngruf, can you copy/paste your list of extensions from the Troubleshooting Information page. Here's how:

Open the troubleshooting information page using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Then scroll down to Extensions and just below that heading, select and copy the table, then paste that into a reply. It will look a bit messy, but we're used to it.

mufngruf said

no offence, but isn't there a way to get Mozilla to respond to these questions? No-one in this forum seems to have a solution that works.

This is the official support channel. You are encouraged to start your own question about this problem if the solution in another poster's thread didn't work for you.

more options

as you asked.. hope it helps

1Password 4.6.1 true onepassword4@agilebits.com AdBlocker Ultimate 2.23 true adblockultimate@adblockultimate.net Ant Video Downloader 2.4.7.45 true anttoolbar@ant.com Classic Theme Restorer 1.5.8 true ClassicThemeRestorer@ArisT2Noia4dev Download Status Bar 15.0.0.1 true {6c28e999-e900-4635-a39d-b1ec90ba0c0f} Download YouTube Videos as MP4 1.8.8 true {b9bfaf1c-a63f-47cd-8b9a-29526ced9060} FEBE 8.9.2 true {4BBDD651-70CF-4821-84F8-2B918CF89CA3} Flashblock 1.5.20 true {3d7eb24f-2740-49df-8937-200b1cc08f8a} Google translate https 1.1.1-signed.1-signed true jid1-vhLR6vkMUx9csw@jetpack Greasemonkey 3.9 true {e4a8a97b-f2ed-450b-b12d-ee082ba24781} InFormEnter 0.76.1-signed.1-signed true {5546F97E-11A5-46b0-9082-32AD74AAA920} Lazarus: Form Recovery 2.3.1-signed.1-signed true lazarus@interclue.com LinkChecker 0.6.7.1-signed.1-signed true {49f3fc85-dcfe-4e42-9301-226ebe658509} Multi-process staged rollout 1.2 true e10srollout@mozilla.org Myibidder (Myibay) Bid Sniper for eBay 1.3.7.1-signed.1-signed true firefox1@myibay.com PDF Download 3.0.0.2.1-signed.1-signed true {37E4D8EA-8BDA-4831-8EA1-89053939A250} Pocket 1.0.4 true firefox@getpocket.com Real-Debrid extension 1.4.8 true firefox@realdebrid Save as PDF 1.5.1-signed.1-signed true save-as-pdf-ff@pdfcrowd.com Tabs on Bottom 0.7.3 true tabsonbottom@piro.sakura.ne.jp To Google Translate 0.3.1-signed.1-signed true jid1-93WyvpgvxzGATw@jetpack Video DownloadHelper 6.1.1 true {b9db16a4-6edc-47ec-a1f4-b86292ed211d} Web Compat 1.0 true webcompat@mozilla.org Xmarks 4.3.19 true foxmarks@kei.com ZenMate Security, Privacy & Unblock VPN 5.9.0 true firefox@zenmate.com Adblock Plus 2.7.3 false {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Autofill Forms 1.1.5 false autofillForms@blueimp.net Blur 5.3.1983 false donottrackplus@abine.com Cache Status 0.9.3 false cache@status.org Download Tab 0.2.1-signed.1-signed false {a949831f-d9c0-45ae-8c60-91c2a86fbfb6} Flash and Video Download 2.02 false {bee6eb20-01e0-ebd1-da83-080329fb9a3a} FlashGot 1.5.6.13 false {19503e42-ca3c-4c27-b1e2-9cdb2170ee34} Ghostery 7.0.1.4 false firefox@ghostery.com HTML5 Video Everywhere! 0.3.4 false html5-video-everywhere@lejenome.me JavaScript Deobfuscator 2.0.4 false jsdeobfuscator@adblockplus.org New Tab Override (browser.newtab.url replacement) 4.0.1 false newtaboverride@agenedia.com NoScript 2.9.0.14 false {73a6fe31-595d-460b-a920-fcc0f8843232} SafeSearch Incognito 0.1.7 false @safesearchincognito SmoothWheel (AMO) 0.45.8.20130519.3.1-signed.1-signed false {5F590AA2-1221-4113-A6F4-A4BB62414FAC} TrafficLight 0.2.23.1-signed.1-signed false trafficlight@bitdefender.com Translate This! 3.5.0 false jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack Video WithOut Flash 3.1.2 false vwof@drev.com

more options

please bear in mind that the items that are enabled at the moment have been enabled for some time - long before this Bing thing happened.

more options

Hi mufngruf, it seems you disabled about half your extensions. Try disabling everything except these:

  • 1Password
  • Classic Theme Restorer
  • Download Status Bar
  • Tabs on Bottom
  • Xmarks

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

To put that another way, I suggest testing with the following switched from enabled to disabled:

  • AdBlocker Ultimate 2.23
  • Ant Video Downloader 2.4.7.45
  • Download YouTube Videos as MP4 1.8.8
  • FEBE 8.9.2
  • Flashblock 1.5.20
  • Google translate https 1.1.1-signed.1-signed
  • Greasemonkey 3.9
  • InFormEnter 0.76.1-signed.1-signed
  • Lazarus: Form Recovery 2.3.1-signed.1-signed
  • LinkChecker 0.6.7.1-signed.1-signed
  • Myibidder (Myibay) Bid Sniper for eBay 1.3.7.1-signed.1-signed
  • PDF Download 3.0.0.2.1-signed.1-signed
  • Real-Debrid extension 1.4.8
  • Save as PDF 1.5.1-signed.1-signed
  • To Google Translate 0.3.1-signed.1-signed
  • Video DownloadHelper 6.1.1
  • ZenMate Security, Privacy & Unblock VPN 5.9.0
more options

again - no offense, but you're not reading what I have written about the situation... as I already said - I have taken each add on, one by one, and disabled it until they were all disabled. But the problem persists. Whereas, if I start in "Safe Mode" (with add ons turned off), the issue is solved.,

and ALL of these add-ons have been there for a long time BEFORE this problem started.

Modified by mufngruf

more options

mufngruf said

I have taken each add on, one by one, and disabled it until they were all disabled. But the problem persists. Whereas, if I start in "Safe Mode" (with add ons turned off), the issue is solved.,

This might help, Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

more options

AGAIN - this has already been suggested and done.. hardware acc IS turned off.. and has been.. and your hot key combo "Hot key; <Control>(Mac=<Command>) <Shift> A)" simply selects everything on the page.. and the only "appearance" choice there is, is default.

more options

Hi mufngruf, you got a Windows keyboard shortcut because you posted in a Windows user's thread.

I appreciate that you have no faith in my suggested next step for troubleshooting, but equally, I find it hard to believe your results.

Can you check whether any of the extensions I suggested disabling are invisible on the Add-ons page, Extensions list?

Also, would you like you try this:

New Profile Test

This takes about 3 minutes, plus the time to test searching.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Oct2016, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button.

Firefox should exit and then start up using the new profile, which will just look brand new.

Does searching work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

jscher2000 said

This is the official support channel. You are encouraged to start your own question about this problem if the solution in another poster's thread didn't work for you. </blockquote>

why would I start another thread with exactly the same topic and question? I don't understand... if this is indeed the "official support channel", why do I have to keep repeating myself and how about an answer to some of the actual questions I have asked, such as... "And what about those bing choices in the about:config panel.. why are they greyed out?"

It's not that I am not gratedful for the attempts to help - but they're not, frankly, being at all helpful and I tire of having to answer the same questions over and over again.

It's this simple.. SUDDENLY, yesterday, whenever I searched in my usual Google search box, the response I get is from Bing.com. So - I began turning each add on to "disable" and, after each one, I'd restart FF, discover that the issue persisted, and then turned off another one - LEAVING THE FIRST ALSO STILL DISABLED., then a restart again and a re-test... and continued until ALL of the add-ons were disabled.. but still the problem persisted. BUT - If I go to the "question mark" and click "Restart with add ons disabled" - when FF re-opens, the uissue is fixed. I have deleted the Bing option in the search prefs and chosen google. I do not have this issue in any other browser and I have run three different anti-virus programs which have found nothing. The problem, clearly, is within Firefox itself.. and, coincidentally, it was only a day ago that there was a FF update abut security issues, which, of course, I allowed. Will a new installation of FF cure this problem? I REALLY don't want to "refresh" because I ALWAYS lose stuff.. and it's a pain... and, also, because if I don't know what caused this in the first place, i have no real way to prevent it again, right? UNless I simply ignore FF updates - and what's the sense in that?

more options

sorry - there's nothing on this thread that suggests that it is a windows thread.. I don't have faith in your suggestions because none of them have worked.. or I have had to keep repeating that i have already TRIED that.. on the other hand, what reason do you have to disbelieve what i am telling you? Why on earth would I make it up..

still, moving onwards..., I'll try this "new profile" thing, and let you know if it works.

more options

OK - created a new profile and opened using it. I did NOT set it up to import all my bookmarks and stuff.. but the search is working correctly. Now what have we discovered?

more options

mufngruf said

It's this simple.. SUDDENLY, yesterday, whenever I searched in my usual Google search box, the response I get is from Bing.com.

Do you mean a Firefox search box in one of these places --

  • Search bar (usually toward the right end of the main toolbar)
  • Address bar
  • Built-in Firefox home page
  • Built-in Firefox new tab page

-- or in Google's own site at https://www.google.com/ or somewhere else?

If you follow a link to a Google results page, do you get Google results?

https://www.google.com/search?q=firefox&ie=utf-8&oe=utf-8&client=firefox-b

more options

google search bar - top right

I just tried entering a search in the main URL box at the top.. and hit enter. When I did, the immediate response was "search in google" - but it still brought me to the bing page. I can TRY to take a couple of screenshots showing the process, iif that will help? But, here in a nutshell is the main question... If I manually disable all the add-ons.. and the issue persists BUT when I "restart with add-ons disabled", the issue is fixed. So what does the "restart with add-ons disabled" function do that manually disabling all the add ons doesn't do?

Modified by mufngruf

more options

mufngruf said

OK - created a new profile and opened using it. I did NOT set it up to import all my bookmarks and stuff.. but the search is working correctly. Now what have we discovered?

Just that it's a settings problem. Try this to see whether you can transfer the problem from the old profile to the new profile without add-ons:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing various files and folders in Finder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename prefs.js to something like prefs.old.

In Finder, navigate to the Profiles folder one level up, and double-click into your normal profile. Right-click (Ctrl+click) the prefs.js file there and Copy. Go back to your test profile and paste the file.

Start Firefox back up again. Does the problem return, or still good?

more options

OK - I tried that, but with some complications. Firstly, I now have four profile folders.. see picture so, I went to "default user" because that seemed like the most recent and the largest but I found a "prefs.js" file and also a "prefs-2.js"

I renamed the "prefs.js" file to "prefs.old" and copy/pasted it into the "new" profile.. made it 'default" and opened normally.. I got a clean FF but none of my settings were there. I went back and made the old default back and restarted it.. al is as it was.. and the search still doesn't work. If this is indeed a settings issue - what changed it? and, again, If I manually disable all the add-ons.. and the issue persists BUT when I "restart with add-ons disabled", the issue is fixed. So what does the "restart with add-ons disabled" function do that manually disabling all the add ons doesn't do?

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5