Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

put www.baidu.com redirect to http://www.baidu.com/baidu.html?from=noscript

  • 2 replies
  • 1 has this problem
  • 65 views
  • Last reply by cor-el

more options

put the site www.baidu.com ,but it redirect to http://www.baidu.com/baidu.html?from=noscript,and some website is not work in firefox, but it is right in chrome

put the site www.baidu.com ,but it redirect to http://www.baidu.com/baidu.html?from=noscript,and some website is not work in firefox, but it is right in chrome

All Replies (2)

more options

My guess is that you have the NoScript extension installed [based upon that message from Baidu], and you need to learn how to use it. Few websites these days will work properly, or work all with the default setting in NoScript - blocking all JavaScript.

NoScript is a powerful extension, but it is a pain in the arse to use until you know how it works and start setting permissions for your most commonly used websites so that the features of the website that you want to use actually work.

With all the attention placed on "social media" these days the number outside domains that many websites connect to has expanded from [like] 3 or 4 per webpage 5 or 6 years ago, to sometimes over 25 different websites these days - and NoScript will block them all until you allow them piece-mail, or globally each time you visit a website.

You need to take the time to learn how to use NoScript -- or uninstall it if you don't want to put the time in to learn how it works and the time to "allow" for every website that you visit. IMO, it's not an extension for 'rookie' users - really only for medium or advanced level users who understand how it works and want to put in the time for the greatest protection as offered by NoScript.

https://noscript.net/ https://noscript.net/features https://noscript.net/faq https://noscript.net/screenshots


I have used NoScript since it first came out and in recent years I have been using NoScript with the "whitelist" set in NoScript Options to Scripts Globally Allowed (dangerous) in the Profile that I use for everyday surfing. Not recommended by the developers of NoScript.

more options

It is also possible that JavaScript is blocked otherwise and that you get a version of the page that doesn't use scripts (i.e similar to a <noscript> tag).

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window