Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No primary email address field option showing when I try to import from Outlook 16 .csv file

  • 4 replies
  • 0 have this problem
  • 33 views
  • Last reply by david

more options

When I try and import my contacts from Outlook 2016 via a .csv, Thunderbird does not show an option for primary email. The result is that it imports all the info EXCEPT the primary email.

What am I missing here (except, of course, I'm missing the option for importing the primary email!).

Thank you.

When I try and import my contacts from Outlook 2016 via a .csv, Thunderbird does not show an option for primary email. The result is that it imports all the info EXCEPT the primary email. What am I missing here (except, of course, I'm missing the option for importing the primary email!). Thank you.
Attached screenshots

Chosen solution

Okay, Your solution did work, I just didn't understand it at first!

Adding the "Primary Email" in the Outlook.csv first line added "Primary Email" in the Thunderbird list, as you said it would (that was the bit I didn't understand).

However, I had already played with the "Address Book Field" drop-downs for other things in that list, like Email 2 for instance, and so I had to uncheck those so that I could correct "Address Book Field" for "Primary Email" - now it's all good! thank you!

Read this answer in context 👍 0

All Replies (4)

more options

I suggest possibly editing the first line of your CSV, assuming it has header info. Change the name of the column for primary email to be Primary Email and I think you will be successful. I duplicated the problem to test it, and 'Primary Email' is an option on the import.

Helpful?

more options

Hi, David, Yes and no. It moves the solution a little closer.

I created multiple copies of my .csv one after the other, because there are multiple headers with the word :"E-mail" in them.

One of the "E-mail" columns has only the email address, another has the "display as" info.

No matter what I do - change the first line column header in turn, or delete the "display as" column, nothing gets only the email address in the outlook profile "email" In fact, when I renamed the column with only the email to Primary Email" and deleted the "display as" column, it didn't pull over any email addresses. What it will take - and only the info there - is the "display as" and put that in as the email address. That "display as" info looks like this in Thunderbird in the "email addresses" box:

office@somewhere.org %SMTP %Lizzie Borden(office@somewhere.org)

Helpful?

more options

Chosen Solution

Okay, Your solution did work, I just didn't understand it at first!

Adding the "Primary Email" in the Outlook.csv first line added "Primary Email" in the Thunderbird list, as you said it would (that was the bit I didn't understand).

However, I had already played with the "Address Book Field" drop-downs for other things in that list, like Email 2 for instance, and so I had to uncheck those so that I could correct "Address Book Field" for "Primary Email" - now it's all good! thank you!

Helpful?

more options

You're very welcome .

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.