Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to have a copy of EVERY sent email placed in my Local sent folder? Replies to received emails are NOT going there. Original emails are.

  • 6 replies
  • 9 have this problem
  • 148 views
  • Last reply by DougHall

more options

I use Thunderbird as my email client on a Windows 7 system. Xfinity (Comcast) is my ISP and my email account there is IMAP. In Thunderbird Account Settings, Copies & Folders tab, I have set it so a copy of sent messages should be placed in my LOCAL Sent folder.

When I write an original message and send it, the copy is placed there correctly.

BUT when I reply to a received email and send the reply, it is NOT placed in the Local Sent folder. Instead the copy is placed in the Xfinity Server's Sent folder. I need ALL of my sent messages, whether originals or replies to be placed in the same Local Sent folder. How do I do that?

I use Thunderbird as my email client on a Windows 7 system. Xfinity (Comcast) is my ISP and my email account there is IMAP. In Thunderbird Account Settings, Copies & Folders tab, I have set it so a copy of sent messages should be placed in my LOCAL Sent folder. When I write an original message and send it, the copy is placed there correctly. BUT when I reply to a received email and send the reply, it is NOT placed in the Local Sent folder. Instead the copy is placed in the Xfinity Server's Sent folder. I need ALL of my sent messages, whether originals or replies to be placed in the same Local Sent folder. How do I do that?

Chosen solution

Wow. A brilliant work around. Thank you.

I have set it up as you instructed and tested it as instructed. The test was done from my Thunderbird on my Windows PC.

It worked like a charm. Now I will be able to keep copies of all sen emails indefinitely.

I greatly appreciate the time and effort you put in to help me with this. I didn't even know about the Message Filters options.

Strange, though, that Mozilla's code somehow treats original messages and replies differently regarding where they should be placed when sent. Your suggestion solved the problem.

Read this answer in context 👍 0

All Replies (6)

more options

are all the emails belonging to one identity? Or is the server picking up mail from a number of email addresses

more options

Yes. All emails are one identity. There is only one email address.

As best I can tell, the problem seems to be with Thunderbird. It does place in my Local Sent folder a copy of those emails that I start by clicking on the "Write" button, write my message, and then click on "Send". But when I read an email and click on the "Reply" button, write my reply, and then "Send" the copy is NOT placed in my Local Sent folder. Instead a copy is placed in my Xfinity Sent folder.

more options

Can you clarify what is the reason for not using the imap mail account 'Sent' folder for all sent emails? Then they will be stored all together.

Why must all sent emails be stored in 'Local Folders'? After all, all emails are stored on the server.

Would a pop mail account be better than an imap? then all emails will be on your computer as there is no synchronising of folders.

Please advise the forum... do you only download headers which retrieve emails when you click to open or do you download/synchronise all emails so they are actually on your computer?

I'm thinking that because you are 'Replying' that this creates a link with a server stored email, so the reply must also be on server...maybe!??

Check this next bit and report back on results... Make hidden files and folders visible:

  • Help > Troubleshooting Information
  • click on 'Open Folder'
  • click on 'ImapMail' folder
  • click on 'imap mail account name' folder

Q: Do you have both 'Inbox'(no extension) mbox file and 'Inbox.msf' file (and same for all your other subscribed folders ) in the profile folders or only .msf files ?

more options

Toad Hall, thank you for your reply and questions. Here are my replies.

1) My internet provider (Comcast) deletes emails in the Imap Sent folder on its server after a period of time. It does the same with the Imap Trash folder on its server. There is no "keep indefinitely" option. I want to keep all of my sent messages an indefinite period of time - maybe 20+ years. I can do that if I store them in a local folder on my computer. I have been able to do that with deleted messages: save them to my local Trash folder. And I have been able to do that with the messages I send as original messages to a recipient. But I have not been able to do that with messages that are replies to messages I have received. Those go only to the Comcast server's Sent folder, not to my local Sent folder.

2) I have three devices accessing my email account - my phone (Android), my tablet (Android) and my home-office computer (Windows). At one time, before I had the phone and tablet, I did use POP. That worked fine. But I need to keep the three devices in sync, so switched to Imap.

3) My received emails' headers are downloaded. When I click on one, the full email is downloaded. I then reply to that email that is then in my local Inbox.

4) I have 2 mail account folders imap.comcast.net (last modified date of 12/22/2017) & imap.comcast-1.net (last modified date of 10/1/2016.

Inside imap.comcast.net there is INBOX (no extension) and INBOX.msf (both with last modified date of today, 12/31/2017).

There is a Sent.msf (but no Sent without extension) with a last modified date of 11/17/2015. There is also a Sent-1 (no extension) and Sent-1.msf (both with (both with last modified date of today, 12/31/2017)

Evidently the system is using the Sent-1 files in the imap.comcast.net folder.

more options

I've just performed a test on my imap gmail account and I believe this workaround will get exactly what you need.

In Account Settings > Copies & Folders, I have it set up to save copies in the imap Sent folder. This obviously stores emails on the server.

I created a Message Filter for the imap gmail account, but you would select comcast. See filter details at end of this comment.

I then sent a new Write email from gmail imap account another of my accounts (not a gmail account). The 'Sent' email was stored on imap sent folder as expected. However, the filter ran immediately upon sending and put a copy of it into the Sent folder in Local Folders.

I then replied to get email back into the imap gmail account. Then I selected the email and used the 'Reply' button and repeated a send. The 'Replied' 'Sent' email was stored on imap sent folder as expected and also a copy was stored in the Sent folder in Local Folders.

So I suggest you set up the Account Settings to use the imap Sent folder and also set up a Message Filter to act upon sending emails to store a copy in the Local Folders. This way should get you all copies of sent mail stored locally regardless of whether a new Write message or a 'Replied' one.

This is the Message Filter Settings:

  • 'Menu icon' > 'Message Filters' > 'Message Filters'
  • Filters for: select imap comcast mail account
  • click on 'New' to create a new filter
  • Filter Name: 'Creating copies of Sent'

Apply Filter When:

  • select checkbox for 'After sending' (uncheck all the others)
  • select 'Match all of the following'
  • 'FROM' 'contains' type your email address

Perform these actions:

  • 'Copy message to' choose the 'Sent on Local Folders'
  • click on OK
  • make sure the 'Creating copies of Sent' filter checkbox is enabled


Please report back on results.

more options

Chosen Solution

Wow. A brilliant work around. Thank you.

I have set it up as you instructed and tested it as instructed. The test was done from my Thunderbird on my Windows PC.

It worked like a charm. Now I will be able to keep copies of all sen emails indefinitely.

I greatly appreciate the time and effort you put in to help me with this. I didn't even know about the Message Filters options.

Strange, though, that Mozilla's code somehow treats original messages and replies differently regarding where they should be placed when sent. Your suggestion solved the problem.