Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell check keeps turning itself off... ??

  • 8 replies
  • 48 have this problem
  • 2 views
  • Last reply by uplinktruck

more options

I'm on the latest FF and have "Check my spelling as a type" checked in Options. However, the spell checker seems to not work properly. When I right click in the text box, there is no check mark next to "Check spelling." I have to click "Check spelling" in order to turn it on. Once I do this, the check mark is there and it works fine. Ideas?

All Replies (8)

more options

Check the setting: Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"


How do I use the Firefox spell checker? http://kb.mozillazine.org/Dictionaries http://kb.mozillazine.org/Spell_checking

more options

I've noticed this lately, too. I have the global spellcheck on. However, I find that "Check Spelling" is not checked on the right-click dialog box while typing on a website message board. I enable it, but the next time I go to the site, it's disabled again.

Very frustrating.

Modified by michiganstate4ever

more options

It is possible for websites to disable spell checking via a spellcheck="false" attribute.

You can see that on the Google Translate page in the left pane.

more options

No. It works with Chrome and IE--and it used to work fine with Firefox. I've just noticed, too, that it seems at times I have to enable "Check Spelling" for every text box I type into--not just leaving the site.

Again, frustrating. I like really like Firefox--their extensions are the best--but I hate typing errors.

Thanks for trying.

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Thanks for the response. I tried safe mode, and the "check spelling" still goes off.

more options

I'm also getting this problem on 64-bit Firefox 11 on Linux. I think that the problem started when I switched the dictionary from US English to Canadian English, but that could just be a co-incidence.

EDIT: Well, I just checked and I notice that, while spellcheck itself stays enabled, the dictionary is randomly set to NULL (I mean that I suddenly find myself with no dictionary selected).

Modified by Exuberance

more options

Got the same problem. Seems to have started with the update to 11.0. Very frustrating.